cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

soleous
Journeyman III

Ubuntu AMDGPU 20.50 - ring uvd test failed

Hi Guys,

I am getting errors with the new 20.50 drivers on Ubuntu 20.04.2, kernel 5.4.0-67 and 5.8.0-45.  It is a virtual machine on ESXi, however, it functions within windows and with the stock drivers on ubuntu, but I'm trying to install 20.50, therefore I am not pointing my finger at the ESXi configuration at this point.

I get several lines of post, then it freezes just before "Initialized amdgpu 3.40.0 20150101".  The error is:

[ 5.230556] amdgpu 0000:13:00.0: [drm:amdgpu_ib_ring_tests [amdgpu]] *ERROR* IB test failed on uvd (-110).
[ 5.342533] [drm:amdgpu_device_delayed_init_work_handler [amdgpu]] *ERROR* ib ring test failed (-110).

"dmesg | grep -E 'drm|amdgpu'" below:

Spoiler
[ 0.000000] Command line: BOOT_IMAGE=/vmlinuz-5.8.0-45-generic root=/dev/mapper/ubuntu--vg-ubuntu--lv ro radeon.cik_support=0 radeon.si_support=0 amdgpu.cik_support=1 amdgpu.dc=1
[ 0.035434] Kernel command line: BOOT_IMAGE=/vmlinuz-5.8.0-45-generic root=/dev/mapper/ubuntu--vg-ubuntu--lv ro radeon.cik_support=0 radeon.si_support=0 amdgpu.cik_support=1 amdgpu.dc=1
[ 1.466426] [drm] amdgpu kernel modesetting enabled.
[ 1.466433] [drm] amdgpu version: 5.9.10.20.50
[ 1.466434] [drm] OS DRM version: 5.8.0
[ 1.466552] amdgpu: CRAT table not found
[ 1.466556] amdgpu: Virtual CRAT table created for CPU
[ 1.466567] amdgpu: Topology: Add CPU node
[ 1.469125] amdgpu 0000:13:00.0: vgaarb: deactivate vga console
[ 1.469652] [drm] initializing kernel modesetting (HAWAII 0x1002:0x67B1 0x1462:0x2015 0x80).
[ 1.469657] amdgpu 0000:13:00.0: amdgpu: Trusted Memory Zone (TMZ) feature not supported
[ 1.469782] [drm] register mmio base: 0xFDB00000
[ 1.469784] [drm] register mmio size: 262144
[ 1.469797] [drm] PCIE atomic ops is not supported
[ 1.469833] [drm] add ip block number 0 <cik_common>
[ 1.469835] [drm] add ip block number 1 <gmc_v7_0>
[ 1.469836] [drm] add ip block number 2 <cik_ih>
[ 1.469838] [drm] add ip block number 3 <gfx_v7_0>
[ 1.469839] [drm] add ip block number 4 <cik_sdma>
[ 1.469840] [drm] add ip block number 5 <powerplay>
[ 1.469842] [drm] add ip block number 6 <dm>
[ 1.469843] [drm] add ip block number 7 <uvd_v4_2>
[ 1.469845] [drm] add ip block number 8 <vce_v2_0>
[ 1.469919] amdgpu 0000:13:00.0: BAR 6: can't assign [??? 0x00000000 flags 0x20000000] (bogus alignment)
[ 1.645305] amdgpu 0000:13:00.0: amdgpu: Fetched VBIOS from ROM
[ 1.645475] amdgpu: ATOM BIOS: MS-V30823-F5
[ 1.645506] amdgpu 0000:13:00.0: amdgpu: PCI CONFIG reset
[ 1.645509] amdgpu 0000:13:00.0: amdgpu: GPU pci config reset
[ 1.645701] [drm] GPU posting now...
[ 1.652445] [drm] vm size is 64 GB, 2 levels, block size is 10-bit, fragment size is 9-bit
[ 1.652484] amdgpu 0000:13:00.0: amdgpu: VRAM: 8192M 0x000000F400000000 - 0x000000F5FFFFFFFF (8192M used)
[ 1.652487] amdgpu 0000:13:00.0: amdgpu: GART: 1024M 0x000000FF00000000 - 0x000000FF3FFFFFFF
[ 1.652496] [drm] Detected VRAM RAM=8192M, BAR=256M
[ 1.652497] [drm] RAM width 512bits GDDR5
[ 1.652632] [drm] amdgpu: 8192M of VRAM memory ready
[ 1.652634] [drm] amdgpu: 8192M of GTT memory ready.
[ 1.652637] [drm] GART: num cpu pages 262144, num gpu pages 262144
[ 1.653294] [drm] PCIE GART of 1024M enabled (table at 0x000000F400000000).
[ 1.654203] amdgpu: [powerplay] hwmgr_sw_init smu backed is ci_smu
[ 1.654277] [drm] Found UVD firmware Version: 1.64 Family ID: 9
[ 1.654896] [drm] Found VCE firmware Version: 50.10 Binary ID: 2
[ 1.655567] [drm] enabling PCIE gen 2 link speeds, disable with amdgpu.pcie_gen2=0
[ 1.903372] amdgpu: [powerplay] smc is running, no need to load smc firmware
[ 1.906653] [drm] dce110_link_encoder_construct: Failed to get encoder_cap_info from VBIOS with error code 4!
[ 1.906672] [drm] dce110_link_encoder_construct: Failed to get encoder_cap_info from VBIOS with error code 4!
[ 1.906688] [drm] dce110_link_encoder_construct: Failed to get encoder_cap_info from VBIOS with error code 4!
[ 1.906699] [drm] Display Core initialized with v3.2.114!
[ 1.929237] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[ 1.965940] [drm] UVD initialized successfully.
[ 2.085995] [drm] VCE initialized successfully.
[ 2.091678] kfd kfd: amdgpu: Allocated 3969056 bytes on gart
[ 2.094636] amdgpu: SW scheduler is used
[ 2.094651] amdgpu: Virtual CRAT table created for GPU
[ 2.094769] amdgpu: Topology: Add dGPU node [0x67b1:0x1002]
[ 2.094773] kfd kfd: amdgpu: added device 1002:67b1
[ 2.094776] amdgpu 0000:13:00.0: amdgpu: SE 4, SH per SE 1, CU per SH 11, active_cu_number 40
[ 2.095817] [drm] fb mappable at 0xC03EB000
[ 2.095820] [drm] vram apper at 0xC0000000
[ 2.095821] [drm] size 5242880
[ 2.095822] [drm] fb depth is 24
[ 2.095824] [drm] pitch is 5120
[ 2.095898] fbcon: amdgpudrmfb (fb0) is primary device
[ 2.167814] amdgpu 0000:13:00.0: fb0: amdgpudrmfb frame buffer device
[ 2.188749] [drm] Initialized amdgpu 3.40.0 20150101 for 0000:13:00.0 on minor 0
[ 4.387838] systemd[1]: Condition check resulted in Load Kernel Module drm being skipped.
[ 5.230556] amdgpu 0000:13:00.0: [drm:amdgpu_ib_ring_tests [amdgpu]] *ERROR* IB test failed on uvd (-110).
[ 5.342533] [drm:amdgpu_device_delayed_init_work_handler [amdgpu]] *ERROR* ib ring test failed (-110).
[ 5.346736] snd_hda_intel 0000:13:00.1: bound 0000:13:00.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])

Any pointers would be greatly appreciated.

Thanks,

EDIT: The card is an R9 390.

0 Likes