cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

jerryjrowe
Journeyman III

Ubuntu 20.04 + Radeon RX 570 = visual artifacts and crashing

I would love to have some help with this issue.

It's a new system; everything should be working fine.  And it was, for some days.

I am experiencing the same sort of problems as have been mentioned in [other posts][1].

When I plug anything into my Radeon RX 570 video card, I get visual artifacts and freezes usually within minutes of working. (Most notably, my 2 monitors.)

I chose that post as an example because it has representative examples of what I am experiencing; especially the third picture.

Initially I had no problems. Then I tried to install "League of Legends" via Lutris, and got a crash. (No overheating, though. Nothing ever went above 50C.) I have since uninstalled and reformatted (see below), but nothing has helped. If I try to use the video card, I get overwhelming artifacts and often freezes. (Although if YouTube is on, it continues playing audio. And occasionally I will see something resembling a mouse pointer, but I cannot click on anything or open a terminal or issue a command via alt+F2.

Just before the overwhelming artifacts, there is usually a bit of screen tearing in the upper left of my left monitor for 3-10 seconds. I cannot click on anything during this time.

Things I have tried / verified:
1. I am almost certainly not overheating. No fans are ever blocked, and "System Profiler and Benchmark" (as well as PSensor) tell me that nothing that they are able to detect (in either the CPU or GPU) is ever going over even 50C. (Usually everything is around 35C.) I have no reason to distrust them. PSensor doesn't detect the GPU, but I mention it anyway.

2. I am not overclocking anything, according to the BIOS.

3. It almost certainly isn't the cables. The cables from the card to the monitor are brand new DisplayPort cables from Amazon Basics, and as I mention in #7, they work fine as long as they're not plugged into the card. This tells me it's the card, not those cables. As for the card itself and the cables in the case, I got the satisfying click from every cable that plugs in. Also, the cards worked without issue for a few days, whereas if it had been a seating issue, it seems like it ought to have been a problem nonstop from the moment I began to use my computer.

4. I have tried multiple reformats / clean installs of 20.04 and 20.10. This has not helped.

5. As per [this guide][2], I've installed the PPA third-party repository and the proprietary AMDGPU-PRO drivers. This did not help. I also got the drivers [directly from AMD][3], and followed their instructions. This did not help.

6. It seems that I can make this happen on command (rather than waiting) by letting the screen turn off and then back on, as per the Settings > Power > Blank Screen option. It does seem helpful to know that it is, at least, repeatable in this fashion.

7. If I plug my monitors only into the motherboard, everything works fine with the onboard Intel graphics chipset. It appears that the amdgpu drivers are loading and that the card is there, but it at least doesn't crash my system (so far).


Here's a link to my hardware in use right now:

https://linux-hardware.org/?probe=8118fd6863

Because of what I have read in similar threads, I am going to preemptively post the terminal results of some commands here:

The results of:
sudo lshw -C memory

*-firmware
description: BIOS
vendor: American Megatrends Inc.
physical id: 0
version: 0811
date: 06/12/2020
size: 64KiB
capacity: 16MiB
capabilities: pci upgrade shadowing cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int14serial int17printer acpi usb biosbootspecification uefi
*-memory
description: System Memory
physical id: 40
slot: System board or motherboard
size: 32GiB
*-bank:0
description: [empty]
physical id: 0
slot: ChannelA-DIMM1
*-bank:1
description: DIMM DDR4 Synchronous 2133 MHz (0.5 ns)
product: F4-3200C16-16GVK
vendor: G-Skill
physical id: 1
serial: 00000000
slot: ChannelA-DIMM2
size: 16GiB
width: 64 bits
clock: 2133MHz (0.5ns)
*-bank:2
description: [empty]
physical id: 2
slot: ChannelB-DIMM1
*-bank:3
description: DIMM DDR4 Synchronous 2133 MHz (0.5 ns)
product: F4-3200C16-16GVK
vendor: G-Skill
physical id: 3
serial: 00000000
slot: ChannelB-DIMM2
size: 16GiB
width: 64 bits
clock: 2133MHz (0.5ns)
*-cache:0
description: L1 cache
physical id: 4d
slot: L1 Cache
size: 512KiB
capacity: 512KiB
capabilities: synchronous internal write-back unified
configuration: level=1
*-cache:1
description: L2 cache
physical id: 4e
slot: L2 Cache
size: 2MiB
capacity: 2MiB
capabilities: synchronous internal write-back unified
configuration: level=2
*-cache:2
description: L3 cache
physical id: 4f
slot: L3 Cache
size: 16MiB
capacity: 16MiB
capabilities: synchronous internal write-back unified
configuration: level=3
*-memory UNCLAIMED
description: Memory controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 1f.2
bus info: pci@0000:00:1f.2
version: 00
width: 32 bits
clock: 33MHz (30.3ns)
configuration: latency=0
resources: memory:7fd20000-7fd23fff

 


The results of:
free -h

total used free shared buff/cache available
Mem: 31Gi 2.4Gi 26Gi 659Mi 2.2Gi 27Gi
Swap: 2.0Gi 0B 2.0Gi


The results of:
sysctl vm.swappiness


vm.swappiness = 60

 

The results of:
sudo dmidecode -s bios-version

0811

(This was a self-assembled computer from parts that Computer Part Picker verified were indeed compatible with each other and Ubuntu.)


Please, help.


[1]: https://askubuntu.com/questions/1265799/ubuntu-20-04-freezes-with-visual-artifacts
[2]: https://linuxconfig.org/amd-radeon-ubuntu-20-04-driver-installation
[3]: https://www.amd.com/en/support/graphics/radeon-500-series/radeon-rx-500-series/radeon-rx-570

 

I do not know how to fix this problem.  I'm not even sure what options there are left to try. (It seems like I should be able to force, I dunno, a firmware update or reinstall? But I have not been able to locate any information on that.)

 

And thus, I am here. I would really, really appreciate help.

0 Likes