Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Ubuntu 18.04: amdgpu-pro-21.10 driver fails to recognize s9x00 boards but some work OK

Have a single s9100 and several s9000 cards on Ubuntu 18.04.4

Downloaded the amdgpu-pro-21.10-1263778-ubuntu-18.04.tar which seemed to install just fine.  clinfo shows problems with this 21q2 driver.

s9000 with 6gb ram  recognized incorrectly at  ATI FirePro V (FireGL V) Graphics Adapter with 3gb ram.  My app fails with error "unable to get host memory" or something like that as it expected 6gb.

s9100 with 12gb ram is recognized as AMD Radeon FirePro W8100.  My app runs correctly and sees the 12gb.

These boards worked fine on Ubuntu 16.04 and an upgrade to 18.04 a year or so ago with an older firepro driver.  I can't seem to get it to work with a clean install of 18i.04 and that 21q2 driver

3 Replies

AMD Moderator @fsadough the expert on Professional GPU card can assist you with your problem.

Went to the Release Notes and here are the compatible GPU cards for this version:

Screenshot 2021-09-21 175910.pngScreenshot 2021-09-27 115119.png



after upgrading to 18.04.6 (which didnt work either) I tried the following two drivers


Neither install properly due to some kernel deficiencies


Going to download 16.04 since that was proven to work with s9000.  I don't need the latest & greatest Ubuntu.


  1. What is the kernel version?
  2. What are the BIOS Part Numbers of the GPUs?