Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Ubuntu 18.04 AMDGPU drivers 19.10 libllvm7.1 packages not installing

Hi everyone,

I've been trying to update my drivers from 18.50 to 19.10 on a system dual-booting Windows 10 and Ubuntu 18.04.2 on the Linux side.  Already, due to kernel version updates, I had to do so from the command line before even being able to boot into a GUI desktop just so it could build a working setup for the kernel versions I had.  Then, once that was done, I tried making sure everything was properly updated by re-installing, and I am encountering this error:

Get:1 file:/var/opt/amdgpu-pro-local ./ libllvm7.1-amdgpu 1:7.1-785425 [12.1 MB]
Get:2 file:/var/opt/amdgpu-pro-local ./ libllvm7.1-amdgpu 1:7.1-785425 [13.5 MB]
(Reading database ... 216546 files and directories currently installed.)
Preparing to unpack .../libllvm7.1-amdgpu_7.1-785425_amd64.deb ...
Unpacking libllvm7.1-amdgpu:amd64 (1:7.1-785425) ...
dpkg: error processing archive /var/opt/amdgpu-pro-local/./libllvm7.1-amdgpu_7.1-785425_amd64.deb (--unpack):
trying to overwrite '/opt/amdgpu/lib/x86_64-linux-gnu/', which is also in package libllvm7.0-amdgpu:amd64 1:7.0-756341
Preparing to unpack .../libllvm7.1-amdgpu_7.1-785425_i386.deb ...
Unpacking libllvm7.1-amdgpu:i386 (1:7.1-785425) ...
dpkg: error processing archive /var/opt/amdgpu-pro-local/./libllvm7.1-amdgpu_7.1-785425_i386.deb (--unpack):
trying to overwrite '/opt/amdgpu/lib/i386-linux-gnu/', which is also in package libllvm7.0-amdgpu:i386 1:7.0-756341
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

This is when I was attempting to install the two packages that kick back as packages that are unmet dependencies for about 13 other files.  The .deb packages are sitting there just waiting to be installed but even attempts to manually/directly install just those packages have all failed.  It is as if my system simply just will not read them.  I have also tried all suggestions I could find online to solve the "error code (1)" issue, short of purging the packages (since I don't believe that would do anything good), to no avail.  I cannot even purge anything related to the drivers and try again since it will continually just kick back the unmet dependencies.  How can I install these packages so that I can properly install the drivers?

0 Replies