cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

fatecasino
Journeyman III

ubuntu 18.04.5(hwe) + amdgpu-pro: No OpenCL platforms found No avaiable GPUs for mining.

After some many days I managed to install amdgpu-pro in ubuntu 18.04.5 HWE with an AMD R9 390x card. The main trick to do so was to install 20.40 amd drivers with kernel 5.4.0-54-generic.
When I try to run PhoenixMiner or Claymore I get:
No CUDA driver found
No OpenCL platforms found
No avaiable GPUs for mining. Please check your drivers and/or hardware
When I run gpu-manager I get:
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
can't access /run/u-d-c-nvidia-was-loaded file
can't access /opt/amdgpu-pro/bin/amdgpu-pro-px
Looking for nvidia modules in /lib/modules/5.4.0-54-generic/updates/dkms
Looking for amdgpu modules in /lib/modules/5.4.0-54-generic/updates/dkms
Found amdgpu module: amdgpu.ko
Is nvidia loaded? no
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is intel loaded? no
Is radeon loaded? no
Is radeon blacklisted? yes
Is amdgpu loaded? yes
Is amdgpu blacklisted? no
Is amdgpu versioned? yes
Is amdgpu pro stack? yes
Is nouveau loaded? yes
Is nouveau blacklisted? no
Is nvidia kernel module available? no
Is amdgpu kernel module available? yes
Vendor/Device Id: 1002:67b0
BusID "PCI:1@0:0:0"
Is boot vga? yes
Found "/dev/dri/card0", driven by "amdgpu"
output 0:
card0-DVI-D-1
output 1:
card0-DP-2
Number of connected outputs for /dev/dri/card0: 2
Skipping "/dev/dri/card0", driven by "amdgpu"
Skipping "/dev/dri/card0", driven by "amdgpu"
Skipping "/dev/dri/card0", driven by "amdgpu"
Does it require offloading? no
last cards number = 1
I couldn't open /var/lib/ubuntu-drivers-common/last_gfx_boot for writing.
Error: can't write to /var/lib/ubuntu-drivers-common/last_gfx_boot
Why am I getting this triple Skipping "/dev/dri/card0", driven by "amdgpu" message? I tried to disable onboard graphics but nothing changed. Is there any suggestion? How can I overcome this?
 
xrandr --listproviders:
Providers: number : 1
Provider 0: id: 0x5a cap: 0x9, Source Output, Sink Offload crtcs: 6 outputs: 5 associated providers: 0 name:AMD Radeon (TM) R9 390 Series @ pci:0000:01:00.0
lspci -k | grep -EA3 'VGA|Display'|:
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii XT / Grenada XT [Radeon R9 290X/390X] (rev 80)
Subsystem: PC Partner Limited / Sapphire Technology Grenada XT2 [Radeon R9 390X]
Kernel driver in use: amdgpu
Kernel modules: radeon, amdgpu
inxi -Fzx :
Graphics: Card: Advanced Micro Devices [AMD/ATI] Hawaii XT / Grenada XT [Radeon R9 290X/390X]
bus-ID: 01:00.0
Display Server: x11 (X.Org 1.20.8 )
drivers: fbdev,ati (unloaded: modesetting,vesa,radeon)
Resolution: 1680x1050@59.88hz, 1600x900@60.00hz
OpenGL: renderer: AMD Radeon R9 390 Series
version: 4.6.14756 20.40 Direct Render: Yes
lshw -c video:
*-display
description: VGA compatible controller
product: Hawaii XT / Grenada XT [Radeon R9 290X/390X]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:01:00.0
version: 80
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
configuration: driver=amdgpu latency=0
resources: irq:35 memory:c0000000-cfffffff memory:df800000-dfffffff ioport:ee00(size=256) memory:fde80000-fdebffff memory:c0000-dffff
0 Likes