Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Ubuntu 16.04 RX 560 AMDGPU-Pro 17.40 not working


I am trying to use a RX560 with Ubuntu 16.04.3 64bit. First off, I could not get the default Ubuntu installer to work, I had to edit a init kernel options to add nomodeset and then it started up so I could install Ubuntu. Even after installing and updating my Ubuntu, I still have to set nomodeset in my /etc/default/grub file as part of the kernel options for boot.

If I dont set nomodeset, shortly after GRUB menu selection is made/done it goes to blank screen and freezes.

I came across a post on these forums suggesting to use Linux kernel : 4.8.0-58-generic

I have tried the following kernels all of which experience the same problem:

4.13.0-32-generic (lastest kernel introduced through updates)

4.10.0-28-generic (kernel installed by installer)

4.8.0-58-generic (recommened kernel that user said worked for him)

So with the < 4.10 versions, I could not run the AMGGPU-Pro 17.40 installation successfully (by executing amdgpu-pro-install). It would fail when compiling the module for the kernel but continue installing everything. Driver not working after reboot.

When I switched to 4.8.0-58, I could successfully install without errors, but I still have to keep the nomodeset option for my kernel and the driver is still not working after the reboot.

My kernel line ends with:

<pre>BOOT_IMAGE=/boot/vmlinuz-4.8.0-58-generic root=UUID=4a95b337-866c-40bd-9e47-8cb71ee34195 ro nomodeset radeon.modeset=1 vt.handoff=7</pre>

I dont think radeon.modeset is doing anything here.

So at this moment here is the output of my glxinfo command:


name of display: :0.0

Error: couldn't find RGB GLX visual or fbconfig


Output of Xorg.0.log:


[    39.732] (II) LoadModule: "glx"</br>

[    40.865] (II) Loading /opt/amdgpu-pro/lib/xorg/modules/extensions/</br>

[    45.325] (II) Module glx: vendor="X.Org Foundation"</br>

[    45.325] compiled for 1.18.0, module version = 1.0.0</br>

[    45.325] ABI class: X.Org Server Extension, version 9.0</br>

[    45.325] (EE) glx: module ABI major version (9) doesn't match the server's version (10)</br>

[    45.325] (II) UnloadModule: "glx"</br>

[    45.325] (II) Unloading glx</br>

[    45.362] (EE) Failed to load module "glx" (module requirement mismatch, 0)</br>



[    45.537] (II) modesetting: Driver for Modesetting Kernel Drivers: kms</br>

[    45.537] (II) FBDEV: driver for framebuffer: fbdev</br>

[    45.537] (II) VESA: driver for VESA chipsets: vesa</br>

[    45.538] (EE) open /dev/dri/card0: No such file or directory</br>

[    45.538] (WW) Falling back to old probe method for modesetting</br>

[    45.538] (EE) open /dev/dri/card0: No such file or directory</br>

[    45.538] (II) Loading sub module "fbdevhw"</br>

[    45.538] (II) LoadModule: "fbdevhw"</br>

[    45.538] (II) Loading /usr/lib/xorg/modules/</br>

[    45.538] (II) Module fbdevhw: vendor="X.Org Foundation"</br>

[    45.538] compiled for 1.19.5, module version = 0.0.2</br>

[    45.538] ABI class: X.Org Video Driver, version 23.0</br>

[    45.538] (**) FBDEV(1): claimed PCI slot 2@0:0:0</br>

[    45.538] (II) FBDEV(1): using default device</br>

[    45.538] (WW) Falling back to old probe method for vesa</br>

[    45.538] (EE) Screen 0 deleted because of no matching config section.</br>

[    45.538] (II) UnloadModule: "modesetting"</br>



Can anyone help please? According to the AMDGPU-Pro download page and instructions, I have the right distro and driver that is supported and/or compatible yet I am unable to get anything working.

1 Reply
Journeyman III

I have the same problem.

$ lspci -k | grep -EA2 'VGA|3D'

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Device 67ff (rev cf)

Subsystem: Micro-Star International Co., Ltd. [MSI] Device 8a91

Kernel modules: amdgpu

$ dpkg -l amdgpu-pro


| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend

|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)

||/ Name           Version      Architecture Description


ii  amdgpu-pro     17.40-492261 amd64        Meta package to install amdgpu Pr

System will not boot to graphics.

I followed the directions at

  How-To Install/Uninstall AMD Radeon™ Software AMDGPU-PRO Driver for Linux® on an Ubuntu System

Do I need to remove the RX 560 and go to NVIDIA? Some help would be appreciated.