cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

johna1954
Journeyman III
Journeyman III

Trying to install Radeon WX3100 card on Debian 9 Stretch

Hi everyone, I hope that you will be able to help me install my new WX3100 card.

After several days following suggestions on Debian forums,  I came across your forum and a post which was similar to my problem when trying to install the amdgpu-pro driver on Debian 9. (amdgpu-pro-18.20-621984)

The error message was 'Unsupported O/S' and the post I came across suggested editing the Install file to change 'Ubuntu' to 'Debian'. Did this but there were problems with dependencies:

Package: *amdgpu*

Pin: release o=AMD

Pin: version *-621984

Pin-Priority: 1000

Package: *amdgpu*:i386

Pin: release o=AMD

Pin: version *-621984

Pin-Priority: 1000

Reading package lists... Done

Building dependency tree     

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

amdgpu : Depends: libgl1-amdgpu-mesa-dri (= 1:18.0.0-621984) but it is not going to be installed

          Depends: libosmesa6-amdgpu (= 1:18.0.0-621984) but it is not going to be installed

          Depends: mesa-amdgpu-va-drivers (= 1:18.0.0-621984) but it is not going to be installed

          Depends: mesa-amdgpu-vdpau-drivers (= 1:18.0.0-621984) but it is not going to be installed

          Depends: mesa-amdgpu-omx-drivers (= 1:18.0.0-621984) but it is not going to be installed

amdgpu-lib32 : Depends: libdrm2-amdgpu:i386 (= 1:2.4.91-621984)

                Depends: libdrm-amdgpu-amdgpu1:i386 (= 1:2.4.91-621984)

                Depends: libllvm6.0-amdgpu:i386 (= 1:6.0-621984)

                Depends: libwayland-amdgpu-client0:i386 (= 1.14.0-621984)

                Depends: libwayland-amdgpu-server0:i386 (= 1.14.0-621984)

                Depends: libxatracker2-amdgpu:i386 (= 1:18.0.0-621984)

                Depends: libgbm1-amdgpu:i386 (= 1:18.0.0-621984)

                Depends: libegl1-amdgpu-mesa:i386 (= 1:18.0.0-621984)

                Depends: libegl1-amdgpu-mesa-drivers:i386 (= 1:18.0.0-621984)

                Depends: libwayland-amdgpu-egl1-mesa:i386 (= 1:18.0.0-621984)

                Depends: libgles1-amdgpu-mesa:i386 (= 1:18.0.0-621984)

                Depends: libgles2-amdgpu-mesa:i386 (= 1:18.0.0-621984)

                Depends: libglapi-amdgpu-mesa:i386 (= 1:18.0.0-621984)

                Depends: libgl1-amdgpu-mesa-glx:i386 (= 1:18.0.0-621984)

                Depends: libgl1-amdgpu-mesa-dri:i386 (= 1:18.0.0-621984)

                Depends: libosmesa6-amdgpu:i386 (= 1:18.0.0-621984)

                Depends: mesa-amdgpu-va-drivers:i386 (= 1:18.0.0-621984)

                Depends: mesa-amdgpu-vdpau-drivers:i386 (= 1:18.0.0-621984)

amdgpu-pro-lib32 : Depends: libgl1-amdgpu-pro-glx:i386 (= 18.20-621984)

                    Depends: libegl1-amdgpu-pro:i386 (= 18.20-621984)

                    Depends: libgles2-amdgpu-pro:i386 (= 18.20-621984)

                    Depends: libgl1-amdgpu-pro-dri:i386 (= 18.20-621984)

                    Depends: libgbm1-amdgpu-pro:i386 (= 18.20-621984)

vulkan-amdgpu-pro:i386 : Depends: libc6:i386 (>= 2.17) but it is not installable

                          Depends: libgcc1:i386 (>= 1:3.3.1) but it is not installable

                          Depends: libstdc++6:i386 (>= 4.8) but it is not installable

                          Depends: wsa-amdgpu:i386 but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

Has anyone solved this problem, I am running Kernel 4.9 and all packages on the system are up to date.

Appreciate any help that you can offer.

Thanks

John

0 Kudos