Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


THREAD-LOCK, Cant install any amd driver, system freezes

I have 7850 HD and using windows 10AU

So yesterday infamous black-screen problem happened to me as well.

To briefly summerized,  Screen went blue while on playing and after windows 10 never  could be boot again, only black screen.

Formatted pc and make clean windows 10, but screen goes black immidiately after ati driver loads to os, Drivers wiped and re installed but in mid installing, screen goes black and so on.

Only way to break the black screen loop is go to safe mode, and wipe out amd drivers and switch to windows default driver. But problem returns while on driver installition.

Last state of overdrive was on, crimson 16.8 drivers was installed. (now even legacy CCC drivers could not be installed)

The only change before catastropic event was installing 16.7 drivers and enabling overdrive. (i had enable overdrive  time to time int the past with no problems)

Vbios reflashed with stock - no change.

Card is responsive with windows default driver. I managed to see thread_lock blue screen by enabling on board card with first priority then try to install amd.

For a quick search there seems to be tons of people having exact same issue, mostly on 270 or 370 series which are also superseed of 7850. Amd, please respond to us the fact that if our cards just get bricked or maybe by change your drivers manage to write corrupted information to some rewritable rom on card?

These people supported you for ages with buying your cards generations to generations, and i believe they deserve an proper answer from you!

3 Replies

Re: THREAD-LOCK, Cant install any amd driver, system freezes

Most 78xx series do not support Uefi, Check your mobo settings.

My OS is on MBR & card(7970) set to Uefi & legacy in mobo bios.

Also, what error shows in windows reliability history (not event viewer).

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3200c16d kit, Aorus nvme gen4 1tb, Nitro+RX6900XT, RM850.

Re: THREAD-LOCK, Cant install any amd driver, system freezes


I dont have any option to set card to uefi or legacy in bios. Mobo is asrock z77 extreme4 and yes my cards bios is legacy not uefi. Also i cleared cmos multiple times, and set bios to last good known settings but no change. I tried linux installing but it also gave radeon crash error while on boot.

Secondly i search past and recent post in forum there numerous people have exactly same situation with me. Two of them just openned topics about it. Even newer card owners report similar situations. I'm afraid this issue will quickly evolve to "black screen of death" chronic problem.

Anyway i'm gonna post reability monitor results as soon as i'm back in town but i hardly believe there will be anything there because some thread in device driver looks like causing deadlock or quickly eating all resource since there are not a single entry could be writen in evet log.

Adept II

Re: THREAD-LOCK, Cant install any amd driver, system freezes

have you tried putting card into a different machine to see if the other computer experiences the same problems? if it does, then the card maybe going bad. if it doesn't. it could be a host of things. like the hdd is going bad, or the drivers are corrupt. if you have a bad driver, it could potentially cause these problems. if i was you, i'd do a complete driver removal. i will post a link to the tool. even if for example, you uninstal driver from your graphics card settings and lets say you had an old card (different card on that hard drive.) or had corrupt drivers, the drivers can still linger on that hard drive. so you need to use this tool to completely remove the drive remnants. i had the same thing happen on a 380 card i had. i had an old 5750 on the machine, removed the drivers from ccc. and put new card in, put drivers on, and black screen would occasionally happen. and i kept getting blue screen of death. so after scouring the internet. i found out that drivers can remain on hd even with removing them manually from the gpu unistaller. i have also had this same exact problem with that same 380 on a different hd. the drivers became corrupt and i had to use this tool below to fix it. give it a try and tell me if it works.

Display Driver Uninstaller Download version