cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

emielscholte
Journeyman III

The compatibility checker is wrong?

So according to the compatibility checker my Asus ROG Strix RX Vega 56 does not meet the minimum requirements for 'old' games like AC Black Flag and Dishonored 2?? And a 5700XT does not meet the recommended requirements for Dishonored 2??

Anyone seen this before? This is in 20.4.2, but it did the same in 20.5.1.

AMD Compatibility.png

0 Likes
4 Replies
kingfish
Volunteer Moderator
Volunteer Moderator

Re: The compatibility checker is wrong?

Don't believe everything you read. Have you tried playing the games?

0 Likes
emielscholte
Journeyman III

Re: The compatibility checker is wrong?

Of course I don't believe that, the games play perfectly fine. I'm just wondering why the AMD software says this. It wasn't like that before.

0 Likes
silverarcher
Journeyman III

Re: The compatibility checker is wrong?

i have the same thing here with my asus ROG Strix rx vega64 and every thing runing normal, i have try to change for older drivers today and i got the same thing too ,so i see that it is from amd servers it self not in my or your gpu , but let .us wait my be they will fix it 

0 Likes
colesdav
MVP

Re: The compatibility checker is wrong?

Yeah AMD Compatibility Checker used to ask me to upgrade from RX Vega 64 Liquid to EOLed Radeon VII.
I got that recommendation fixed by filing AMD Reporting form.
It should only recommend GPUs you have a chance of buying new.

Then it started telling me to upgrade to an RX5700XT which is funny since that GPU is slower at 4K Ultra on a number of games.

Next thing it tells me I need to upgrade from a Ryzen 7 2700X to an R9 3950X 16 core 32 Thread Processor.

It is total Marketing rubbish.

I usually turn off the Gaming Advisor.

If you want to know what you need to run a game just look up the minimum and recommended Systems Requirements for the game or look up game reviews.