cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Waseem
Adept I

Text Select pointer goes to being white colored when hovering over black text

Hello, a couple of days ago, windows updates automatically installed a new AMD display driver on my laptop. Since then, the "Select Text" mouse pointer (which is the pointer that shows up when you hover over text) has been showing up as being white colored even when hovering over black text with a white background, which makes it very hard to tell where the mouse pointer is located at. However, if I move the mouse pointer a bit (while hovering over black text) and also just do a left click, the Text Select pointer goes back to being black colored.

Notes:

  • This is on Windows 11.
  • I clean installed Windows 11 and the issue still persists.
  • Driver version causing the issue: 31.0.12016.9
  • CPU: AMD Ryzen 5 5500U with integrated graphics
  • RAM: 8GB
45 Replies
NicholasFlamy
Journeyman III

I have the same issue on  2 devices that both have AMD GPUs and are running Windows 11. I fixed the issue before with the MPO disable but I have reinstalled Windows since then so I will have to redo that today.

PC 1: 5600X in MSI B450 with 6700XT running Windows 11
PC 2: 3600XT in MSI B550 (issue previously also occurred with Asus ROG B350) with 6600XT running Windows 11

Reading other threads about this problem, the common factor is either AMD CPU or AMD Graphics. I have AMD CPU+GPU. Someone had an AMD APU. Someone had an AMD APU with an NVIDIA GPU. Either it's CPU, or that person has their display hooked up to the motherboard and iGPU and maybe uses the GPU for specific programs.

0 Likes
NicholasFlamy
Journeyman III

I just had a big realization moment. I have dark mode on my PC and on Chrome. The text cursor is supposed to be black when the background is white and the text is black. It's supposed it be white when the background is black and the text is white. On websites with dark mode, my cursor is white so I can see it, on websites such as Google Docs, it seems like some system on the computer isn't realizing that even though the text in the URL bar of Chrome is white because I have dark mode, Google Docs has a white background with black text and needs a black cursor. Something isn't defining this when MPO is enabled but when disabled my cursor does what it's supposed to, white over the URL bar and on sites with dark mode and black on sites that have light mode such as Google Docs or this forum.

0 Likes
NicholasFlamy
Journeyman III

I have found somebody with an Intel i7-12700K and an AMD RX 6800 XT. This tells us for sure it's an AMD GPU issue and not a CPU issue. Maybe now we can have some more leverage.

0 Likes
ahsantariq
Adept I

@NicholasFlamy Is this issue exclusive to Darkmode?

I have an AMD CPU with integrated graphics and it has the same issue.

0 Likes

I think so.

0 Likes
dthanhvu
Journeyman III

Why haven't they fixed this error yet? I have replaced 3 VGA cards, hard drives and ram but it still doesn't work. and it was only completely normal when I installed version 22.1.2 , Please fix it AMD

0 Likes