Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Suddenly RX 580 cannot boot & Windows recognized it as RX470

Hello guys, I got some issue regarding my RX 580 8GB (XFX Radeon RX580 8G GDDR5) which suddenly that GPU cannot boot and Windows recognized it as RX470 when I boot using Integrated Graphics.

Eventhough its recognized as RX470, it cannot being used and result of GPU-Z will shown the BIOS are unknown and most details are '0'. The GPU fan are spinning and the blue light appeared as usual when the pin connected.

I bought this GPU online and use it for almost 1 year already, but I didnt know either they flash it or not since I didnt check it before since its running good as usual.

I attached GPU-Z result below :


Ive tried using DDU and reinstall using AMD driver but as usual, Windows keep detect it as RX470 and not working at all.

Besides, eventhough the AMD driver installation successful, before/after restart if we try to open AMD software, notification 'No AMD Graphic drivers is installed or AMD driver is not functioning properly'.

Ive tried also using atikmdag-patcher (patch successful & signed) and reboot but its still remain the same with unknown BIOS and '0' memory/clock information.

Ive also tried using ATIFlash trying to flash the BIOS but 'error reading ROM' appeared, not even getting to the software main interface.


Is this GPU already 'dead' or any way to 'save' it ? This suddenly occured since I didnt flashed/change anything regarding the GPU till this issue occured.

Any solution/replies/thoughts from you guys , I appreciate it.

2 Replies

The first thing I noticed is that your AMD Driver is not installed correctly. At the bottom of GPU-Z you should have at least 3-4 (OpenCL, OpenGL, Vulkan, etc) boxes check marked. Instead you only have one box check marked. So basically nothing is enabled on your GPU card by the driver except OpenGL.

Also on GPU-Z click on the upper right box " LOOKUP" and see what is shows.

Second the white label in the rear of the GPU card seems like it was stuck on there from another GPU Card. It doesn't look like the original.

I have a feeling you have either a counterfeit GPU card or someone installed a RX470 BIOS on a RX580 GPU card.

I would contact the Manufacturer of the GPU card (XFX which shows on the Fan) and give them the Serial Number and Model number to see if it is a RX580 from the white label in the rear of the GPU card.

It is possible someone switched the Cowl (Outer covering) from a XFX GPU card and put it on a RX470 GPU card.

Found on Ebay the same GPU card as the one you posted it is a RX580:

Screenshot 2021-02-20 105303.png

Screenshot 2021-02-20 105402.png

Screenshot 2021-02-20 105920.png

Your white label is showing a XFX RX580 or RX560 GPU card (Hard to read the white label correctly) .

Both your photos and from Ebay seems to be a RX580 GPU card. You can verify by opening a XFX Support ticket and sending to them the photos you posted here with the Serial and Model numbers from the white Sticker.


Yes, ive uninstall and reinstall and its still detected as RX470 by windows.

Also using DDU (Display Driver Uninstaller) and after AMD software installed, detected as RX470 (which is having issue/not working) and the details from GPU-Z is the same.

Its usually detected as RX580 and Im always updating Windows + GPU driver without any issue. It just suddenly occurred after I boot up, and this issue happens.

Thats why im feeling so weird about this issue. How come suddenly the GPU arent detected correctly and its not working anymore.

The clock/memory also shown as 0.