Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Storemi installation failed, error 65536

Hello there, I tried to install the newest version ( of AMD Storemi, but the installation keeps failing and presenting the error code 65536, I uninstalled the previous version (, and it left without a trace, and now I cannot install the newest version due to this error.

The reason I wanted to install the newest version was due to an issue I was facing whenever the cache hits 12%, for some reason, the Hard drive where I keep my games and use a separate SSD to accelerate it gets corrupted, and every time it happens I have to clear the cache to make the errors go away. I'll leave my specs below just in case.

PC Specs

Ryzen 5 2600 Stock

Biostar Racing B450GT3 (Latest Bios version)

2x8GB XPG ADATA Z1 2666Mhz C19 (OC to 3200Mhz C14)

RX 570 4GB

Crucial SSD MX500 120GB (OS)

SSD Kingston A400 120GB (Cache)

HDD Western Digital 1TB (General Backup, no Storemi Caching on this one)

HDD Seagate Barracuda 1TB (Games and cached via Storemi to make it faster)

PSU: Thermaltake Smart Pro RGB 650W (I know, this PSU is kinda overkill for this setup)

1 Solution
Adept I

Ok, I guess I solved the issue by making a clean (the zero factory option, which requires a system restart) installation of my graphics card driver, now I could successfully install the newest version of Storemi.

View solution in original post

12 Replies
Adept II

After a long effort working with it I found Store MI to be a difficult and limited option for drive cache solution. I went with PrimoCache and have been more than happy ever since. They have a free 30 day trial and a non-intrusive install/uninstall. It has an improved method of NVMe cache that also uses an allocation, you set, of unused system RAM as a buffer for all drives. It is highly recommended by Linus Tech Tips based on a comparison he did along with Store MI and Intel Optane. He found PrimoCache to be the best performer, most scalable, and infinitely flexible. It literally is a few clicks and a couple of seconds to do all its functions from install, use, adding/removing any kind of drive, and uninstall.

With level 1 enabled using 4GB of system RAM I set for cache use I get 17-22 GBs read/write speeds even on my external USB HDD. Level 2 sets the NVMe cache buffer and they can work together or separate. If you decide you want to keep it a lifetime license is $30 and you can use it on your future PC each time you upgrade for life. I suggest you give the free trial a try if like me you want mega fast drive performance on every type of drive you plug in with one click ease of use.



I am concerned about PrimoCache, but I live in Brazil so that's not an option since the dollar here is too expensive. StoreMI, however, is the only thing I can make use of for now.

Adept I

Ok, I guess I solved the issue by making a clean (the zero factory option, which requires a system restart) installation of my graphics card driver, now I could successfully install the newest version of Storemi.

how is that option possible?


Has anyone else found a solution to this that does not require a clean installation?

AMD support hasn't been able to help with this problem after about 8 emails. The best suggestion they have provided is to try plugging into a different port in case the SATA ports aren't all being serviced by the AMD chipset (they are in my case).

Never had any problems like this with Intel RST and their support was very good when anything came up with other software or drivers.


Now that you said, I remember changing some SATA ports into different ones before I did the clean installation.

Adept I

So I first had installation error -1 when installing a recent-ish 2.x version after I'd tested (IIRC) 1.5 and uninstalled it.  I eventually managed to resolve that by running the StoreMICleanup.exe (or similar name) which somehow was left behind.

But then I had major disk corruption (suddenly Windows said the cached hard drive needed to be repaired via a restart, and that + every subsequent ChkDsk I ran corrupted more and more files), so uninstalled my 2.x version.  After I learned recently this could have been caused by a known Win`10 NTFS corruption bug instead (which behaves like that, fixed in a recent update), I wanted to give the current version another try today, but this time I got the 65536 error every time.

I finally managed to install it by deleting all remaining files and folders related to StoreMI:

C:\Program Files\AMD\StoreMI

(note if you have a log open in Notepad if won't let you delete the 'Packages' folder).

I also closed down all background applications, including a disk monitor called 'Hard Disk Sentinel' (which monitors disk temps & SMART counters etc).  This could have been the failure cause.  No reboot.

Then it installed.

.. my big issue with how StoreMI currently works is that it hides the cache SSD and hard drive from does not pass through S.M.A.R.T. counters to disk monitoring utilities. so you no longer can see temperatures or other counters.  I like to keep an eye on temps, failed sectors and other stats, so that's a problem.

It would be great if StoreMI could expose that data.

Journeyman III

I still have the same issue. Emailed support January, last Time they emailed back was March. I even emailed them last May after I cleaned my boot drive and did a fresh windows install and Storemi install still failed.


AMD Ryzen 3 3100

MSI MAG B550M Mortar

16310 MB DDR4-3000 DDR4 SDRAM 

Radeon RX 570 Series (4 GB)



Been waiting on support since April, got an email in May saying it had been escalated but nothing since.

Adept I

Having the same issues on a B450/R5 3600 system. StoreMI borked itself and deleted my HDD's data. Reinstalling the software with the latest version from the website has been impossible because of the error code.

Even tried the suggested "fix" from this thread and still nothing.


I managed to get it installed 3 times (I uninstalled it the 1st I didn't have a supported config).  Don't bother, it corrupted my hard drive the same way twice.  From my experience it is NOT safe.