Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

StoreMi does not support this cpu and motherboard combination

Just Installed my Ryzen 9 5950x with my MSI x570 Carbon Max, and to my dismay I cannot install the storeMi software. It's a real shame. Because it was this feature that compelled me to buy these components instead of the competition.

I tried everything to make the installation work with no avail.

I also visited forums in search for a solution, and it seems like this is plaguing a lot of people.

I concluded that this is a problem with the software installation itself, because I have all the requirements for this feature to work, and it doesn't.

Please, we need you to address this issue and find a solution.

Mar 15,2022 21:23:20;Information;Launched from: C:\Program Files\AMD\StoreMI\Qt_Dependancies
Mar 15,2022 21:23:28;Information;Local system language: English
Mar 15,2022 21:23:28;Information;## Installer Invoked ##
Mar 15,2022 21:23:28;Information;Install type: Install
Mar 15,2022 21:23:28;Information;Root: C:/, Total size: 999538 MB, Free Space available: 948646 MB
Mar 15,2022 21:23:29;Information;SATA AHCI Count: 2
Mar 15,2022 21:23:29;Information;NVMe Controller Count: 2
Mar 15,2022 21:23:29;Information;Windows Caption: Microsoft Windows 10 Pro
Mar 15,2022 21:23:29;Information;Windows Version: 10.0.19044
Mar 15,2022 21:23:29;ERROR;Check for Required Processor - FAILED
Mar 15,2022 21:23:29;Information;Local system language: English

11 Replies

According to AMD STORMI Webpage your X570 Motherboard and 5000 series processor should work with StorMI:

Screenshot 2022-03-13 220146.png

Do you have the latest version of StorMI (Compatible with Windows 11):

Revision Number
NOTE: Make sure you have all the proper BIOS Settings enabled or Disabled to run StorMI.

EDIT: Open a AMD SUPPORT Ticket and see what they recommend:

Aside from AHCI mode, I don't see any other settings I need to enable/disable in the BIOS.

Yes, I tried the latest version of StoreMi.

And yes, I opened a ticked.

Thanks for the reply.

Sounds like a bug in StorMI concerning the 5000 series Processors.

Possibly it hasn't be updated for the newer 5000 series processors.
Adept II

Seems another guy with a new revision CPU having issue with StoreMI. Go check out your CPU revision via CPUz. If it shows VRM-B2, then that's the reason you can not install StoreMI.

Yes, that is correct. My CPU stepping is VRM-B2 as well.

Thanks for the reply,

I have the same issue. Stepping 2 revision VRM-B2. 

I went through the ticket process and they said they were going to submit an internal ticket because nothing they did helped.

I'm at the stage that was asked for a screenshot of CPU-Z of my CPU. Don't know why.

But the solution is obvious, they need to update their drivers to support the new CPU stepping. It's just taking too long.  



Same issue here (5900X), hope they fix it quickly.

This build is going to a customer so (one 9 year old is waiting and at that age patience is not one of the virtues :-))

I wonder if there is beta build available, I would be happy to test it. As it really is only one CPUSTRING in installation check phase.



Yes, feels like forever and a day.

Journeyman III

I have the same problem. Running a AMD Ryzen 7 5800X 8-Core Processor 3.80 GHz with a B550 Tomahawk. Under the chart, it says it should work. But every time I run StoreMI version it says that my combination is unsupported.


Does anyone have a solution for this? Or has AMD addressed this?



Yes, AMD Moderator MATT_AMD looks like he opened a ticket to investigate this issue with the proper department from this recently opened thread on the same subject:

I suggest everyone from this thread also reply on the linked thread above to let Matt know more Users are having the same issues with StoreMI.