Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

StoreMI causing errors?

I did a new system build a few months back where I was using an M2 SSD for most apps and a SATA magnetic hard drive for media and games. I had a spare SATA SSD lying around and a compatible CPU and chipset (Ryzen 5 3600 on B550), so I thought I'd try setting the old SSD up as a cache drive for the magnetic drive (I'm not using RAID or anything). All was fine for a month or so, but prompted by some game crashes, I got Steam to check game integrity and I found that games were getting corrupted and worse still, Steam couldn't recover them by repairing or reinstalling. I ran chkdsk and it found errors on the hard drive and even more worrying, I found errors after rebooting once I'd done one round of fixes. While I'm aware of other issues that can interfere with Steam's ability to install games (I spent a lot of time Googling this), I wouldn't have thought these should be causing hard drive errors. As StoreMI is the only remotely unusual thing I'm running on that drive (no third party anti virus or anything), I tried disabling it and haven't had chkdsk errors since, trying a few reboots. And most importantly, Steam was able to fix the games.

Are there any pitfalls that I need to be aware of? One detail I'm abundantly aware of is that the support for my chipset was added relatively recently, so could they still be ironing bugs out? The other is that the SSD I was using was very well-used, having previously been in service as a boot drive on a different computer for several years. While aware that SSDs have a finite lifetime (particularly the older ones), could that be a source of glitches?

There's an outside chance that an uncontrolled shutdown caused the error (I'm aware of at least one occasion where my daughter found the reset switch) but if that's the case, should I just say that StoreMI isn't stable enough if I have to worry about that sort of thing happening again? The final option I can think of is that the hard drive is defective, but I'll discount that as a possibility if it continues to work with StoreMI disabled. There aren't any stressed SATA cables or anything (checked that too).

16 Replies
Journeyman III

I was just going to post the same issue. I am using a 2TB Seagate FireCuda and a 256GB Corsair SSD as the cache drive. The games load and run fine for a bit, then like you, I begin to get loading errors where Steam wants to verify game files. It finds corrupted files and attempts to download and repair but it fails. I have used the HDD separately and all runs fine. I have tested and used another SSD but after a week or so the game files get corrupted again and only deleting the game and reinstalling it fixes the issue but it quickly returns. 

It also happens with Epic games. I've had Metro Exodus get corrupted so it's something with the StoreMI software. I hope they will investigate the issue. If you haven't done so already, I would recommend sending a ticket in to AMD so they are aware of this. 

Adept I

I do get exactly the same issues now. Whenever StoreMi is enabled both Steam and also find corrupt files on the drive. If you do a repair installation everything works fine. It takes about 2-3 restarts to get a problem with corrupt files again.

My configuration is a Ryzen 7 3700X, X570 MoBo with 6TB WDC Gold and Samsung Evo 960 M2 SSD with 250 Gigs.

I checked SMART on all drives and they are fine. I'll be running the system without StoreMi for the next couple of days to figure out if StoreMi really caused the problems.  The only strange thing is, it worked for perfectly for the last 2 month, never had any issue with StoreMi. It started just a week ago. I also updated StoreMi to, which should be the latest version by now. I uninstalled it now.

There where two changes I did in the last week, when the problems started. First was a BIOS update for my ASUS MoBo to BIOS 3402 and I changed the Graphics Card from RX5700 to RX6800. Maybe it's a bug in the BIOS causing the problem, I don't see a reason why the Graphics Card should interfere with StoreMi.

Did you guys see any improvement on StoreMi?


Does anybody of you have Kaspersky software running on the computer? Asking because it looks like Kaspersky is putting an additional filter driver into the storage stack on my system. I removed Kaspersky, re-installed StoreMI and will test my config without having Kaspersky running.


No, I am only using built in Defender. I suggest everyone submit a ticket if you haven't down so already or post in their reddit.

Adept II

I also experienced this problem. Wasted about 50 gigs of download on steam attempting to repair corruption (and then saying the downloaded files are corrupt) before I remembered seeing something about steam corruption with storemi, then removed my storemi drive association, and everything was suddenly fine.

Whatever the problem is causing this issue, storemi 2.0 clearly needs more time in the oven, it's not ready yet.

I'm also experiencing this, running on a Asus B550 prime-A and a Ryzen 3600. Have a 256gb adata 8200 SSD and a Seagate Barracuda 2 tb drive. This happens on both steam and epic games. This happens to me after windows fixed the corrupt hard drive.


Yeah, I have had some game and music library corruption using store mi with a 256GB SSD and 2TB HDD as well. Music will have the end of the file get corrupted/disappear.

I use BitDefender.

It's off now. Should probably go back to using FuzeDrive which now lets you undo the drive without wiping everything. Funny AMD switched away from that just as they added that ability and now we get corrupt files


Came here to say I'm having the exact same issue. Disk errors, corrupted Steam games, at one point Steam wouldn't start at all. It was all perfectly fine right until I installed StoreMi, and after uninstalling and verifying all the games/reinstalling Steam it's fine again.


Thought it was a fluke and tried reinstalling StoreMi, corruption again within a few days. Been running a few weeks without now and perfectly fine, it was definitely StoreMi. Made a similar post on Reddit and a few users there are experiencing the same.


It just not Steam. Its all the game launchers, Epic, Steam, Origin and DCS World. Whenever I have StoreMI enabled, Games under all of these launchers eventually get corrupted and unusable. I currently have it off but hopefully they acknowledge the issues and get it fixed.


There's a new build since April of 2021.
Has everyone here tried that?
I downloaded it, but haven't pulled the trigger yet.
AMD lists it as being rebuilt from the ground up. So NEW product.


Yes, these issues occurred while using using the new/latest StoreMi.


So I wrote a response detailing a very likely cause for the error and it was deleted as spam. Instead of doing it again, I'll say check the top reply here:

The math checks out for me too, using my drive sizes that's exactly where I started experiencing errors.


So I'm running the current latest revision of StoreMI ( and my 1TB NVMe SSD is sitting at 100% cache space used for the 3TB HDD it's caching.

When trying to update or even full reinstall a steam game I'm seeing various "corrupt chunk" and "Corrupted or unrecoverable data error" errors (among others) while tailing the content_log.txt file found in the steam logs directory: C:\Program Files (x86)\Steam\logs

The files relate to both the steam download cache and files already present in the game installation directory.

I've attempted chkdsk /scan followed by chkdsk /spotfix which identifies and fixes the corrupt files, but during the next update attempt or game file validation check I see a bunch more of the "corrupt chuck" errors.

I was starting to think I may have had a hardware issue but having found this thread figured I'd add my 2 cents.


Quick update.

I cleared the SSD cache in StoreMI and tried to update the steam game again. The game completed the verification process without and errors.

Looks more like an issue when the cache hits some value to me.


Adept I

There's some conjecture that the issues might start when the cache reaches a certain size. So far what I've gathered is:

(cache drive size)/(drive size)*100 is the limit, as a percentage. So a 500Gb cache on a 4Tb drive would be:

500\4000*100 = 12.5

12.5% (reads as 13% in the software)

Which is exactly where I started experiencing issues with StoreMi both times, after it had been running fine for weeks. Might check if the same is true for you.

Journeyman III

I really like the idea of this feature, but I also came to a point of getting frequent HDD errors. I can confirm corrupted Steam files.

I can also add that many of my Raw and Jpg files were corrupted, which were on the same HDD. They seemed to be mostly photo files that I was editing at the most recent time. I was lucky that the RAW files were still on my SD cards and could rectify and send them to an additional back up drive.

I've since disabled storeMI, but hope to see some follow up to this issue here.