Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

StoreMI 2.0 - Can't Select hard drive as source device, says "connected to a third party controller"

I have a ASRock B450M Steel Legend motherboard with an AMD Ryzen 5 2600, along with two Western Digital HD and an Intel NVMe SSD that I want to use as a cache device.

I can select the SSD as a cache device.

Unfortunately, StoreMI doesn’t allow me to select either hard drive as a source device. They are “greyed out” with the following tool tip message:

Source device is connected to a third-party controller, please power down your system then move the device to an eligible SATA controller for use with StoreMI


Others have had the same problem and I have tried their solutions:

I have updated the bios and reinstalled the AMD drivers. [Post]

I have checked the storage controllers to make sure the “Store MI Bottom Device” driver is in use. [Post]

I have powered down the computer and tried all 4 SATA ports. [Post]


I have also uninstalled and reinstalled StoreMI.

According to the StoreMI page, B450 chipset with Ryzen 2000 processors is supported.

Below are screenshots of StoreMI app and Device Manager Storage controllers.

Any help would be appreciated. Is there any official support contact for this?


StoreMI AppStoreMI AppStorage ControllersStorage Controllers

2 Replies

Are you able to select secondary drive [SSD] ? from the cache devices

Journeyman III

Are you able to select secondary drive [SSD] ? from the cache devices?

No, only the PCIE SSD can be selected.  In the screen shot you may notice there is no green dot in the upper right corner of that drive.  None of the SATA ports are seen as connected to an AMD controller, just the PCIE port.

This makes me wonder if the issue is with the motherboard SATA controller, but the Enmotis' version of StoreMI (v1.*) worked fine.