Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Still locking up when watching video content in a web browser.

Hi All, 

Just wanted to share that with the latest driver offered (19.9.2), my PC still freezes up when watching YouTube.

System instability may be experienced on some Radeon RX 5700 series graphics system configurations when watching video content in a web browser.

This was in the "Fixed" section of the release notes but it hasn't been fixed for me unfortunately.

I've reverted to the last stable version that worked for me, which was 19.7.2.

The following are my specs and I hope a fix is available soon, as I would really like to get some more frames for Borderlands 3 while being able to view videos as well, you know .


Radeon Software Version - 19.7.2
Radeon Software Edition - Adrenalin 2019
Graphics Chipset - Radeon RX 570 Series
Memory Size - 8192 MB
Memory Type - GDDR5
Core Clock - 1286 MHz
Windows Version - Windows 10 (64 bit)
System Memory - 8 GB
CPU Type - AMD FX(tm)-6300 Six-Core Processor

Thanks in advance.

10 Replies
Journeyman III

Same problem for me with both Amazon Prime and Netflix in Firefox (current release). I'm on 19.9.2. I have an R9 200 series card, an Intel i5-4460 CPU and am running Windows 10 current release.

The browser stops responding for a few seconds; a few seconds later, any other open app freezes; and then a few seconds after that, the whole system freezes completely, requiring a hard reboot.

Yah that's too bad. The drivers have had this issue back and forth the get it fixed then somehow broken again for about 2 years now. As far as I know disabling hardware acceleration does the trick though. It just changes it from being processed on the GPU to the CPU. In most cases with modern CPU's it really is a non-issue. I'm sure they will ultimately get it fixed, as i said this has already happened several times that I know of. Just keep reporting the issue so they no it isn't an isolated occurrence and is a wide spread problem. 


Not sure if they meant that it is fixed for all series of cards or not but the listed RX 5700 series is not the same series as your card if what you have is an RX 570. RX 570 is a couple years old Polaris card and the RX 5700 is Navi. It is confusing how they make those numbers so similar. If you are having issues you can go into your browser settings and disable hardware acceleration and it should work fine then until a driver does fix the situation properly.

Good Luck!

Thanks for your responses.

I figured one of the responses would include something about my old card lol.

Hardware acceleration is disabled but it still happens.

To be honest, the 19.7.2 driver is working just fine; I just like to keep everything up to date.

If they release another driver, I'll give it another go and open another thread if it fails.

Adept II

Have the same issue, but with an RX 5700 XT wich 19.9.2 should have solved the issue, but not ... it can work 2/3 days and the next day on a random video youtube : it freeze, the sound can continue for some minutes, but "signal lost" on monitor, and keyboard / mouse don't responde (ver num / caps lock ).

Forget to update status here, well the 19.9.3 solved the issue, it was hardware acceleration in Discord and in web broswer that caused the issues, from 19.9.3 and futher no more problem.

Good luck to the ones that still have an issue : /. 

Adept I

This still happens for me as well with 19.9.2.  With pretty much any YouTube video in Chrome.  Ad plays, hit "skip", entire browser freezes and I have to kill all chrome.exe processes and restart it.


I can tell you guys this has to be very specific to the Navi cards. I am sure it is a bug, but that same driver is not doing this on my Polaris RX 580. Maker sure to report the issue to AMD.

Adept I

I just wanted to share that I tried the new optional driver 19.11.1 and the problem still exists.
So I rolled back again to 19.7.2
Will continue trying new ones as fast as they are released and report back.

Adept I

Hhmm.. Check for driver update in your motherboards Bios system. If your motherboards does not suport pcie-4 you have problem with rx5700xt or any other Gpu with pcie-4. You have to download from the motherboard company the latest bios update. For ex. My Asus x470 prime pro has pcie-3. I had the same problems (Chrome, ytb, sound, unstopable restart and blue screen video tdr failure atikmpag.sys). After i installed the bios update my Gpu fixed. Try it.