Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Something uninstalled my AMD Radeon software! ???

I have no idea what happened. I was online. Everything was working fine. Suddenly my monitor (I'm using a TV) went black. I noticed the power light on the monitor was off but the computer was on. I turned the monitor back on, but a blue screen said no signal. I'm on a Windows 10 Pro desktop. I couldn't do anything so I turned the computer off from it's power switch. I waited about a minute and tried turning it back on. It came up but with a lower resolution and I noticed that AMD Radeon software was not loaded although the Radeon RX 590 showed as my display driver in the system information. OK, still the resolution was screwed up and much lower, so my desktop was screwy, as was everything I tried to run.

I searched and found my last installation download from a month ago and tried re-installing it. That went well and installed the latest version 21.10.2 and said it was up to date. I had just received support on fixing issues back then and everything was finally back in working order before this happened. My resolution is back, but I wonder what could have caused that? I'm checking my AV. I'm sort of on a wait and see mode. Has anyone had anything like this happen? Any ideas?

11 Replies
Volunteer Moderator

This is strange and it could be caused by a corrupted driver installation or possible because of your AV software, the only AV you should use is the one that comes integrated with Windows 10 / 11 - don't use any other AV programs, they do more harm than good.

Uninstall the current AMD Driver using DDU as per this method:

It could be due to a corrupted AMD Driver installation.

Download free program DDU (Display Driver Uninstaller). Run it in Safe mode with the internet disconnected.

You can also run it in Windows Desktop but then you would need to Reboot the computer for DDU to finish erasing all of the AMD Driver traces from your computer.

Once it finishes uninstalling the current AMD Driver in Safe mode and boots back to Windows Desktop, still with the Internet disconnected, delete the AMD Installation folder C:\AMD if it was created before.

Now install the full AMD Drive package you downloaded manually from AMD Download page. Not the express package. Run the package and if it installs correctly again delete C:\AMD folder and reconnect the internet.

This should prevent any conflict when installing the new version from the previous version.

By the way, C:\AMD is always created whenever you run the AMD Driver package


Thanks. Look, I've done all of this. I've sent requests for help to Support. They've been extensive, and yes, eventually I get everything reinstalled and working properly. It's a bit of a pain to search for all my settings each time. Everything works alright for a while then I have the same problems return. Currently, I'm trying to deal with Radeon constantly overriding my other existing hotkeys. I finally just disabled hotkeys on the Radeon. For example, in Google Chrome, there is a hotkey combination that opens up the Bookmarks Manager. It is Crtl-Shift-O. That also happens to be a Radeon combination. Here's the problem though. The hotkeys on Radeon are disabled. When I try to open my Bookmarks Manager, Radeon opens its Performance Overlay, even though the Radeon hotkeys are disabled. I have to open the Radeon Software, enable and again disable the hotkeys. Only then can I use the hotkey combination without Radeon overriding and showing its overlay!

Adept II

LOL what version of driver you have isntalled ?

If higher than version 10.1 please remove the driver completely by using DDU and download the 10.1 version driver

DO not install any newer versions as they do nothing besides screwing up your system

Now i have no clue how it behaves under win 11, but since it is just another user interface change i refuse to switch.

I have locked my pc to not install win 11, for at least several years.

So unless i stop gaming i might check if some nice program popsup like the good old open-shell

Which turns it back to a usefull OS, but i refuse to change to the newer interfaces these twerks invent from M$.

Again non of the newer drivers contain any updates for cards lower than the 6700 series.

I have not found any code which shows me that they improved anything for the "old models"

It is sad to see that AMD is becoming a only supporting the newest hardware company.

Especially because most of us have totally no need for the newer series, unless you like the silly hardly visible ray tracing hype.

So as long as you do not have these type of games.

Most funny is all the people i know having the powerhouses from amd and nvidia almost all of them turn of that silly raytracing stuff because it has a way too big impact on the FPS xD, Roofl.

They paid a fortune for 1 or 2 of the most expenssive cards for nothing ....

I admit they are that crazy and will buy anything as long as it does not hamper their other hobbies like driving racecars and such rich boys toys.


I'll keep this in mind.


I've been havimng same issues for a long time now my software just completely uninstals itself every few days and i get this message...

Made various bug report no one at AMD has ever got back to me


Screenshot 2021-12-11 121158.png


Sounds likw Windows Update is installing/changing graphics drivers.

Fix >


I cant seem to find the Local Group Policy page on my computer?



Type .... group policy in the search box.


does you CPU has a build in GPU ?

And did you reset bios somehow as that is the most likely problem

I had that after i had repasted the cooling paste on the cpu and did reset the bios without the my graphics card

Which resulted in ofcourse the pc booting with the cpu buildin one

So i went back in the bios switched it back to external gpu and poof back working




sorry i didnt understand most of what you are saying, im very nooby with this kind of stuff so i have no clue, ive never made modifications but i did buy this laptop from someone else. Screenshot 2022-01-05 171006.png


also my GPU MHz keeps spiking from 300MHz to 2000MHz every few seconds which is causing my game to stutter every few seconds