cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

onewithwaves
Adept I

Some strange program & monitoring behavior after replacing a faulty GPU in a CrossFire setup. Any advice how to fix it?

Hello and thanks for taking a look at my question! I've been building PCs for over 10 years and this issue has me totally perplexed; any and all advice is very appreciated! Sorry for following AMD's template but I'm a new user and don't want to anger the community on day one.

Describe your system:

  • Custom ATX desktop
  • AMD Graphics Cards:
    • Sapphire NITRO+ RX 480 8GB x2 (Crossfire setup)
  • Operating System:
    • Windows 10 Pro 64-bit (most likely ver. 1803)
  • Driver version installed
    • Adrenalin 2019 Edition 18.12.3 (Optional)
  • Display Device
    • Acer XG270HU, DisplayPort connection (fully DP compliant cable)
  • Motherboard + Bios Revision
    • ASRock Z87 Extreme4, latest beta BIOS (it's far newer than the latest stable and both are several years old)
  • CPU
    • Intel i5-4670K (OC to 4.2GHz)
  • Power Supply Unit Model & Wattage
    • EVGA Supernova G2 750W
  • RAM
    • 16GB

Describe your issue:

I've been running an RX 480 since they came out and I love my Nitro+ so much, I wanted to get it a friend on eBay. The first card I got had clearly been used for mining and had lots of problems; it didn't always power on with my system, sometimes my MOBO reported it didn't support UEFI when powering on, etc., and I returned it as not working. I got another card which is in much better shape and doesn't throw any errors on me but I have lingering issues I expect are from the old shoddy card (not sure how that would be possible but it's the only thing that's changed). When I first set up CF I was getting ~%150 scaling in Overwatch and all my monitoring programs worked perfectly (I use Afterburner to display hardware stuff on my G13's LCD). After the (old, bad) card threw a few fits, Afterburner stopped reporting GPU load correctly and OW and other CF capable titles stopped scaling at all; even with CF turned off, they ran far worse than they did before I set up CF. After getting the second (good, working) card, most games scale properly again but Afterburner and HWinfo64 are still not reporting GPU load at all; both cards constantly read 0%. I also have some issues with microstutter and CF scaling that weren't there before. For example, Overwatch runs in CF when connecting to the server and entering the game, but CF suddenly turns off once the menu loads (I have the CF logo turned on for troubleshooting purposes). I've even specified the AMD profile for Overwatch with no improvement. I'm it my wit's end trying to figure out what went wrong and what sort of gremlin that dead card left in my system - what do you think could get me up and running at 100% again?

So far, I've attempted totally uninstalling AMD's driver using DDU in Safe Mode and performing a clean reinstall of the latest Adrenalin driver. I've also totally uninstalled and reinstalled Afterburner, both the latest and Beta versions. I've tried enabling Unified Monitoring in Afterburner, disabling ULPS, disabling Power Efficiency in Radeon Settings, toggling global CF on and off and disabling my CPU's iGPU in my BIOS but haven't been able to resolve this issue. As I said before, any and all help is greatly appreciated as I've run out of ideas at this point.

0 Likes
68 Replies
sattla
Adept II

do you even get the crossfire logo in game if enable in Adrenalin software? i also got like 150% scaling but it does not even work for me now only with 1 card.

0 Likes

sorry saw now that you have same issue, cf disables when enter game. before that it use to disable when entering the highlight selection in game which was manageable now it does not work at all.

0 Likes

I don't think I ever opened the highlights section of the game when it was working as expected so that's interesting that you're seeing a similar issue. What have you tried so far in order to fix it?

0 Likes

This all started with Ashe update so i guess its overwatch that has done something that forces second GPU to start working when entering main screen of game..

I did raise this issue with Blizzard who said it was on AMD's side and since AMD has it on its list of supported games they should rly look in to it as its about to become the Nr1 esport title or atleast thrive to become.

I have also reported this to AMD before without any kind of reply.

We are running this problem in to 2nd month with any word from AMD over 3 4 driver updates and i dont even think its a big problem

0 Likes

I appreciate the additional info; I was only able to find out from one other place after you told me about the specific update, so I'm glad it's not just me. Hopefully AMD reads these forums and tries to get in touch with Blizzard about what changed.

On the other hand, do you think it's a coincidence that Afterburner stopped reporting GPU load for me at the same time? I still find it a little suspicious that other games like Fallout 4 don't seem to scale as well as they did or suffer from way more microstutter than usual. At the same time, though, I know it's basically impossible for a part to affect my PC long after it's been uninstalled short of physical damage.

I re-did all my case fans and bought two GPU support brackets this week. I'll report back next week after I've had a chance to test more extensively in case this is all a case of GPU sag or something silly. I'm planning on doing another clean uninstall with DDU in safe mode and installing whatever the latest driver is at the time. I'm also going to see if enabling the embedded GPU on my CPU makes a difference at all.

0 Likes

Hi,

(1). Uninstall Afterburner until you debug the problems.
if your secondary GPU is installed and working properly then the Radeon Performance Overlay in Adrenalin 2019 19.1.1 Driver should be able to report GPU2 Utilization.

(2).RE: DDU in Safe Mode - you need to make sure you disconnect from the Internet. Then run DDU in safe mode to remove AMD driver . Reboot. Make sure you are still disconnected from the Internet otherwise Microsoft OS may install it's estimate of required AMD driver without you noticing during or immediately following boot up and you will end up installing over an existing driver installation resulting in who knows what. Install Adrenalin 19.1.1. then reboot your PC. Then connect to the Internet.

(3). Overwatch was scaling great for me last time I looked. I will check again after I update it to latest patch.

Bye.

Thanks colesdav - I'll definitely follow your recommendations once I have a chance to take a look at this again. Disconnecting from the internet is an excellent idea; I wonder if that's the crux of the issue here.

Please let me know if OW is still behaving with CF for you next time you play!

0 Likes

Hi,

I am setting it up to test now. I will be running on a pair of R9 Fury X in Adrenalin 2019 19.1.1 on Windows 10 Pro 64 bit.

Bye.

0 Likes

Hi,

Sorry for the delay. I was repairing and running Windows 10 64 bit OS checks after attempt at running Auto Overclocking an RX Vega 64 Liquid.

The Windows 64bit OS was repaired, checked, updated and is fine. I swapped the RX Vega 64 Liquid out and fitted a pair of R9 Fury X's.


I tested how Overwatch is running on i7-4790K and a pair of R9 FuryX in Crossfire at 4K Epic Settings with Crossfire on and off.
Both are running terribly with Adrenalin 2019 19.1.1. in comparison to last time I ran those cards on that game at those settings.
I am getting mouse lag, hitching gameplay, generally bad experience.
In short there is something wrong or something has seriously changed and got harder w.r.t. Graphics Requirements for running Overwatch.

Also I got an AMD Related Driver Windows 10 64bit BSOD when adjusting the in game resolution in Overwatch which I have never seen before.
I will add that BSOD here next.

I also checked Destiny 2 - that is running fine at 4K highest settings and I get positive scaling.
The CPU and GPU were running at stock clocks.
Fan, temp,and power targets for the GPU were maxed out.

Interesting.


I will go and check what has been going on with Overwatch. Maybe they have pushed up Graphics Requirements significantly?
I would have thought that 4GB of HBM and definitely 8GB of Vram on RX480 should be more than enough for Overwatch.
Also I will take a detailed look at what GPU VRAM is reported by the R9 Fury X - maybe you could check what your RX580's say?

Thanks.

0 Likes

Here is the BSOD resulting from attempt to change Screen Resolution in Overwatch running on Adrenalin 2019 19.1.1:

20190120_014056[1].jpg

0 Likes

Make sure relive replay isn't recording when changing resolution. This could cause issues.

0 Likes

This is what it used to run like: Overwatch latest patch 4K Epic DX11 Crossfire R9 FuryX/Nano. - YouTube  - according to me at least.

It now runs 10x slower.

Bye.

0 Likes

I also checked BF1 DX12 MultiGPU and Crossfire - boith scaling well.
I did however get Black Screen and Audio Buzz PC Freeze in DX12 MultiGPU BF1 when I used Alt Enter in attempt to go from Windowed to Full Screen Mode.

So that's 2 PC Freeze / BSOD out of testing 3 games with Adrenalin 2019 19.11.1 Drivers in one evening.

That's enough from me for one night.

In short it is not just your GPU's / System that see's problems with Overwatch and AMD Drivers.

Bye.

0 Likes

And another crash ...

BF1 DX11 Crossfire, Adrenalin 2019 19.1.1

pastedImage_0.png

0 Likes

Hey!

did all of the steps you described my CF still deactivates when login on to main screen in Overwatch.

My second GPU shows up in alt+r overlay and i can measure the usage.

For your Overwatch CF test what setting do you use? i find every setting except for one giving me negative scaling.

I use these settings
http://prntscr.com/mbhkw8

would you test with these settings?

any suggestions on how i could move on to get it work?

Hi,

1. Launch Battle.net, logged in.


pastedImage_0.png

2. Check Software version.

pastedImage_1.png

3. Global Settings.

pastedImage_0.png

4. Wattman Settings for Primary and Secondary GPU's

pastedImage_1.png

pastedImage_2.png


I save this post in case it gets lost and follow on with info on Overwatch Profile Setup OK?

0 Likes

Next step is set up Overwatch Profile:

The first thing to to is to Reset Profile - all game profile settings should reset to default, apart from those that need to match the Global Settings and Wattman Settings above.
pastedImage_0.png
After Reset, changing nothing:

pastedImage_1.png

Note initially I turn Histogram On - 2 reasons:
(A) Previous error in Adrenalin where Game Profile Wattman Settings where not applied if Histogram off.
(B). To monitor GPU activity.

pastedImage_2.png

pastedImage_3.png

I save this again, and next post I will look at launching Overwatch.

Here are my display settings - please note I am running my cheapest, lowest cost FreeSync Monitor.
I test at Overwatch 4K with Epic Settings.

pastedImage_0.png

And:

pastedImage_1.png

And in AMD Settings:

pastedImage_2.png

Note if you hover your mouse over "Radeon FreeSync" you will see your FreeSync Range available at the Monitor Mode you have set.
Note the range in this case with this monitor.
It is pretty narrow.
Low end = 48
High end = 60

So...
1. To avoid a generally bad, laggy experience tou should aim to set up the game options so that your in game FPS never drops below 48 FPS in this case.
2. To avoid any screen tearing and / or 'vertical rolling banding' when running FreeSync (assuming you have Vsync in game switched off...) Set FRTC to 59 FPS so that the GPU outputs frames to the monitor at 1 FPS below the top end of the FreeSync Range.

Next I will launch Overwatch.

0 Likes

why are you using GPU scaling? is it because you are using VSR?

0 Likes

Yes  I am running VSR for these tests. I think Display Scaling was off in Overwatch Profile though.
My real 4K FreeSync Monitors much better connected to a Palit RTX 2080 OC and an RX Vega 64 Liquid on other PC's.
Thanks. 


0 Likes

I'm getting the same results as sattla's video using the same uninstall procedure (uninstall AMD, uninstall in device manager, uninstall Afterburner, CCleaner registry clean, disconnect internet, run DDU in safe mode, install latest AMD driver, reconnect to internet).

Here's an overview of my system after following the complete uninstallation and clean reinstallation:

01 Overview.png

My software details:

02 Software.png

Properties of my GPUs:

03 Primary GPU.png

04 Linked GPU.png

Monitor details and settings, just in case:

05 Monitor.png

Here's my Overwatch profile:

06 Overwatch profile.png

One thing I've noticed is the HD audio device on one of the cards throws an error in Device Manager but I wouldn't think this would matter:

07 HD audio bus.png

I went ahead and deleted my in-game preferences for Overwatch through the Battle.net client, watched the intro cutscene and login process in glorious CF and saw CF disabled again upon loading the main menu as before. I tried resetting the graphics profile to Medium since it defaults to Epic and restarted with the same results. Here's my main menu with my graphics settings as I typically set them, mainly 100% display scaling, 144fps limit and most settings on low or medium (except textures on models, on High and Ultra respectively):

08 Performance monitor.png

I checked out the AMD performance monitor and it showed 0% GPU load as I'd expect. I'll try a few more CF compatible games tonight and post again with the results.

0 Likes

Just wanted to add my CPU isn't even approaching above 30% utilization before CF turns off so I wouldn't image that's it.

The HDMI Audio Drivers have been missing from AMD Installer (on and off) for a while. Sometimes it's there, sometimes not. If you want them back, easiest way I get them is from 17.4.4 WHQL driver.
Run custom incremental install and only install the HDMI Audio Drivers.

Alternatively, remove your AMD Drivers completely and then let Windows 10 automatically install it's version of the AMD Driver. Windows should install the HDMI Audio Driver for you.

How you get from there to the latest correct AMD Driver is too tiring to describe right now.
Seriously the AMD Adrenalin/Crimson ReLive/ Crimson installer/uninstaller is a mess.  
But the GUI does look great on marketing slides so hey, what's the problem...

0 Likes
kingfish
Volunteer Moderator

This worked for me:

Download & Reinstall  Realtek HD Audio Manager

Before downloading the new drivers, uninstall all the current drivers. In order to avoid duplicate conflicts among several drivers, one must uninstall the duplicate audio drivers as well.

To do this follow these steps-

Click on Start button and navigate to Device Manager.

Expand Sound, video and game controllers from the list in Device Manager.

Under this, locate the audio driver Realtek High Definition Audio.

Right-click on it and select on Uninstall device from the drop-down menu.

Download & Reinstall Realtek HD Audio Manager

Check the option with Delete the driver software for this device and hit the uninstall button.

Now go to Views tab and click on Show hidden devices from the drop-down menu.

Now search for duplicate audio drivers if any. Right-click on it and hit the Uninstall option.

Restart the system.

To manually download the audio driver, Navigate to the official website of Realtek here – realtek.com/en/downloads.Click on High Definition Audio Codecs (Software).

0 Likes

did this make your CR work?

the audio driver is OT here but thanks a lot for filling in.


im stuck here i tested everything now it feels like i just got to get a vega instead i guess.

gonna do reinstall windows when i get to Spain moving from Sweden next week.

0 Likes

Video running with Adrenalin Driver settings you described, and Overwatch runinng 1080p Low settings is here;

(Link to video to follow - it is still processing).

0 Likes

Here it is: Overwatch test Crossfire 1080p low to check for Crossfire Dropout. - YouTube 
Note at one point you will see me Alt Enter out of Crossfire and back into Crossfire as the game launched and initially was playing with slight stuttering. That happens sometimes at launch, especially at high CPU Utilization. Alt Enter out and Alt Enter back into Crossfire seems to fix it.
I am off to try a few more things out and make one last attempt to repeat the DX 11 Crossfire problem you see running these R9 Fury X's.
Bye.

0 Likes

Hi,

Overwatch in crossfire is still stable for me on i74790K 4Core 4 threads even running at  1080p low, with the following settings for Global:
pastedImage_1.png
Local:
pastedImage_2.png
I am getting very high FPS in ranges 220 - 260 in DX11 Crossfire with the above settings at 1080p, even when recording with Radeon ReLive on. The CPU utilization is very high ~ 95%+ and both R9 Fury X GPU's are running.

I also took a quick look at turning on all Microsoft Gaming tools in Windows 10, and I also checked if setting in game FPS Limiter at 30/60/ whatever at launch was causing a problerm.

This Overwatch DX11 Corssfire dropout problem is problem is looking more and more like an RX480 specific issue to me.

I have tried everything top break DX11 Crossfire on Overwatch within reason and I have failled so far. It looks like AMD have done a very solid job for DX11 Crossfire on Overwatch with R9 Fury X at least.

I will have one last bash at running with the options described by sattla next, and finally I will look to see if it is anything related to installing MSI Afterburner.

Thanks again.

0 Likes

Display Driver Uninstaller (DDU) V18.0.0.7 Released. - Wagnardsoft Forum 

-Possibly fixed the removal of the "AMD audio bus" that was causing issues to AMD GPU owner who also have AMD chipset + CPU.

0 Likes

I have set up your AMD Settings. One question. Why have you turned off Surface Format Optimization?

RE: Here's my main menu with my graphics settings as I typically set them, mainly 100% display scaling, 144fps limit and most settings on low or medium (except textures on models, on High and Ultra respectively):

The picture you posted:
08 Performance monitor.png

Does not give me much to go on I am afraid.
Thanks.

0 Likes
kingfish
Volunteer Moderator

Surface optimization is automatic FP16 to FP11 format demotion and it affects base texture quality. It benefits low end cards...sacrifices quality for performance. Mainly applies to older DX9 games. 

If you want the best quality disable it.

0 Likes

colesdav this was my reasoning; I also remember reading a while ago that it could cause shimmering or flickering in CF in some games. I'm not playing a lot of DX9 games lately and figure I can always make a profile for them if need be.

0 Likes

The last time I could get force overdrive graphic settings was when it still was CCC. Can toy guys confirm it's working, it doesn't look like there is much AA, I know it was just 2x. If you increase the AA does your performance go down?

0 Likes

Here I launch Overwatch

pastedImage_0.png

I see this at launch:

pastedImage_1.png

Nexi I enter my login ...

0 Likes

Here I am logging in ...

pastedImage_0.png

Here I am logging in, the game is running very poorly FYI. I have been running Strange Brigade at 4K maxed out Grapics Settings at > 60 FPS on this exact same system earlier today. Look at the Overwatch FPS in the top LHS of the screen. It is awful.
Also ... please note I can see the Crossfire Logo on top RHS of my screen, but the PC Print Screen will not capture it at the moment.

pastedImage_1.png
Here are the Graphics Quality Settings in detail:

pastedImage_3.png


I will try to run it again for a few minutes but it looks just as bad as last time I tried to run it.
Hopefully all of the above posts will help you.
I will file an AMD Reporting Form about poor Overwatch Performance in Crossfire because something is wrong ...

I will point to this AMD Community Forum Post ...

Please file one as well.

You do it here:

pastedImage_4.png

In your case you may want to open an email support case about this.
Online Service Request | AMD

I will quickly take another look at Overwatch in Crossfire, but I need to go now.
Again I hope this helps you out.

Please let me know if you at least get the Crossfire Logo to stay on.
Bye.

ok now test to set the setting i use and you will see a huge improvement. (some time i haft to alt+enter window mode and back to get my scaling good on overwatch)

And running 4k with 200% render scale maxed out wont give you good fps with any any CARD Overwatch is way to demanding for that.
Saying its not good with setting that even a 1080ti would give you -60 fps with is not a proper test. Fps espors titles are all about fps nothing about 4k imo.

Huge Thanks for all the effort tho.

0 Likes

additional: I never had good performance in OW with FramPace - On, Texture Filtering Quality - standard and Crossfiremode Default.

i always had to set: FP- Off - TFQ - Preformance - CFM - 1x1

with any other setting i had negative results as you describe.

thnx

0 Likes

Hello.

It looks like the Ultra Settings were messed up somehow when I ran the Overwatch Update.
I do not know why.

I did not force them or set them like that this time at least.
If you look at previous 4K Videos I created of Crossfire on Overwatch the were run at EPIC and resolution scale 100% and they all run fine.

Bye.

0 Likes

yes that's normal its gives you the settings it thinks would be preferred - Those are always way to heavy to run the game in a worthy fps range.

0 Likes