Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Some black flashes while gaming (and browser letters failing too)

Good morning everyone

I've been playing Valorant and Hogwarts Legacy all week, no problems. Suddenly today, I opened Valorant and I see some flashes, like rendering failure and I have no idea what it could be, it's happening while gaming and watching videos.

I've already cleaned my PC, removed the dust, and it's still happening. Graphics are all up to date, everything looks fine.

I'm using a MSI Radeon RX 570, Ryzen 5 3500x, MB Asrock A320M.

Video of the problem here (it's happening in every game)

Also, sometimes elements from browser, like text and buttons also have some problems that I can't explain ...

Already tried another GPU, worked perfectly. With my GPU, switched RAM and the problem remains. 



3 Replies
Journeyman III

I am having the exact same problem with my MSI RX570 8gb in Ryzen 5 3600x CPU. 

 It started after the updated driver for Company of Heroes 3. 

 At first i had green pixels in the screen also (in warframe), now only the kind of problem related here in the video while playing Guilty Gear: Strive, somehow the green pixels went away, in Warframe from time to time the screen is getting black as if the video got disconnected and went back after a few seconds as if nothing ever happened. 

Journeyman III

the black streaks are artifacts, you generally start seeing them if you overclock to high or your card is failing.
but sometimes it's drivers, if you updated drivers recently try rolling back.  

Thank you, i am totally sure it was drivers and it began in the february patch that gave company of heroes 3 support. Both of us use MSI RX570, have the exact same problem and it began at the same time. I have already uninstalled and reainstalled all the drivers, but i have a problem. Where do i find the older AMD drivers? i am searching and so far have been unable to find then. 

 Edit: i have found 3.2.1 trying to install it to see if works or if i need to install an even older version. I will update here.