Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


[SOLVED] when trying to open AMD settings i get error saying "radeon settings and drivers do not match. please try again after updating to the latest version(s)

hello so couple days ago my nvidia 630 gt graphic card fried and i got it replaced by radeon rx 550 card and im having troubles.

i tried uninstalling radeon rx 550 series drivers in "device manager" then installing the newest drivers from amd website, when installing the radeon software it says my drivers are up to date but when i try and open AMD settings to configure my pc to have more fps rather then 60 in games i get an error saying "radeon settings and drivers do not match. please try again after updating to the latest version(s)". tried uninstalling and then re-installing the drivers, the radeon software but every time i still get the same error.

my pc specs:

  • AMD Graphics Card
    • AMD RX 550
  • Desktop or Laptop System
    • desktop
  • Operating System
    • windows 7 profesionall
  • Driver version installed
    • Radeon RX 550 series 24.20.11021.1000 shows in device manager
  • Display Devices

    • LG monitor 1680x1050 @60Hz i also have a displayport to VGA adapter because i dont have the right cable for my monitor-pc right now

  • Motherboard + Bios Revision
    • Asus system type x64 based pc system model: all series
    • intel core i3-4130 CPU @ 3.40 Ghz (4CPU's) - 3.4 ghz

  • RAM
    • 4GB
5 Replies

Issue is being investigated by AMD, try the workaround on page 10 Radeon settings version and Driver version do not match. Please try again after updating to latest v...

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

someone can close this topic, thank god I found another solution to fix this from other person.
I will copy-paste how to fix this here so maybe less people would have to struggle for 2 or more days trying to fix this annoying thing

Confirmed working 100%.


Such a simple thing that could've been debugged months ago now when first reported.

Solution (for those who have never used regedit before):

First, If you have "RadeonSettings.exe" process in Task Manager, kill it ("end task").  I had to do that because once it displays the message, it silently stays running in the background.  To launch task manager, right click on the task bar and "start task manager."  Scroll to see if you can find radeonsettings.exe  If you can, highlight it and "end process."

Go to start\run (or start\"search" if you don't have run showing)
type "regedit" without the quotes
If you've never used regedit before, you'll probably see "Computer" and then a tree of stuff underneath.
Once there, on the right side, find the string which says "DriverVersion"
Double-click on the name.  A window to edit the value should pop up.
Erase the value (should be 26.some numbers I don't remember).  Click "OK."
There's no need to "Save" - changes in regedit are instant.  Just quit the program.

Try launching settings again - should work perfectly now.

Laugh at AMD engineers and lack of expertise for such a simple issue.

As I suspected, it turns out you don't need to use driver cleaner, you don't even need to install drivers using the "clean" option, and most certainly you do NOT need to "format your system" or "upgrade to Windows 10" - absolutely ridiculous and mostly worthless advice for advanced users.

Thanks.  I'll repost in this thread if this resurfaces in the future.

P.S.  To do this, I'm pretty sure you need an admin account, elevated permissions for regedit, etc.  If you don't, ask the person who does to fix this :-) .

Community Manager

We have been trying hard to reproduce the issue and would like some information from those still experiencing it.

Please provide the value in this registry key BEFORE you erase it:



Journeyman III

Hi ,

Go to Display Driver Uninstaller (DDU) V17.0.8.7 Released! - Wagnardsoft Forum

Download Display Driver Uninstaller.

Follow the instructions to download, install and run, and when you run it, you need to be in Safe Mode, otherwise, you have not have a Good Experience using it.

Then reinstall the Graphics Drivers again using Normal Mode, but don't install Raptr. Remove the Check to install it. So you need to install the Graphics Drivers, using Custom, not Express method.