Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

[Solved]Vega Blender Cycles split kernel error; Invalid ray state caused by subsurface

Solved edit

Just use the pro drivers


Rendering anything with Cycles in Blender with any Subsurface material property is causing a "split kernel error - invalid ray state". Render Preview mode closes Blender with no error messages

Occasionally, Render Preview will appear to be working, with the correct settings. It does, however, perform as though it's still using CPU rendering. Attempting to render scene when this happens will  "successfully" complete a render. The rendered image will be of black, white or noisy squares (attached).

I have not been able to ascertain what causes either of these failure modes.

I'm using Blender 2.90.1 (hash 3e85bb34d0d7), and have tried 2.91.0.

I'm running a Vega 64, with Driver Version -

Searching for similar errors only finds posts years old from a time before the GPU could do subsurface

Steps to reproduce-

1 Open Blender 

2 New File  - General

3 Add subsurface material property to default cube (any quantity / colour not needed)

4 Edit - Preferences - System - OpenCL. Ensure Vega 64 is checked

5 Render properties - Render engine - Cycles

                                 - Feature set - supported

                                 - Device - GPU compute

6 Press "F12" /  Render - Render Image

I'm exceptionally new to Blender; apologies if I've missed something obvious.

Let me know what else I can do to help,


Tags (2)