Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

[SOLVED]AMDKMDAP keeps crashing again and again

S I am currently at a dead end. Whenever I try to game it will crash totally randomly, it will even crash sometimes when I am just surfing the web. Here is my setup:

 -CPU : AMD Ryzen 5 2600 6 cores
-RAM: 16 GB Corsair vengeance 2400 mHz
-GPU : Sapphire Nitro+ Radeon Rx 580 4Gb
-Mobo : MSI B450I Gaming Plus AC mini ATX
-PSU : SeaSonic M12II 520 Bronze Evo Edition
-SSD(on wich the os is installed) : SAMSUNg SSD 850 evo 120 Gb
-Hdd (On wich i installed games) : Western Digital Blue 1 TB

Here is an exhaustive list of what i've already tried to troubleshoot/fix this problem that is frankly giving me multiple headaches:


-Switched PSU for another still have the problem(my PSU run perfectly well on older build)

-Switched graphics still have the problem (tried my graphics card in an old build, works fine)

-Switched MOBO for a brand new one, still the same problem)

-RMAed my RAM for new sticks, still the same problem:

-Swapped my HDD for another, still the same problem

-Installed my OS on another SSD, still same problem

-Couldnt swap my CPU but ran prime 95 for 8 hours straight, without one single error


-Ran memtest86, no error,still have the problem

-Ran prime95, no error,still have the problem

-Uninstall using DDU, then reinstalled the drivers from AMD website,still have the problem

-Uninstalled windows and reinstalled it, still have the problem

-Installed Ubuntu, still got the problem when running benchmark on it.



Here is a screenshot of the windows event viewer when it crashes. Any help would be immensely appreciated, I've been stuck with this problem for well over 3 months.


SOLVED: The problem was a faulty RAM stick, I can't believe I RMA my original sticks and they sent back 2 broken one... I guess I will have to RMA it again

15 Replies

This is tOC version GPU. Set core clock speed value from 1411MHz to 1340Mhz with WattMan. The problem will probably be solved.
Annotation 2019-10-03 101833.png
The image above was taken from a different website and I marked the core clock speed difference.


Where do I lower it in wattman?


OverdriveNTool software is compatible with RX 580. You can make necessary changes using this software. With this software, change P7 state value from 1411 to 1340. If that doesn't work, use RX 480 standards. RX 580 GPU comes with 2000Mhz VRAM not 1750Mhz. Sapphire may even be selling the graphics card with RX 580 BIOS using the RX 480 GPU. Sapphire RX 5xx GPUs have many problems. So I took a screenshot of RX 480 standards.
Annotation 2019-10-03 104947.png


Ive found how to lower it in WattMan, still have the same problem(lowering the max clock even made the crash a bit weirder, screen got green and teard up before shutting down and reopening) and I can't install AMD overdrive because I get the AODDriver.sys BSOD when i install it (i then need to uninstall it in safe mode)


Apply values in the picture I shared with OverdriveNTool software. You can find this software using Google. Changing a single value may not solve the problem.


Well Onedrive isnt supported with ryzen cpu so I can't even install it, I am goinng to set those values in Wattman and see how it goes


The programs that you wrote with OverdriveNTool are different. The program you specified does not work anymore.


Changed all the values, still get the crash!


Change GPU core power to -30% with RX 480 standard values. Reset WattMan settings first. If these settings work, your PSU is insufficient, I think.



Exact settings I Used and  Overwatch crashed as soon as i joined a game. As i said orignially, ive tried a different card(an old sapphire r7 r70) and i get the same exact message, I don't think this is related to power consuptions of the card


If there is crashing though you make core power to -30%, your PSU probably doesn't have a problem. 
Test the GPU for 15 minutes with Furmark (800x600 without AA and with 8x AA). What is the maximum temperature? Does Furmark test cause a crash? Reset WattMan with OverdriveNTool software and try these. Use your Testing profile if it crashes.


Ran 2 test, one with AA off and one with AAx8, Not a single crash, but i got a crash during the 30 minutes between both(i was surfing the web) temp got to 79 max during both tests!


Try this driver. Also with WattMan, set 1411Mhz to 1340 (standard). This driver is more stable. And I think you won't have problems with standard value (1340 not 1411) and this driver. Despite all these things, if the result is the same, there is a different problem. I can't decide what the problem is and I can't help you.


Thanks for the help but problem still persist!



did swapping the RAM actually Helped?
please let me know.
its been a year now that im suffering from same fate.
thank you