Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

sleep/wake up problems

Hey all,

I just built a new machine with the following config:

- B450M Mortar (updated to newest bios: 7B89v13)
- AMD R5 2400G APU
- 16GB (2x8) G Skill Aegis 3000Mhz RAM
- Be quiet! pure power 10  600W PSU
- Philips 276E8VJSB 4K IPS Monitor (connected via HDMI)
- Windows 10

Everything works fine after updating to 1.30 bios and installing Adrenalin 19.1.1.
But two things are confusing me:

1st issue:
The machine doesn't wake up from sleep mode correctly.
My monitor stays off.
Motherboards LEDs turn on and the CPU fan starts spinning.
The CPU debug led lightens up.

Got to press the reset or power button.

Clearing CMOS brought no result.
Reverting to previous bios didn't help.

2nd issue:
I set Win10 to turn off my monitor after 5 mins of idle.
But after it turns off, it turns on again immediately and shows a black screen.
I can return to windows by moving my mouse or pressing a key on the keyboard.

I tested my monitor with my laptop and it went off without any problems.
So it seems to be a problem of my new machine.

Does anyone know whats wrong with my pc?


16 Replies
Adept II

Also I noticed that when I clean out all AMD drivers, clear CMOS and boot up with default settings, everything works fine.

But after enabling Windows WHQL support in BIOS  or/and  installing AMD drivers, these two problems appear again.

Any ideas?

Adept I

I'm having the same issues! Fresh install of Windows 10. When windows automatically installs the drivers for me, it installs 17.1.1. I have no wake issues from sleep, takes like 2-3 seconds.

When I install the latest 19.1 or 19.2 after doing a full uninstall and clean, I get issues waking from sleep again. Takes about 30-45 seconds with a bunch of screen flickering.

I plan on trying the latest version 18 to see if i also get sleep wake issues.


tried 18 and still got the same issue. it seems all Adrenalin drivers are causing sleep wake issues for me. I rolled back to the latest Crimson 17.11.4 drivers and the issue goes away.


Thank you for your reply!!

Which hardware do you have?

(i found your info)


I solved my computer sleep problem.

What i did:

Adrenalin 19.1.2 and the latest chipset drivers (18.10.1810) were already installed on my computer.

Today i decided to check the chipset installer once again.

I was quite perplexed when it showed all chipset drivers "not installed" (see custom install --> hover mouse cursor over each driver ). So i installed them and rebooted.

I also found an article that says chipset drivers version 18.10.1810 isn't up to date anymore. LINK (german website)

The new version is 18.50.06 and (for unknown reasons) it is only available on the ASUS support website.

Only two things were renewed since previous version:

- AMD GPIO Controller   (old:

- AMD PCI Device     (old:

I took these two drivers from the link above (to avoid installing the whole driver package ~370MB)

and updated directly through the device manager.

After a restarting windows and assuring everything works well I went into bios and flashed it once again (same version).

Then booted into windows with default bios settings.

Tried sleep mode --> It works!!!

Went into bios, loaded my saved settings, started windows

Tried sleep mode --> Computer gets lost in sleep again. (won't wake up properly)

Went into bios, loaded bios defaults, started windows

Sleep mode --> It works!!!

Went into bios and set everything what i need manually, without loading MY saved settings. Started windows

Sleep mode --> It works!!!


Hallo all

I too have problems with resume from standby with the latest drivers installed: 19.4.1.

Following your advice I updated the chipset (B450) drivers from the Asus website and then updated later with the new version available on the AMD website: 18.50.0422.

I then re-flash the bios with the V1002 and loaded the default parameters, started windows and everything ok: PC goes on standby and wakes up correctly !!

I then returned to the bios to start setting my parameters, which have always worked with the my previous video drivers (19.2.3).

Meanwhile I activated the profile D.O.C.P.  #1 to work at 3200MHz with my ram (as I have always done), I saved and restarted and... the PC goes into standby, but does not wake up properly..

I returned to the bios to cancel the DOCP #1 profile, but nothing to do: the PC never wakes up correctly from standby..

I tried to re-flash the bios again with the exact same version 1002, default parameters and.. so it works.. but, as soon as I set my profile DOCP #1 there is no more towards: something gets dirty..

All this makes me think that the standby function is currently very fragile on AMD.

My system spec:

CPU & GPU: Ryzen5 2400G

MB: Asus b450M-A

RAM: 16GB DDR4 3200MHz HyperX HX432C16PB3K2/16 

Journeyman III

Do you still have these issues too?
I have the issue also with version 19.3.3. 


Only my second issue still persist.

I still cant get my monitor into standby mode.

Backlight won't turn off.

I gave up installing new drivers every few weeks, because i'm busy with other things and aslong my machine works stable (except that monitor bug) i'm quite contented.

Btw. Adrenalin 19.4.1 is released... But the changelog doesnt show anything concerning our problem... I think i wait for the next one...

I already tested Adrenalin 19.4.1. now and at first I really thought it would solve the issue. The first 15 times everything worked well and my pc+monitor woke up from sleep mode.

Now I just had again the same problem - the graphics did not wake up from sleep - it is really getting on my nerves. I downgraded now to version 17.11.4 and hope that that will solve my sleep-mode issue. 

AMD should be ashamed. Next time I will definitively by Nvidia instead...

Having similar or same problem, 1 of my dual monitor stays black when windows 10 wakes up from sleep mode.

I tested up until driver 25.20.15016.1002 included in new chipset driver, did not tried new 19.4.1.

Last driver working for me is 18.9.3.

Using Raven ridge 2400G, ASUS TUF B350M(tested multiple firmware), 16GB, Windows 10 (1803, 1809)


Try disabling fast start. Read this please > The Pros and Cons of Windows 10’s “Fast Startup” Mode 

How to Enable or Disable Fast Startup

Deciding whether to bother with Fast Startup actually takes longer than turning it on or off. First, open up your power options by hitting Windows+X or right-clicking your Start menu and selecting Power Options. In the Power Options window, click “Choose what the power buttons do.”

power options

If this is the first time you’ve messed with these settings, you’ll need click “Change settings that are currently unavailable” to make the Fast Startup option available for configuration.

available options

Scroll to the bottom of the window and you should see “Turn on fast startup (recommended),” along with other shutdown settings. Just use the check box to enable or disable Fast Startup. Save your changes and shut down your system to test it out.

fast startup

If you don’t see the option at all, it means hibernation is not enabled on your machine. In this case, the only shutdown options you’ll see are Sleep and Lock. The quickest way to enable hibernation is to close the power settings window and then hit Windows+X and open Command Prompt (Admin). At the Command Prompt, type the command:

powercfg /hibernate on

After turning hibernate on, run through the steps again and you should see both the Hibernate and Fast Startup options.

Journeyman III

I had a same issue with monitor sleeping. (Gigabyte AB350M-HD3 and Ryzen 2400G). I tried every bios with every vga driver, and only one worked: 2019/09/25 vga driver with any bios. But this driver had another problem, the embed video reloading with green tint. It was repaired by AMD at the end of 2018 or early 2019.

My solution is: changing the cable. I connected the monitor with a dvi-d cable, and the sleeping problem has gone. I can use the fresh vga drivers. The previous hdmi cable is working fine in another computer :-)

Adept I

Might early to say, but after updating windows 1903, my monitor is waking up ok, windows 1903 installed Microsoft driver, it worked ok. Now I updated to AMD 19.6.1(26.20.11015.9003), still waking up ok. Fingers crossed...

With 19.6.2 problem came back again. Using 2 monitors on vga and dvi port, dvi no problem, vga stays black after about 10min of standby. At least now I have newer driver 19.6.1 that I can live with, a big jump from 18.9.3.

Journeyman III

Im sorry, my answer related to zemuan's 2.nd issue, when the monitor in stand by mode gone black, but the backlight wont turn off. I tried to find solution (clean windows install with windows 10 1809/1903, different bios and vga drivers), the cable changing was the key.

thats the solution for this problem!

I connected my monitor with a displayport cable and now everything is working fine!

It seems to be a HDMI driver problem.. I read somewhere the HDMI audio channel stays active when going into standby mode, what leads to this problem.

thank you very much!