Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Sleep/wake up problems AMD setup - 3900x/RX580

My problem looks a lot like this one:

My system:

Asus X570 Prime - 3900x - 64GB 3200Mhz (XMP and voltage is set to correct value) MSi RX570 8GB ARMOR OC / ASUS RX580 8GB OC GAMING, Western Digital Black SN850 1TB and a Corsair RM750x. I use 4x16GB Crucial Ballistix Sport LT BLS8G4D32AESCK. Using 2x8GB different brand doesn't make a difference.

Windows 10 Pro is fresh installed and completely updated. Adrenaline version 21.6.1. MB bios is also the most recent.

My monitor is a HP Z43 connected with a DP cable. HDMI cable doesnt solve the problem. When i connect the monitor to my laptop this problem is gone. I also have tried a different monitor.

My computer also doesn't wake up after sleeping after about 15 times (like in the link mentioned). I have tried different DP cable, tried 2 GPU's also tried different PSU.

I have used and disabled FAST boot, no difference.

I have disable PCI-E Link power save (don't remember the exact correct name). Also no difference. I have turned AMD high performance powerplan on.

It is really driving me crash, i don't wanna say it but even though i really like the 3900x i will probably switch to an Intel setup.

I need and should be able to use the sleep mode. I often get a call and need to quickly be able to use my computer at that point.

I really hope someone has got a solution for this problem, which looks to be around for quite a while now. Isn't there an answer or reaction from AMD employees yet? It is quite clear this is an AMD issue in my opinion... i also have used an older Intel setup as a test but than there is no problem.

Well not this problem, the problem that it is still an INTEL is of course at that point still there (just kidding of course).

3 Replies

Windows 10 uses a new modified sleep mode.   It is deeper than the old S3.

The PSU  ATX 12V  V2.51 standard  and beyond support this new deeper version of sleep.

Most power supplies you buy today are ATX 12V V2.4 which can give you trouble with this deep sleep.

In my GIGABYTE BIOS I have a setting "Power Supply Idle Control"  (Auto. Typical Idle, Low Current Idle)

I believe you should find a similar setting in your bios and set it to Typical Current Idle.

Good Luck



Looking at this it seems your are right. My PSU is a 12V v2.4.

Let me see if i can find that BIOS option on my ASUS mainboard.

It is a bit strange right? All of the often used PSU's at the moment are V2.4. Do you know a PSU that is V2.51 (or 53 which seems to be the lasted)?

I mean if you kind of sure this is the problem, i might even buy a 12v V2.53 PSU, but like i said all the major brands and common used PSU's seem to be V2.4...

Adept I

Been awhile. Any with new suggestions? To just buy a 2.53 PSU (around 200/250 euro) seems a bit much, with a bit more conformation.