cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

tuanle_ftu2
Journeyman III

Sapphire RX 5600 XT - Card stopped working after driver installation

I've purchased Sapphire RX 5600 XT. When I installed the driver, the card stopped working (fan stopped working also), screen flickered, then BSOD, then no signal to the screen. I had to hold power button to restart the computer. Then when the computer restarted, everything was ok in bios, but when windows was loaded, the same things happened. I had to reinstall the window to get rid of the error. When I tried installing the drivers again, the issue persists.

I've tried the following, but nothing fixed the issue:

- Install the card through vertical riser and not through vertical riser

- Install the drivers before and after card bios update

- Reinstall the window and redo it

- Try all three versions of the driver for 5600 XT

- Set PCI Express mode from Auto to GEN 3

Is my card faulty?

My build is:

Motherboard: ROG STRIX ASUS B450-I

CPU: Ryzen 3600

Ram: 16GB @2666

0 Likes
26 Replies
ezemeriggi
Adept I

Re: Sapphire RX 5600 XT - Card stopped working after driver installation

I have the exact same issue with the Gigabyte Gaming OC.
5600xt it's awful so far.
I think I will have to return it because I cannot find any solution so far

0 Likes
eliandre
Adept I

Re: Sapphire RX 5600 XT - Card stopped working after driver installation

I have the exact same issue with the Sapphire RX 5600 XT.

While I try to install the drives, the PC crashes, then it does not boot anymore.

Tried every BIOS and driver possible. It happened after one Windows Upgrade.

0 Likes
pimboril
Adept I

Re: Sapphire RX 5600 XT - Card stopped working after driver installation

Hi, hoping to help u... 
I had this problem, and i returned the card to rma... 
then they told me that the card worked fine... 
So i discovered that the driver was the issue... the mother will post but after loading windows ...the display goes black and gone. but in my case windows was loading and starting up... so i was able to do things... like remote desktops... 
So i ddu`ed the drivers and.... that recover the display after reboot....so then installed a older version of the driver and here i am., Now i have the most common problems like downclock, but i can use the pc.

0 Likes
igamer
Adept I

Re: Sapphire RX 5600 XT - Card stopped working after driver installation

I have this exact same problem with my 5600 XT Pulse. The only way to get back into windows was going safe mode, uninstall drivers with DDU and reboot back into windows. But once I try to install any of the Adrenalin 20.x.xx drivers it will black screen during the installation and not respond. It will freeze on windows load screen if I tried to reboot.

This card has been working fine for over a month and only started doing this recently so it could have been the 20.3.1 drivers or a recent windows update?  But reverting back to previous drivers and uninstalling recent windows updates did not fix it.

Things I've tried and have not worked-

  • Fresh install windows 1909 with no updates + drivers  20.1.3, 20.2.2 and 20.3.1 DDU, between each install
  • Fresh install windows 1909 with all updates + drivers  20.1.3, 20.2.2 and 20.3.1 DDU, between each install
  • Tried the same on a different machine with same results (have both AMD and Intel systems albeit old)
  • Switching between silent and performance bios
  • swapping ram modules
  • tried different power supply
  • setting PCIe3 in the motherboard bios
  • unplugging all non essential peripherals

It will work and load into windows using the generic windows display driver. So... I've reverted back to my

old RX 580 on 20.3.1 for now.

0 Likes
benyslo
Journeyman III

Re: Sapphire RX 5600 XT - Card stopped working after driver installation

Hi,

Has anyone found any solution yet ? I have the exact same issue on my 5600 XT. I started having this same problem 2 weeks ago but i'm not sure if after driver or Windows update. So for a few weeks i managed to get to Windows but only after making about 10 restarts. Yesterday i didn't managed to get in anymore. I then tried to go to safe mode (which works) and like you guys deleted the driver and worked with Windows Display driver. I then tried to install every single old 5600 XT driver but everytime the Windows went black and Windows wouldn't boot anymore. I also reinstalled Windows 10 1909 twice and on the last attempt i didn't even get to first login anymore. Now i have Windows 10 1903 ISO on my work computer and i will try and install it and report back to you guys with results. And if you have any other solution please share

EDIT: Good news guys. After installing Windows 10 1903 from a year old ISO i immediately disabled Windows update service (also from startup) and installed latest drivers (20.4.1). No black screen and Windows is also booting without problem. Now i did change one more thing so i can't say for sure which one helped but i'm guessing the Windows one. Before installing Windows 10 i changed boot from CMS to UEFI in BIOS. I tried changing this when i first had problems but the Windows didn't even boot to loading screen and it only worked when installing fresh installation.

igamer
Adept I

Re: Sapphire RX 5600 XT - Card stopped working after driver installation

Unfortunately I don't have an older installation of windows 10, but this confirms it is Windows 1909 and AMD driver problem. Thank you for posting this information

0 Likes
zodiaccc
Journeyman III

Re: Sapphire RX 5600 XT - Card stopped working after driver installation

I am having the same issue. I'll try to roll back to Windows 10 1903 ISO and edit this.

I also don't have 5600, I am using r9 390. But my problem is same with you guys..

EDIT: nope, I did clean installation of Windows 10 1903 18362.30, but I am still having black screen after a few minutes when I enable my graphic card.

0 Likes
marcelma95
Adept II

Re: Sapphire RX 5600 XT - Card stopped working after driver installation

I have an identical issue to all of you. MSI RX 5600 XT MECH OC. I have been completely unable to find a solution that allows me to boot up into windows without using safe mode or previously uninstalling AMD drivers. I have however found a way to subvert using the ATROCIOUS adrenaline 2020 software that AMD tries to force us to use when installing drivers. In doing so, I am able to install the AMD drivers, but I must remember to uninstall them before turning off the PC or I will have to boot into safe mode. To do this just download the driver, run the program, select install, and then when the adrenaline software opens up and asks you to install, just hit cancel. Then you install the driver in device manager by updating the Microsoft basic display adapter. 

Still, this is by no means a solution, it is absolutely absurd that AMD would treat its customers so horribly. For months these issues have plagued the 5600 and 5700 series cards, rendering the majority of them unusable. The fact that I need to install and uninstall the same driver every single day, only to still experience frequent crashes, is just a middle finger in the face of the entire PC gaming world. This is why people buy consoles and why I will probably never purchase an AMD product ever again. 

0 Likes
awpii
Adept II

Re: Sapphire RX 5600 XT - Card stopped working after driver installation

Try this YouTube , fixed it for me.

0 Likes