cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

soon11
Adept I

Samsung CFG70 with FreeSync enabled won't display BIOS during boot up

I recently purchased a Samsung LC24FG70 monitor, with freesync enabled in the monitor settings and gpu driver(RX 480 on driver version 20.2.2 WHQL) settings, the monitor will skip BIOS during boot up (and the beep sound my motherboard makes before the BIOS screen also disappears), instead, the monitor will only display until windows 10 is loaded to user login display there.

With freesync off however, the motherboard makes the beep sound and monitor displays the BIOS screen during boot up, and everything is normal.
The weird thing is, before this I was using Samsung LC24F390, which is also curved monitor with freesync, I have no problem with freesync enabled, via HDMI as well.
My complete specs
CPU: i7-6700k
Motherboard: Gigabyte Z170x gaming 5 (BIOS version: F22f(latest))
RAM: 16 GB
GPU: Sapphire nitro+ RX 480 8GB
Connection to monitor: HDMI cable (comes with CFG70 monitor)
OS: windows 10 1909
Here is the link to the video that captures the issue when FreeSync is enabled, and also captures what normal boot up looks like when FreeSync is disabled.
Is this a known issue? if it is, is it fixable via software update? amdmatt
Update 1:
A clearer video
0 Likes
4 Replies
elstaci
MVP

Re: Samsung CFG70 with FreeSync enabled won't display BIOS during boot up

If your other monitor Samsung worked correctly with Freesync on and this new Samsung Monitor doesn't. It seems like it is a problem with the Monitor more than the AMD driver.

Your new Samsung Model is really about 3 years old according to the Driver and software download section of Samsung Support.

I noticed you enable Ultimate Engine Freesync instead of Standard Freesync. It is possible that Ultimate Engine is not compatible with your new Monitor. Try using Standard Freesync and see if it boots correctly.

Also check the Monitor's settings to see what is has for Freesync and see if you have the latest Samsung Monitor driver installed.

From your Samsung Manual concerning Freesync:

soon11
Adept I

Re: Samsung CFG70 with FreeSync enabled won't display BIOS during boot up

Ultimate engine or standard engine for FreeSync produces the same outcome. I know this is a 3 years old monitor, so was my Samsung CF390, they were out around the same time, CFG70 is the higher tier curved monitor with Quantum Dot and 144 refresh rate support. although I don't utilize the feature offered by the latter.

So naturally, I assume it will work without hassle, since CFG70 is supposed to be higher tier monitor than my old Samsung CF390, which I also used Freesync ultimate engine on. And apparently I was wrong. Dead wrong.

0 Likes
elstaci
MVP

Re: Samsung CFG70 with FreeSync enabled won't display BIOS during boot up

Found this AMD site that lists all Freesync Monitors. May not be up to date but I believe both of your models are listed: https://www.amd.com/en/products/freesync-monitors 

There is no LC24F390 but there is C24F390FHC also there are two Models but one has C27FG70 the other is LC27FG70FG but both have similar Freesync in the matter both Freesync only works on Display Port outputs. The other monitor you had Freesync worked both on Display Port and HDMI

See if connecting your new Samsung to Display Port you are able to see BIOS when it boots up.

Also try installing a previous AMD Driver in case it is a problem with the latest version unless the other Monitor works with the current driver.

You can download a previous driver (~6 mos) from here: https://www.amd.com/en/support/previous-drivers/graphics/radeon-400-series/radeon-rx-400-series/rade... 

amdmatt
Community Manager
Community Manager

Re: Samsung CFG70 with FreeSync enabled won't display BIOS during boot up

Might also be worth trying to toggle CSM (compatibility support mode) on/off in the BIOS, and to put the monitor OSD panel back to default settings. I suspect the BIOS is using a resolution which the monitor perhaps does not support and that causes the black screen. Try toggling the various options in the monitor OSD to see if any of them helps to produce a display in the BIOS. 

FreeSync will not be active in the BIOS, so for now you may just have to toggle it off via the OSD if you venture into the BIOS for now.