Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Ryzen Master is still NOT working!!


First my system is:

CPU: Ryzen 7 2700X

RAM: G.Skill Ripjaws V F4-3600C16D-16GVK

MOBO: AsRock Fatal1ty X370 Professional Gaming

GPU: EVGA GeForce GTX 1080 Ti SC Black Edition GAMING iCX

OS: Windows 10 64bit v1903 (no insider program)

BIOS: Latest version 5.30

DRIVERS: Everything is up to date and the latest version!!!!!! Including the chipset drivers! Except for RM...

So, I download all Ryzen Master programs from my CPU's driver page. So it has to work on MY SYSTEM, right?

Well, it's not working!! Nothing works anymore!

The last working version of RM is 1.4.0, and it's from ages ago..........................................

Versions 1.5.0, 1.5.1, 1.5.3, 2.0.0, 2.0.1, none of them work!!! Nor through install, nor through 1.4.0's update!

And all of them give the same stupid error message: "a newer version is already installed"..........

It wasn't working even before the update to Windows 10 v1903.

-I uninstalled the old one and tried clean install. Not working.

-I deleted every registry and folder on my system related to Ryzen Master. Not working.

-I used the Windows 10 Install/Uninstall Troubleshooter tool. Not working!

-I used the AMD uninstall everything tool. Still not working!!!

Why is it NOT WORKING??? What did you do? In god's name, FIX IT!!

People are complaining about this error since version 1.5.0!!!! How the hell you did not fix it yet???

FIX  IT,  PLEASE!!!!!!!!!!!!!!!!

13 Replies

Your BIOS up to date?


Yes, I have the latest BIOS for my motherboard, v5.30.


Have you tried the one here? It works just fine for me. I even uninstalled and reinstalled it. Maybe try Revo uninstaller to clean it up? Along with CCleaner?ryzen_master.jpg


How is YOURS different than MINE?

Also, did you not pay any attention? I said I cleared ALL my registries and deleted ALL the folders on my system, related to Ryzen Master!!!

IF you don't read or pay attention to what you read, then please don't reply to people giving them "advices"!

Trust me, I know more than you guys. I just wrote here hoping I'll speak to a developer from AMD, not your usual user... Sorry.


Calm down. I paid attention. For the record I'm not your typical user either. If you need to match credentials I could do so very easily. I asked this question because it seems obvious you have an installer error. These are typically caused by left over remnants due to a bad/outdated uninstall process. 

I'd advise swallowing your pride a bit and using Revo anyway. Followed by Ccleaner. But feel free to talk down to me more. I'm sure that will get you many responses to your problem.



Swallow my pride? What are you talking about?? Dude, I was doing this since the 90s!

And calm down for what? I wasn't arguing.

Well DOH it's an installer error, you don't have to be a genius to figure that out.

As for your precious programs, they are crap. I was playing with them since I was a kid. They aren't MAGICAL.

I stopped using cr-apps loooong ago.

What I do, as I said in the original post, I MANUALLY go into the registries(if you know what that means) and deleted EVERYTHING related to ryzen master.

Then in total commander with hidden files on, I deleted every folder related to ryzen master.

Now, what exactly do you want ccleaner to delete in the registries, if I already deleted it?? Same with revo, it did not find any traces of ANYTHING. Yeah, "I swallowed my pride" and installed them. And what a surprise, they didn't do anything.

As for revo, I used to use advanced uninstaller.

I installed the old version 1.4.0, just so they have something to uninstall and delete again. And it still didn't do nothing.

Now mr "I'm not your typical user either", please explain that.

I wanted to talk to a dev, because only they know what they did.

No, it's not the container, and it's not the way they compile everything into the installer, either. As other people can use the same installer with no issues.

It's a freaking mystery... And only a dev knows what the hell is going on.

You are welcome to help figuring this out, everyone is. But we are mere mortals and can not comprehend the complexity of the, ah the hell with it, I got nothing.................

I wanted the new version because it seems it lets you overclock the infinity fabric as well.


Reading this thread, sometimes it is difficult in finding all related registry entries and files when manually uninstalling a program.  Even using FIND in locating all RM entries in the Registry. 

It seems like when you try to install RM, the installer is seeing a reference in the Registry saying RM is already installed. Of course, you already know this but just mentioning it because of my next suggestion.

If you did a clean Windows 1903 update then ignore the following advice:

This is a drastic measure, but I would do a clean Windows 1903 installation. Then try to install RM again before installing any other 3rd party programs. If it installs that means there was a left over registry or file that you missed. If it doesn't install with the same error, then it means something RM Installer is not compatible with Windows and you should open an official AMD Service Request to see what they suggest from here: Online Service Request | AMD .

Otherwise, I have no other advice except to make sure Hyper-V or Sandbox (1903) (VBS) is not enabled. RM won't install if it is enabled. But that would show a different error message.

I was going to suggest entering into a Clean Windows Desktop with all 3rd party programs disabled and see if you can install RM. But if it is a registry issue or vagrant leftover file then that won't work.

My reasoning is, if you do a clean Windows 1903 installation before installing any 3rd party programs, this will eliminate any conflicts with other drivers or programs. If it still doesn't install, at least you know it definitely is a RM Installation issue thus open an Official AMD Service Request.

I know sometimes if a failing Hard drive or SSD could cause software corruption when installing a program but that doesn't seem to be the case with you.

Good luck


It wasn't a clean update, as you say it. And I know it will work on a clean install, it always does.

But the damn thing didn't want to install on the previous version of Windows either, 1809.

I had version 1.5.x installed, and seeing the update doesn't work, I uninstalled it and tried clean install. And of course, that did not work either.

You know what's funny? Is that ANY version below 1.5.0 will install without ANY problem. And this means my registries aren't fked, nor the Windows installer service. Because if they were, then I'd get this error on ALL versions of RM, including version 0.0.1b.......

So in the end, I guess their installer IS broken. :(

And the error is r*tarded... It says there is A NEWER version already installed. It doesn't say it's already installed, but a newer version is installed.
And it's r*tarded because I can install an even waaay older version of it, without getting that error. Which is r*tarded AND frustrating!!!!!!!!!!


Please keep this discussion on this thread civil and refrain from using offensive language. Members participating in this thread are trying to be helpful, there is no need for you to attack them for doing so.


I guess you are a moderator here. Cool.

But if you read that carefully, I wasn't using "offensive language" on anyone. Everything was directed to and only the issue itself, which I still stand for what I said. An issue of this magnitude, and it's still present after all this time and these updates........ Ryzen Master is not PUBG!

I will hold back my offensive language. But the issue will persist, if AMD won't fix it. I just realized, AMD is very bad with drivers......guess it translates to all software.


Also, I don't have Hyper-V installed at all. And Sandbox is actually good to have, it doesn't block you from installing programs, but rather install them in a safe "environment" in case they are malicious.

Everything about all of this is stupid!


You clearly have ego issues and/or anger management problems. I'll let you wallow in your failure. For the record, I'm 49. I've been building computers since 1982. I have a masters degree in IT and I'm a mainframe analyst by profession. I won't go into how many computer languages I can code but you get the picture. 

You really are quite the prize. I honestly haven't seen your level of hostility ever. You certainly win a prize for that. 

Searching the registry for "Ryzen" isn't going to remove all traces of an install. Especially values encoded in hex. Revo and/or other registry cleaners remove more than you can do with F3 and your search. 

Enjoy your failure. I'm done here.