Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III
Journeyman III

Ryzen Master Installer issues after upgrade

I recently upgraded from a Ryzen 7 1700 to a Ryzen 7 3700X, after uninstalling the Ryzen master for the first gen chip the Ryzen master for my Zen 2 chip won't install.  It says installed successfully, but it's not doing anything.  I've tried a bunch of things and I'm out of ideas.

This is basically a clean install of windows, having just reinstalled and formatted my main NVMe the day before my 3700X arrived.  I saw an older thread when this happened to someone upgrading from a 1700X to a 2700X, but someone said it was fixed in a later release of RM.  I don't know if this is an AMD issue or maybe it's something about my specific hardware configuration.

Usually I wouldn't care, but there really isn't a reason for me to run an All core OC outside of blender and Adobe Suite.

Things I've tried:
Cleaning all of the AMDRyzenMasterVXX keys from the registry
Changing permissions on install directories
Changing the install directory.
Running in compatibility mode
Running with UAC completely disabled
Disabling all AV and Firewall software
Downloading the installer again to account for corrupted package

Specs(Will be changing as parts arrive/come out, new parts will be in parentheses):
AsRock X370 Killer SLI/ac (Gigabyte B550 Aorus Master)
32GB(2x16GB) 3200MHz G.Skill Trident Z B-die
Ryzen 7 3700X(Currently OC'd at 4.4Ghz all cores since I don't have profiles to turn it off when not needed)
RX 480 8GB (Powercolor Red Devil Vega 64 8GB, need the compute and fp64 that the 5700XT doesn't offer.)
Windows 10 Pro 1909

0 Kudos