Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Ryzen Master Driver Not Installed!

Hi everyone, 

Want to keep this short and sweet - I'm getting the post topic coming up asan error for Ryzen master. 

I've done the search into regedit for Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\AMDRyzenMasterDriverVxx and well, it just simply doesn't exsist. I have Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\AMDRyzenMasterDriver - but no Vxx version (xx obvously indicative of the version). 

Again, I've tried everything I can think of - uninstalling, reinstalling, trying the driver version in bin (I've read that that version is correct but the one in services isn't). Just can't seem to find a single fix for it at all and everything online says you need to delete old driver versions but they just simply do not exisit - at least not on the new build available from AMD. 

Help appreciated!

2 Replies
Journeyman III

I'm having the same issue.


I have tried the RegEdit fix, found excess registries but after deleting these, rebooting, reinstalling and then rebooting again I am still getting the "Driver not installed!" error.

I tried the bin folder like you mentioned as well and still no dice.

Running Rysen 5 3600 on a B450 Aorus Elite, Radeon RX 570 8GB, 32GB RAM. All drivers up to date, Windows up to date, ran CC Cleaner to make sure there weren't any random temp files messing with me. Still no dice.

Any other tips welcomed

Dice Please.


This worked for me.