Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Re: Ryzen Master does not start properly

Jump to solution

The QT_Dependencies\setup.exe issue still exists with ryzen master .

amdmatt‌ you mentioned this was previously fixed, but, it does not appear to be.

Can the version check be bypassed through an install switch or other way to prevent recurrence across new builds? This is a persistent issue for the last few years.

For anyone starting at the original reddit thread, it's dead - but was referenced here as well as other threads.

Journeyman III

Re: Ryzen Master does not start properly

Jump to solution

After installing AMD Radeon software almost all newly opened windows were 3/4 transparant.

Only the bottom-right of the window was not transparant.

After hours of trying to figure out (re-installing a lot) what the issue was i still couldn't find it BUT then just by accident i discovered something that's so freaking odd that it's still a mystery for why it worked.

The 'solution' : when you see a transparant window try to resize that window with your mouse by dragging the windows border while pressing the left mouse button.

That's it ... strangely enough.

There are more issues with the software and the worst is that you will encounter problems running open windows on the foreground.

Something is terribly wrong with the driver imo, it seems to be locked to load only 1 window at any given time.

I'm not an expert in graphics cards but i'd say that the whole memory management of a regular workload is utterly broken and unstable.

However, when i play games i get much better performances overall so i'm really clueless on this.

Luckily my accidental solution works as a workaround but it's not something that should be nescessary.

Journeyman III

Possible solution for ASUS board owners

Jump to solution

For all who own a ASUS board:


ASUS also provides a software named Sonic Radar.

This particularly useless baggage uses a library called Nahimic for overlaying the info.

But it also interferes with Ryzen Master (prevents install and start, you 'see' only a transparent window and one core at 100%), because ASUS is using an old version of the aforementioned Nahimic library.

Another sideeffect is that this version of Nahimic also interferes with any number of .netCore 3.1 apps (graphical glitches on mouseovers).


Solution: Uninstall Sonic Radar

After i did that, Ryzen Master worked just fine for me.


@AMDDevs: There are ways to block Nahimic from interfering at all, look them up.


Have fun, enjoy life

- Algorithman

Tags (2)
Journeyman III

Re: Ryzen Master does not start properly

Jump to solution

I have the problem after reinstalling windows, the Ryzen Master was installed and worked, since the it refuses to boot, this on a 2200g. 

I installed Adrenalin, the Radeon drivers were actualized, the adrenalin installed and performance center with GPU/CPU data also, supposably Ryzen Master too, but when i tried to open, it says RM is not installed. I try to install it from the link you gave, but it still wont work.  

It is disappointing to see the error was communicated back in 2018 and it is still not resolved. 


Journeyman III

Re: Possible solution for ASUS board owners

Jump to solution

Yes, its the same for me. If I disable the NahimicService and running processes, RyzenMaster starts up fine.

Seems the Sonic **bleep** keeps creeping in after last updates I applied. So deinstall Sonic stuff and stop the service is a work around solution. I don’t need and use the Sonic stuff, so its ok. But I guess Some people will need it, and RyzenMaster should check and act accordingly if it finds the nahimc stuff.