cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

KillerDonuts27
Journeyman III

Ryzen 5 3600 won't boot in dual-channel

I just upgraded from a Ryzen 5 2600 to a Ryzen 5 3600. I have been running the R5 2600 for about two years with the exact same hardware and have not had any compatibility issues with any of it or the software. I'm using the motherboard Gigabyte x470 Aorus Ultra Gaming (V1). RAM is supported by both the motherboard and CPU (HX432C16PB3K2/16). As of the upgrade to the R5 3600 I updated from BIOS F5 to BIOS F31 then BIOS F40. I can boot with F40 with only one RAM stick but my M.2 does not show up as my boot drive. I upgraded to BIOS F51 and can see my M.2 but can still only boot in single-channel RAM. If I run in dual-channel I get a boot loop and can not get into BIOS. I've tried each BIOS version and went through the steps many times with no luck.

0 Likes
3 Replies

Re: Ryzen 5 3600 won't boot in dual-channel

Check pins on cpu. Swap back to old and check if problem persists

0 Likes
elstaci
MVP

Re: Ryzen 5 3600 won't boot in dual-channel

The RAM Memory you have for the 2600 is compatible but doesn't mean it is compatible for the 3600.

You need to look at Gigabyte's Motherboard QVL List for the 3xxx Processor to see if your RAM is listed.

Generally if before 2 sticks works fine but now only one stick works does seem to indicate incompatible RAM Memory.

https://www.gigabyte.com/us/Motherboard/X470-AORUS-ULTRA-GAMING-rev-10/support#support-doc

Screenshot 2021-01-23 163957.png

0 Likes
mackbolan777
Forerunner

Re: Ryzen 5 3600 won't boot in dual-channel

Why all the BIOS updates? Did you upgrade the chipset driver prior to upgrading from F5 -F31? Then to go to F40 you needed to do: 2. Before update BIOS to F40, you have to install EC FW Update Tool (B19.0517.1 or later version) to avoid 4DIMM DDR incompatibility on 3rd Gen AMD Ryzen™ CPU 

Which is where you might have gone wrong and now have this RAM issue. you also needed to do F42g: 

  1. Update AGESA 1.0.0.3 ABBA
  2. Improve Destiny 2 gaming compatibility
  3. Correction of PCIe Gen4 being disabled when using a 3rd Gen Ryzen (Matisse) CPU due to AGESA change

That's why the M.2 is missing. From there you can go all the way up to F51 or even F60f but F51 is as high as you need to go. Fortunately, you have dual bios on that board, so you might need to put the 2600 back in to flash back to the beginning and redo this process. X470 AORUS ULTRA GAMING (rev. 1.0) Support | Motherboard - GIGABYTE U.S.A. 

You can download the manual there as well, makes it easier to read than a paper one. After you fix the BIOS updating all the way to the F51, you can then try installing the R5 3600 with the RAM and you should be fine but will need to reinstall Windows after putting the 2600 in to fix the chipset driver, since it doesn't update after O.S. install. I don't think you'll need to reinstall the O.S. after the F51 is done to put the R5 3600 in. Lotta work for that board to put a 3000 series in!

"It worked before you broke it!"