Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Ryzen 3400G Windows 10 constant crashes

Ryzen 3400g + Asus B450 a prime + 8gb X2 GSkill Ripjaw + Corsair 550w

Things done 

1) windows memory Diagnostic - full run - all good 

2) bios updated to latest

3) used two different windows build just in case one was faulty, March 2019 and Aug 2019 builds. (Pro Version) 

4) reinstalled windows 5 times 

5) reduced ram from 3000 to 2133

6) got Last released Graphics version for 3400g from Amd website (26.20.13003.1007)

7) got software option from Amd that detects automatically and gets best driver option 

8) let windows update driver that it seems as best option in windows update. 

9)did sfc scan some errors but checked logs some defender files. Did dism and got clean health. 

Sometimes runs for 1 min, sometimes at max 10 mins, sometimes crashes on start up itself.

Random freezes, black screens, no response situations, green screens, bsod (video scheduler internal error). 


Kinda really stuck.  

Any suggestions welcome. 

44 Replies
Adept I

I am not sure if it's software or Hardware issue?


Remove AMD display driver and test the CPU with prime95. Check temperatures. If you can't do this, the motherboard or the PSU is retired.

Thank you for replying 

System works fine incidentally if I remove the Amd drivers. No crashes no green screens no problems at all. 

Got the Prime95 as you suggested. How long should I do the torture test? 

Can you see the processor temperature during the test? Have you tried a different version of the display driver? Did you install the driver using DDU in safe mode? What changes did you make on AMD display driver and errors occur?

I haven't done the test yet , I just started it and realized it is a long process so unsure how long should it run?

Display drivers: I did a couple of things

1) I let windows find and update on it own - still crashed

2) I went to AMD downloaded its tool to "Auto Detect" and choose best for me - same result and crash

3) I downloaded "win10-64bit-Radeon-software-adrenalin-2019-edition-19.9.2-sep12" from Ryzen 5 3400G support page - same result and crashes

I did use DDU before, however in my defense. Today I installed Windows 10, went to my second drive installed straight away the Option 3, on freshly installed windows and same result. 

I didn't make any changes as yet, once AMD driver comes in my system gets fragile in 5 seconds n crashes go-to a black or green screen. (since it isn't Blue any more the  Blue Screenviewer does not give me any dump to check up on)

Once driver is off and its generic Windows display all seems fine n stable. So it seems more like Driver-Conflict somewhere. 


30 minutes prime95 will suffice. The test is correct if the CPU and RAM usage are full. You can see with Windows Task Manager.

cool will do shortly, Thank you again.

Also just to check for temperature readings should I use CPUZ as a reliable source. or the PRime report would include it in the end? 


You're welcome. I think the system is healthy, but we can say that there is a problem with the driver. 
Now... Use DDU in safe mode for AMD display driver. Then, 
setup it...
Do not change any driver related settings for AMD display driver. Will the system run stable?

in the long pause, earlier -  I went to safe mode and did a DDU. I cleared all possible traces. Even deleted the AMD folder from Root Directory. 

Then I felt maybe its Window's doing some installation on its own, I unplugged from the internet. I had downloaded the same driver as the link you shared - the Sep 12, 2019 - dated driver.

However, The Driver could not be installed as it needed the internet for some reason. Anyways, logged back to my system in Regular mode, connected to the internet and reinstalled AMD driver. I did an express install (not custom). (also checked file size it was over 400mb as in not corrupted) 

And nah all crashed yet again  :-( 

So kind of out of options all around. 

all -PSU+Proc+Mobo is new so I guess have to take them to the seller. I would run Prime95 in sometime

Delete all files and folder for "C:\Windows\SoftwareDistribution\Downloads" path.
Re-download latest driver.
Re-run DDU in safe mode.
Disconnect internet.
Setup AMD driver in normal mode.
Then, test your system again with prime95.

So I did this:

1) Deleted folder as suggested

2) Re-downloaded driver (Link you shared was Ryzen 3, so I got it from Ryzen 5 proc page)

3) Re-installed Windows clean slate ,  Re-started in Safe mode, Even with reinstalled, ran DDU 

4) Regular mode restart for windows, and then set up the previously downloaded AMD driver

5) 10 seconds in system crashed

Before I crashed for the night, I ran extended Windows Memory Diagnostic, it ran for over 12 hrs, around 98% mark system restarted. Memory was without error till that point. The dump says svchost process died. Bluescreen Crash Viewer says Ntsokrnl.exe was the reason for the fail.  (it was Black Screen crash but went to check the minidump)

Rolled Back AMD driver, on the Windows Basic Display Adapter - ran Prime95 Torture Test for 40 minutes. All self-tests till that time passed. 

If this problem is hardware releated, in 40 minutes your system probably would crash with prime95. Could you follow the link above? AMD team maybe helps. You can share this link with them.

Thank you once again

I shall try the Support  Team as well.  I hope to hear from them. Meanwhile if i solve it - i shall get back to you too.

There is no reason to prevent your hardwares running properly. And I don't know why the problem came from. However, if you share this link, maybe you can get AMD help. It is obvious that there is BIOS or software releated problems with 3000 series CPUs. But what is this problem? Please ask? Also, even RAMs are from AMD recommendation... You have bought everything as it should be, but there is a problem...

totally clueless, but two minds better than one. you been a great support. ... Thanks - written to the Support will update you too 

Seeing the problem symptoms and troubleshooting performed by you, I highly suspect this could be due to faulty APU. As you already in touch with support, I assume that they offered you the replacement and new CPU are working fine without any issue.

Journeyman III

Anyone had any luck resolving this?? I've bought 10 of these to build and the first 3 builds are doing exactly this! I've gone through the same troubleshooting steps and basically no matter what you do the system will Green Screen the second you try to install the Radeon Video Drivers.

ASUS Prime A320M-K 

Flashed all the BIOSes to the latest version
Read and followed the guide on AMD  and UEFI issues
Downloaded and installed the latest Chipset drivers - installed first
Downloaded and installed all the latest drivers for Audio and LAN from ASUS for this board

At this point is all fine, disabled auto install of drivers in Windows, so its running the Microsoft Basic Driver.

Downloaded and go to install the latest Radeon Drivers and BOOM! Green Screen. 

Tried different monitors, swapped to VGA instead of HDMI (noticed that it Black screened rather than Green when on VGA). Setup BIOS as per all the guides I've found with this issue and as per suggestions in this thread. Running everything stock - no overclocking. All on fresh installs of Win 10 18362 that I've now re-downloaded twice from my MS VLSC- and used on my other Intel builds fine.

If anyone has a solution - I'm all ears as I'm this close to returning the lot and getting i5's. Kinda glad I didn't get the whole 20 I wanted ...

Hi! Same problem here. Trying to solve it for 8 months and I finally got it!

Ryzen 5 3400 G

Gigabyte A320M-S2H-CF

1x16GB Corsair Value Pc 2666 MHz

Windows 10

Black screen crashes when using VGA and green screen crashes when using HDMI. Crashes occurred when using normal web navigation, Word, Excel, AutoCAD in colorful graphics. Nothing very demanding for the graphics processing, only colorful screens. Tried updating Radeon Adrenalin several times with the whole previous graphics drivers removing, flashing BIOS to the latest version, and several other solutions, but nothing. Only temporary solution  when the system crashed was to press ctrl + shift + windows key + B to reset graphics, and could continue using the PC without reseting the whole system. 

So yesterday, I installed latest version AMD Chipset Driver from official Gigabyte website. Just that. Been using for 2 days normally, and hasn't crashed once. 

It seems that there is some trouble with motherboards that had to be updated to support AM4. 

Worked for me, hope it works for you guys!


Don't know what it is mine sometimes runs for days without issues even with a plex media server and transcoding work. and some times it just locks up and takes 2-3 times rebooting before its back to running normally 

now it runs normally since the last reboot that was last monday and since has run fine.


Seems like a whole different problem. Mine wasn´t rebooting the whole system, and happened frequently, totally related with graphics processing.


Update: after I tested for 2 full days without issues, another user tested for some hours and the trouble reappeared. So here we go again..

Journeyman III

Not sure if it matter now, however i have HP 645 laptop with Ryzen 5 Pro 2500U (Zero BIOS options available)

and it crashes also at regular intervals and does not crash when not using the windows AMD ATI GFX drivers.

When using HDMI out crashes far more frequently

It almost exclusively crashes when using Browsers such as Chrome and jumping quickly from tab to tab or scrolling top to bottom rapidly when the page is using 3D acceleration .

no other OS, hardware or memory Faults

Windows BSOD TDR error and even Ubuntu (once AMD proprietary drivers installed) also complete system lock up (Black Screen).

The only resolution/workaround i found for Windows 

Enable TDR recovery windows BSOD no longer however system remains unusable no display (but sounds/music keeps playing).

Extend the TDR wait time, is because the Vega GFX stops responding for x seconds. Then windows in unusable for 1-30 seconds but I dont lose my work. The system flickers the screen and makes a new hardware installed sound (almost like the GFX card was unplugged and plugged in) 

I enabled 



Then I allowed windows to wait a period of time and tnot sure which on the setting is the one to allow the restart and wait for display these are my current settings

It all started when i discarded the OEM included 1x 2400 8GB ram with 1x 2400 16GB, tested many sticks

Journeyman III

I've got similiar problems so I hook to this thread.

System: Ryzen 3400G + MSI B450 Gaming Pro Carbon AC + 2x 8GB G.Skill Aegis (F4-3200C16D-16GIS) + bequiet! 450W PSU

- latest BIOS

- Memory is supported for my board (QVL from G.Skill), MSI homepage doesn't list the memory

The system is stable with all drivers installed except of the AMD graphics driver (using latest WHQL Adrenalin 20.1.3). Ran Memtest86+ and Prime95 for several hours, no problems. Temperatures und voltages look healthy.

Now the wierd thing: After installing the AMD Adrenalin driver the system is stable, installation works without reboot. I can run 3D Benchmarks and the system is stable. No problems.

As soon as I restart the PC the system hangs up in logoff/restart in progress screen. After a hard reset the system comes up und hangs up in 5-10 seconds. The mouse cursor is moving when I move the mouse but nothing else is responding anymore. But no bluescreens or similar. Simply the system is not responding. AMD Ryzen Master, which I can start during the first 5s, tells me that all cores are going to sleep most of the time. Looks like something / some device is blocking somehow.

When I restore to a point where the graphics driver is the standard windows one the system is fine again. Despite of having no GPU capability.

How can I figure out what the system hangs up.

edit: found out that the EnableULPS=0 in the registry fixes the problem. Wonder why this bug is still present in 2020. (see here)

Adept I

Hola, disculpen las molestias. Tengo tres computadoras con ryzen 3400g, dos tarjetas madre Asrock A320M-HDV R4.0 y una tarjeta madre PRIME B450M-A, todas tienen 16GB de memoria ram, y las computadoras funcionan bien, pero cuando entro a FORNITE se cuelgan las computadoras (thread stuck in device driver) que tienen la tarjeta madre Asrock A320M-HDV R4.0, la única que funciona sin problemas es la que tiene la tarjeta madre PRIME B450M-A, y me he dado cuenta que en donde acostumbran caerse es cuando entro al apartado de la Tienda de Fornite, pensaba que quizás era algún problema de incompatibilidad con la tarjeta madre, pero ahora veo que ese problema también se da con tarjetas madres con chipset B450. Quizás el asunto está en los procesadores.

Adept I

Hola, creo que encontré la solución. Solamente desinstalé el driver de video de AMD (la última versión o penúltima), e instalé el driver que viene en la página de mi tarjeta madre  ASRock > A320M-HDV R4.0 y hasta la fecha no han aparecido pantallas azules, ya jugué fornite, ya la utilicé, ya funciona muy bien sin pantallas azules mis procesadores RYZEN 3400G

Espero que les ayude mi respuesta.


Muchas gracias! Fue gracias a vos que encontré la solución después de 8 meses de pantallas negras. Descargué el último driver del chipset AMD desde la página de Gigabyte y funcionó finalmente! 


Hola, a mi me siguió dando problema, pero ahora dejé los drivers que windows 10 instala por defaultl y actualicé todos los drivers de windows 10 por medio de actualizacion de windows, actualicé todo lo que aparecía alli y ya llevo dos o tres días sin pantallas azules y tengo la capacidad de salirme del fortnite con alt + tab sin que la computadora se bloquee, suerte

Journeyman III

Just wanted to share my recent experience - similar to OP, I could never get the AMD graphics drivers to ever load.  I was taking a 12 year old build that's been sitting in a box for the past 8-9 years and updating it. 

Let me be clear, I WAS NEVER ABLE TO GET THE integrated graphics to work - I could not get the AMD drivers to load and have the system remain stable.  I was able to get them loaded for about 10 minutes but that was not touching the system.  After, I would close out the Radeon installer, it would eventually crash and never reboot (unless i went into safe mode).  Extremely frustrating.

  • (New) AMD Ryzen 3200G
  • (New) Gigabyte B450M AORUS rev 1.0 - Latest BIOS F50 came pre-loaded
  • (New) Crucial Ballistix 3200 MHz DDR4 DRAM Desktop Gaming Memory Kit 16GB (8GBx2) CL16 BL2K8G32C16U4R
  • (Old/resused) Thermaltake W0106RU 700W Complies with ATX 12V 2.2 & EPS 12V version SLI Certified 80 PLUS Certified Modular
  • (Old/reused) SATA 320GB 7200rpm 3.5" HDD
  • (Old/reused) eVGA 8800GTS 512mb GPU - I'll get to this in a minute...

As noted, I haven't done a build in over a decade.  I was hoping to just pull the old tower out of the box and fire it up.  But of course, it didn't survive.  The mobo failed but I believe the old quadcore q6600 and crucial memory still work. So just needing a budget build, I went with the components above.


  • Biggest/recurring issue: system would reboot randomly during install or right after install on initial boot of the OS - no BSOD, just black screen straight to reboot
  • Getting the BIOS setup right - went through multiple iterations of turning on/off CSM, changing XMP on/off, voltage, etc.  I finally got to a stable boot at least by turning on XMP so that the memory was at 3200.  Otherwise it was defaulting to 2666.
  • Couldn't install the Windows 10 home 1909 version I bought (USB) - it would load the AMD video drivers and go straight to the reboot crash.  Had to get an ISO of 1809 version which allowed me to at least load the OS.  UEFI mode only, no legacy CSM support enabled.  Full wipe of HDD and completely fresh install

Attempted Resolutions:

  • Set BIOS to disable CPU boost, disable IOMUU, disable Fast Boot, set to UEFI only support
  • Tried using Gigabyte Chipset Drivers - uninstalled
  • Installed AMD Chipset Drivers
  • Attempted to install Radeo Graphics Software/Driver - this was the crux of the issue
  • Installed all latest Windows 10 updates (except the AMD video drivers it attempts to install)
  • Used the AMD cleanup utility to remove all old AMD drivers (except Chipset)
  • Used DDN to uninstall all graphics drivers and start over from scratch - MULTIPLE times


Final resolution:

  • Installed the 10-12 year old eVGA 8800 GTS 512MB with latest drivers

Ultimately, the integrated graphics on the 3200G just DOES NOT WORK with my setup. I have no idea why - I could maybe try and install Windows 1909 but I doubt that'll do anything to help - especially since i couldn't even get it to load initially.  I'll eventually upgrade to SSD but this machine is really only running my golf simulator.  If anyone else has ideas, let me know.

Hope this helps.

Journeyman III

Not exactly the same here, but my system locks up some times after running for quite some time. 
Mostly it locks up around the day the windows updates come in and needs to get installed

after i reboot it runs perfectly fine for couple of days and then locks up 

System config 

AMD Ryzen 5 3400G

Asus Prime B450M-K 

 2x 8GB Crossair Vengease LPX CMK16GX4M2A2666C16 16GB KIT 

Samsung PM981 M.2 SSD Boot drive

4x 3tb WD RED NAS drives 

case fractal design Node 804 

PSU 450Watt Came out of an Atec HTPC case 

Possible that PSU is not supporting the signals for resetting or powering down correctly

PSU change is in the works but I am looking for a modular PSU  400 watt for it. 

Maybe the system will get changed to an Baremetal hyper-visor like Unraid or Proxmox 

Adept I

Hola, solo para decirles. En mi caso, tenía un ryzen 5 3400g con tarjeta madre con chipset A320M-HDV R4.0, y memoria KINGSTON FURY DE 8GB, creo entender la razón de las pantallas azules, se me figuran como jalones de orejas por comprar un ryzen 5 3400g y ponerte tarjeta madre con chipset 320.

Ocurre que finalmente logré resolver el problema al cambiar el procesador a una tarjeta madre ASUS PRIME B450M-A, y un par de memorias KINGSTON FURY de 8GB cada una funcionan bien con la tarjeta madre ASUS PRIME B450M-A,  pero no funcionan bien con la tarjeta madre A320M-HDV R4.0,

Entonces la conclusión son problemas de compatibilidad, al parecer lo que sugiere todo esto es que debemos poner un chipset mejor al ryzen 5 3400g, y como si las memorias algunas fallan con chipset a320. Eso fue lo que encontré como orígen de las pantallas azules. En mi caso tengo tres ryzen 5 3400g donde puedo hacer las pruebas y finalmente tuve que comprar otra tarjeta madre con chipset b450, y finalmente quedó bien esto.

Entonces entendí que si bien la tarjeta madre suele quejarse del procesador que se le ha montado, igual lo hace de repente las memorias. Y no sé si esto sea generalizado. Pero esto definitivamente ocurre.

Una cosa es que digan las compañías que sus productos son compatibles, otra cosa es que realmente lo sean.

Suerte y saludos a todos


Hi, your previous solution of using graphics driver from ASRock website still works? Or it didn't work anymore?


Mejoró bastante pero continuó el problema. Y finalmente lo solucioné cambiando tarjeta madre y memorias. Buena suerte.

Tengo tres ryzen 5 3400g, dos asus prime b450m-a, dos A320M-HDV R4.0 y cuatro dimm FURY KINGSTON, y dos dimm ADATA, todas las memorias son de 8gb.

Originalmente tenía la siguiente configuracion:

Equipo 1. Ryzen 5 3400g, asus prime b450m-a, 16gb ddr4 adata   funciona muy bien

Equipo 2. Ryzen 5 3400g, A320M-HDV R4.0, 16gb ddr4 Kingston hyperx fury  <--- reinicios constantes, pantallas azules.

Equipo 3. Ryzen 5 3400g, A320M-HDV R4.0, 16gb ddr4 Kingston hyperx fury  <--- Funciona sin problemas !!!

Cambié la tarjeta madre del equipo 2 y quedó así:

Equipo 2. Ryzen 5 3400g, asus prime b450m-a, 16gb ddr4 Kingston hyperx fury  <--- Finalmente funciona sin problemas !!!

Y me di cuenta que si ponía la memoria Kingston del equipo 2 en el equipo 3 no podía ejecutar el Fortnite. Entonces agarré esa memoria y la regresé al Equipo 2. Y finalmente las tres computadoras funcionan sin problemas. Solo tengo una tarjeta madre sobrante (A320M-HDV R4.0 ) y le pienso poner el Athlon 3000g esperando que con ese procesador no dé ningun problema.

Entonces, puede ser que o bien sea la tarjeta madre o la memoria el problema, ya que actualmente tengo un procesador ryzen funcionando con A320M-HDV R4.0 y la memoria Kingston.

Si, me di cuenta que incluso memorias de la misma marca y modelo algunas no funcionan bien con A320M-HDV R4.0.

Esto es lo que hasta ahora he entendido del problema. Dificilmente habrá solucion sin cambiar hardware.

Ahora que recuerdo, a la tarjeta madre sobrante, no le pude meter una unidad nvme, pues el puerto no le funciona cuando atornillo la unidad, y lo más curioso es que cuando solo fijo la unidad y hace angulo como de 45 ° la unidad nvme funciona !!! Me voy más por que la tarjeta madre tiene problemas de fábrica. Si, ese debe ser el problema.

Thank you for your detailed response. I'm currently have A320m-hdv r4.0 with Ryzen 3 2200g with G.Skill 8x2 GB. I still experience crash and freeze even with lots of work around and techniques. Now I tested with your solution of using graphics driver from ASRock. I'll report back here if it works fine or not.

Thanks again for detailed information!


It didn't work. Crash very soon after installing the driver.

The following list is what I've tried in no particular order, and each one can combine with one another, but all didn't work long for me.

  • Change pstate0 to custom (let bios fill the numbers automatically), and pstate1-7 to disabled, then one another option about throttle to Enabled.
  • Modify registry regarding to TdrDelay as seen in this thread above.
  • From fresh windows 10 installation, uninstall AMD Graphics Driver, restart, install chipset driver from AMD, install LAN and Audio driver from ASRock, install AMD Graphics Driver latest from AMD, restart.
  • Changed "Power Supply Idle Control" from Auto toTypical Current Idle (ref: [SOLVED] AMD Ryzen 3 3200G with Radeon Vega Graphics Keeps Freezing / Newbie Corner / Arch Linux For... ) (you might want to try Load XMP Setting if your RAM is high speed which support XMP, see in such link, for my case my RAM sticks didn't support so such option isn't showed up in the BIOS)
  • Used ASRocks's bundled AMD all-in-one graphics driver (older version than AMD's official website)
  • Updated BIOS via flash method from P3.3 to P3.7 (at ASRock > A320M-HDV R4.0 )
  • Try to fix RAM speed from original support at 2666 to 2400, or manually set at 2666.

I have tried above with Windows 10, and Ubuntu 18.04/19.04/20.04 with various version of kernel even tried lowlatency kernel once, or tried kernel version dated back to 4.1x.x. All didn't work.

I'd love to continue using Ryzen 3 2200g. If anyone has some other approaches to try, I'm keen to look at it.


My RAM sticks exact model is not listed in QVL of ASRock website at ASRock > A320M-HDV R4.0 . Would this be possible cause of failure?

Hola, mira, intenta hacer una instalación limpia de Windows 10, y dejas los drivers que windows detecte, en mi caso yo instalo fortnite para verificar que funcione correctamente. En mi caso anterior, el equipo 3 quedó con la tarjeta madre igual a la tuya, y según yo había quedado bien, pero nuevamente al presionar ALT + TAB para cambiar de fortnite a windows es cuando se me quedaba paralizada la pantalla. Y pensé en qué hacer y solo se me ocurrió ir a administrador de dispositivos y darle click con el botón derecho del mouse en el driver instalado y luego en actualizar controlador desde windows update, funciono la primera vez, descargó algun archivo, volví a ejecutar fortnite y volvió a congelarse después, entonces volví a ir a windows update y actualicé todos los items restantes, y ahora finalmente se pudo jugar fortnite por más de una hora, y regresar a windows sin problemas. Por ultima vez intenta hacer esto. Instalar windows, instalas el sonido por medio de drivers de la página de la tarjeta madre, y también los drivers que no instala windows los instalas por medio del driver de la tarjeta madre, y luego actualizas todos los items que aparecen en actualizaciones de windows, parches y demás, y con eso deberia funcionar sin problemas, si sigue sin funcionar correctamente, en lo personar te recomendaria cambiar la tarjeta madre por una con chipset B450, pero también puede ser incompatiblidad de la memoria, pero comprando una tarjeta madre con un chipset B450 podrías matar dos pájaros de un tiro. Suerte y sigo al pendiente de tus respuestas.



At last for my case of using Ryzen 3 2200g with G.Skill 8 GBx2 (model: F4-2666C19-8GVK) with mainboard ASRock A320m HDV R4.0 updated with latest BIOS from ASRock P3.7, I strongly believe it's safe to say now it's because of RAM compatibility issue.

If you check Memory QVL list at ASRock > A320M-HDV R4.0  you will see there is no such RAM model I'm using listed there. Pay attention closely to DIMM Socket Support which indicates number of sticks to insert thus be supported by this mainboard model. There is no DIMM Socket Support with value 1 in the table, this might mean they didn't test or it's universally fine to use. But the point is with DIMM Socket Support value as 2, my RAM model isn't listed there. Possibly it's not that compatible thus I experience crash/freeze here and there randomly.

I tested for 2 days (accumulated usage combined from a few sessions of each reboot topped at 24+ hours) on Ubuntu 20.04 with no other work-arounds or solutions we described here or elsewhere. I have not experienced any crash/freeze again. Notable notice is Firefox which will crash often prior to this, but not even once in this case. This relaxes me not to worry about a crash in mid of working on something. I didn't jump back to test with Windows 10 yet, but with this result, I would highly think it would solve for Windows 10 as well.

TLDR: Try put one of your RAM sticks out in case you use two sticks. Per say use just one RAM stick to see if it solves the problem. If it is, then check at Memory QVL list from your mainboard's official website. It's possible that it might not support the case of using 2 RAM sticks for the model you're using. No listing for DIMM Socket Support value "2" might mean no test, or not compatible at all. So keep using just 1 RAM stick during this time until you sort out how to deal with RAM models you're using.

Journeyman III

I have changed down the multiplier for the cpu to x35 and my system has been running like clockwork ever since for weeks straig 24/7 on its a nas system and media server

Adept II

Have you tried this? 
It worked for me.

Adept I

I increase RAM voltage in BIOS from 1.20v to 1.26v and I guess for 2-3 months and until now I never had issue with crash again.

I incrementally increased it by 0.01v to see the effect until I stop at 1.26v. Note that I also upgrade BIOS to latest (there was a new release recently, although with that alone won't help without increasing RAM voltage).

PS. Not the exact model I use with the OP, mine is Ryzen 3 2200g on ASRock HDV A320 r.40.

Journeyman III

Hello !

I had kind of same problem with my  3400G + Gigabyte B450m gaming.  Windows 10 had many problems to install, and after installation it would hang during boot  or it would hard reset sudenly after 1 or 2 minutes.

The only solution that worked for me is to use an old pci express graphic card and to disable it in Bios and Windows.  

Sometimes I try to remove the graphic card, after a bios update or driver update, and it's always the same : Windows hangs or sudden resets.