Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Ryzen 3 2200g Crashing when installing AMD Drivers


Just built a small backup system with a Ryzen 3 2200g. I have never had any problems with AMD drivers before (my other system is a 2700X with a Vega 64), but for this system when I install the official AMD drivers it causes the system to crash. When I boot it again it loads windows and last roughly 10 seconds before it turns of again. This only starts when I install the VGA drivers. When the system is using the windows basic drivers everything is fine. 

I've seen some similar issues but not found any sure fix. Does anyone know what I can do here?

I've tried upgrading the bios and various versions of the AMD drivers. 


Motherboard: Fatal1ty B450 Gaming-ITX/ac

CPU: Ryzen 3 2200g

RAM: 8gb @ 2400 MHz

PSU: 550 watt

Thanks for any help!

7 Replies

Get the latest chipset drivers and install them, if you can get into safe mode, and not have it crash that is.

Otherwise you might consider reseating the CPU heatsink or check that all power connectors are fully plugged in.


Are you overclocking your RAM by any chance?  Also is your RAM on the Motherboard's QVL list?  Incompatible RAM could cause your issues.

Yes, it is a good idea to update your motherboard's Chip set to the latest version.

What version Windows do you currently have installed?

Here is the latest Ryzen 3 2200g APU Driver: AMD Ryzen™ 3 2200G Drivers & Support | AMD 

Journeyman III

I have the exact same issue.  Seems to be a problem with 1903 version of Windows 10. I've done a full reinstall twice and the same issue props up again, might have to try to install with the previous Windows build.

I loaded all the latest chipset drivers and the latest Radeon drivers.  Works for a time then eventually starts crashing with a loop.

If I don't load the Radeon drivers (or disable the Radeon adapter) everything is fine.


Have also:

- Reseated CPU 

- Tried alternative RAM 

- Tried alternative nvme SSD

This website gives some good tips on troubleshooting that BSOD Error: Fix Critical Process Died in Windows 10 Error - gHacks Tech News 

Generally is the same in other websites concerning this particular BSOD error.

Try running your computer with a Clean Boot. Then see if the problem occurs. Clean Boot is basically disabling all 3rd party startups and drivers from running.

Here is how to do it: 

See if your computer BSODs while in clean boot. If it doesn't it indicates a 3rd party driver or hardware that is not compatible with the new version of Windows.

Journeyman III

I also found that website, unfortunately it is no help.

In fact, I loaded Windows 10 build 1809 and everything is fine.  This is 100% an AMD Radeon driver issue, hopefully they fix it soon.


I would say it's a Microsoft issue...all kinds of problems with the 1903 update.

Online Service Request | AMD 

Journeyman III

I don't have a doubt in my mind that there is an issue with the B450 / Windows 1803 through 1903 and the AMD drivers with the Ryzen CPU's with Vega graphics (Ryzen 5 2400G). I believe it's not only driver related but also nvme related. I was able to repeat the CRITICAL PROCESS DIED BSOD with 2 Asus Prime B450 Motherboards and 1 MSI Tomahawk B450 Motherboard with a Samsung 970 EVO Plus NVME drive. 

I have 3 systems to test this with:

System 1: I thought build 1809 was fine, but eventually did get the BSOD with that as well, only stable by using generic Microsoft Display Adapter drivers.

System 2: Threw in a cheap Nvidia GT710 and system is perfectly stable.

System 3: Removed 970 EVO Plus NVME and replaced with 860 EVO Samsung (SATA) drive and am able to get that system stable.

Would love some feedback if anybody can duplicate and confirm what I see.