cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

coosee
Journeyman III

RX590 - amdgpu failed on new Kernels

hello,

i use Qubes OS System and Kernel 4.14.103 works fine, but when i try to use any newer Kernel, the login to Desktop failed.

there are also some artifacts at lightdm login, please look at the atttachment.

i also tried a manually compiled kernel, but the result is almost the same.

in Xorg.0.log there's the Error - this happens only with newer Kernels:

[    62.958] (EE) glamor0: GL error: GL_OUT_OF_MEMORY in glTexSubImage
[    62.958] (WW) glamor: Failed to allocate 22x22 FBO due to GL_OUT_OF_MEMORY.
[    62.958] (WW) glamor: Expect reduced performance.

i also tried the current Version of amdgpu Driver- non Pro!

the only difference to the 4.14 Kernel is the Module >> gpu-sched >> which is only loaded with newer Kernels, e.g 5.0.2.

Is this a Xen Problem or a Driver Problem in context with Xen+newer Kernels?

The Card on FunToo Linux works perfect, no Problems at all.

thx

0 Likes
1 Reply
coosee
Journeyman III

Re: RX590 - amdgpu failed on new Kernels

here are my specs:

---

bequiet! Silent Base 800 Black

MSI C236A Workstation - Intel Xeon E3-1245v5 - 32GB RAM Kingston - Sapphire Nitro+ Radeon RX590 8G

Samsung SSD PM961 M.2 128GB - Samsung SSD 840 EVO 120GB - Crucial m4 SSD 128GB

Creative Sound Blaster RX PCIe - Logitech Speaker System Z623 2.1

Logitech G110 Keyboard - Optical Gaming Mouse G400

---

0 Likes