cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

nitko
Journeyman III

RX570 ITX won't install drivers

I bought a Sapphire Pulse RX570 ITX for my 3700x + B450M Mortar system. I installed the drivers, more specifically all three from here under Win10 64-bit: https://www.amd.com/en/support/graphics/radeon-500-series/radeon-rx-500-series/radeon-rx-570 , I tried uninstalling the previous AMD drivers, then installing new ones. Nothing. When I right-click on desktop, I don't have AMD Radeon settings anywhere. When I try to open AMD Radeon Settings from the start menu, I get an error saying "No AMD graphics driver is installed, or the AMD driver is not functioning properly". I've installed the drivers a hundred times already. Windows also says it can't detect the second monitor (a Wacom Cintiq 22HD), despite both monitors working and the tablet responding to pen movements. But they are duplicated. Moreover, when I use Ubuntu, both monitors work as they should, so clearly this isn't a hardware issue.

3 Replies
jokbon
Adept III

chipset and later bios update? then try?

0 Likes
nitko
Journeyman III

My computer is brand new, its bios and chipset are up to date.

0 Likes
pokester
MVP

Download and have ready the latest driver.

Download DDU from wagnardsoft_com

Disable Internet Unplug net cable or disable wifi.

Reboot to Safe Mode no internet and run DDU.

Reboot normal but still no internet and install the AMD driver.

Reboot and reconnect internet.

With any luck you will be good to go.

0 Likes