cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Highlighted
Adept III
Adept III

Re: RX Vega64 Liquid -- Possible HBM2 Downclocking / Upclocking / Black-Screen issue

Yes, in my opinion Adrenalin Gaming drivers all the version after 18.12 are broken from core, I tested almost all versions since 2018 and sooner or later the card will trigger blackscreen and 100% fan speed. I tested everything, undervolt, overclock, removing Adrenalin & installing the INF file. Change coolers, change PSU, removing the backplate, cooling the VDDC and VRMs, disable all Radeon features, including VSYNC, different cables, different monitors. 

The problem absolutely dissapear when I installed Radeon Pro drivers 20.Q1, yesterday I updated to 20.Q2 it remains rock solid stable. Even reaching 1650mhz with undervolting, which has been never achieved with gaming drivers. 

Highlighted
Adept III
Adept III

Re: RX Vega64 Liquid -- Possible HBM2 Downclocking / Upclocking / Black-Screen issue

Sorry not VSYNC, I turned off Freesync which is reported to cause issues some times. 

Nothing worked. Never. Just the pro driver.

0 Kudos
Highlighted
Esteemed Contributor III

Re: RX Vega64 Liquid -- Possible HBM2 Downclocking / Upclocking / Black-Screen issue

I see the same when the card crash, black screen, fan speed maxed.
I also see GPU Tach at 100% (ALL LEDs lit up).
I tried installing Adrenalin 20.5.1 this morning and in that case the install caused the PC to run like toffee.
You might want to hold off on even looking at it for now.

0 Kudos
Highlighted
Adept I
Adept I

Re: RX Vega64 Liquid -- Possible HBM2 Downclocking / Upclocking / Black-Screen issue

Hello all, I had problems with this and have been posting here at various times across the past year or so, thought I'd say my card has been stable since I got a different PSU. They state a 650W would be enough and it should have been, but for me a change to an 800W power supply has made the card good as gold.

It had been back to the manufacturer for testing and they found no issue so then when it returned to me I tested again and it still crashed, then I purchased the new PSU and it didn't crash ever again after that.

So it seems there is a power spike or something that happens sometimes with the cards and they need a higher than stated PSU to keep the system stable, that's my educated guess.

Hope that helps some who are still having trouble with Vega cards.

Cheers

0 Kudos
Highlighted
Esteemed Contributor III

Re: RX Vega64 Liquid -- Possible HBM2 Downclocking / Upclocking / Black-Screen issue

I have Corsair AX1200i PSU.
Swapping RX Vega 64 Liquid with RTX2080 = no crash.

0 Kudos
Highlighted
Adept I
Adept I

Re: RX Vega64 Liquid -- Possible HBM2 Downclocking / Upclocking / Black-Screen issue

It's not really a wattage issue, but rather some PSU's don't handle the spike in power too well when the PC goes from idle to load. I forget the technical term but it was discussed somewhere in this thread or another as one cause of idle crashes with Vega GPU's. Even some PSU's that are considered good would have this issue, for example i know some EVGA ones have this problem.

In my motherboard's BIOS i changed the PSU idle control from 'Auto' to 'Typical Current Idle' and it solved most of my crashes. Do not set it to "Low Power Idle" as this will cause more crashes.

Well that and disabling ULPS via regedit solved my Vega 64 idle crashes completely. Do a search for 'ulps' word in  your windows registry and set the value to 0.

Highlighted
Adept I
Adept I

Re: RX Vega64 Liquid -- Possible HBM2 Downclocking / Upclocking / Black-Screen issue

Exactly right, Grogg, mine was an EVGA supernova top of the range but it couldn't handle the power spikes.

Funnily enough the one I swapped out for was not a top end one at all, middle of the road Aerocool one. But it handles this card without issue.

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: RX Vega64 Liquid -- Possible HBM2 Downclocking / Upclocking / Black-Screen issue

Dear all, this is quite an old conversation, but I wanted to add my 2 cents anyway, as this is clearly still an existing problem. I opened a ticket for this as well (Ryzen 3400G black screen driver problem), but I seem to have found a solution for my issue:

In the AMD graphics options there is an option to select a custom resolution. If you select this, make a resolution that works for you and select the CVT - Reduce Blanking option, this will greatly reduce the flickering. However this didn't solve it entirely for me, as the problem persisted when stressing the CPU. what solved this last part is lowering the Vcore. My mobo supplied quite high voltages by default, sometimes going up as much as 1.4v. This not only is bad for the lifetime of your CPU, but seems to affect the GPU under stress situations as well.
Anyway, I put my vcore at 1.25v and after that even under the heaviest stress tests the screen doesnt flicker anymore. If the situation changes I will provide an update. However I hope it wontSmiley Wink
I wish the peeps out there with the same black screen issues good luck and hope that AMD will fix this in the future. Especially the high vcore seems problematic.
Cheers!

0 Kudos