Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Rx 590 Activity too high after accepting "radeon advicer recommendations"


I recenty got myself a Rx 590 Fatboy Radeon GPU.

Everything was fine, idle temperatures were at around 37-42c. Fan was quite all the time, unless i started to game.

For around 2 weeks. A few hours ago i noticed the little "!" at the top right corner. I decided, why not, lets give it a try.

So i accepted the reccomedations. Now, my idle temperature is around 62c, activity is high even when pc is complete idle,

(spikes up to 99%), fans start to run every single minute and it is very annoying, no fun at all anymore.

What i already did to solve the problem:

Reset all the settings.

Reset the cache.

Uninstalled the driver, used driver cleaner and reinstalled again.

The card also has begun to "Kickstart" at every PC restart, full fan RPM, never did that in the last 2 weeks.

Nothing works, temperature above 20c the usual (from 35-42c to 64c IDLE), random up to 99% activity spikes on the GPU, fans are annoying me.

Thank you for those great AMD advisor reccomendations, im not sure what to do anymore.

I would like to get some suggestions.

Thank you!

( After i pressed "Yes", to the settings advisor,  ((and oh my god why did i do that?)) all of my 3 screens began to flicker, shut on and off for over 20 seconds.

now the temp climbs from 50c to 60c and then the fans kick in. Absolutely idle, nothing is working but the temperature monitor. Many years ago i said to

myself NEVER AGAIN AMD, and now i did it again. )

28 Replies
Adept II

After looking into it, i can keep the temperature down with disabling the zero rpm settings, i do not mind it much, but till now the setting was off,

and rpm was always (when idle) 0 and temperatures were around 39-42c.Was it a bug? Is the zero rpm setting capable of keeping the temp

at the described temperature? Im used to my old 960 MSI, it was always very cool at zero RPM and nothing but the gpu changed.

I assumed the RX 590 Fatboy could keep the temp down with being purely passive at idle, seeing that the cooler on it is way bigger than on my old 960.

I also did notice that with just HDMI on the card it works way lower on the passive settings, about 45c. With 3 screens (hmdi/display port/DVI) it hits

60c at zero rpm. And again, that only happened after i accepted the settings in the advisor. Little bit confused right now, either the RPM meter was completely

bugged and i was thinking its on passive, or something went wrong and now card is getting hot for some reason.


Adept II

Looks like no one here is around, anyway, i fixed my problem.

Optimized the arflow in the case, added a side fan (i usualy only did that in the summer). passive cooling keeps the card at around 46c.

Drivers are screwed up a little, i just made sure everything is set on manual control, because it seems that the drivers do whatever they want

and however they want to do it. Besides that, the card is pretty good, tho, on high rpm can be loud, i make sure not to go over 1750rpm.

On shadow of the tomb raider that brings me up to 80c, but i guess its okay.

Looks like i helped myself!


Adept II

Okay so, forget everything i wrote above. The solution: Reset to factory settings and DO NOT TOUCH WATTMAN AT ALL!

As soon something is changed drivers go nuts. Install and do not touch. Just never touch it what so ever. Only the display options

are okay to touch, like freesync or hdmi color settings. So after i resetted to factory settings and gave it a few tries, like disabled

the fans i just installed for that card, closed the airflow. Guess what? Temps are lower like that in idle (35c) than with all the fans (not the gpu fans)

running high speeds and very strong airflow. But with "touched" WattMan - 45c. What sort of major nonsense is that? How?

So my first thing that i said here was true, all went totally south after i did accept wattmans suggestions.

Disable wattman right after installation and use (if needed) MSI Afterburner, or other software. Biggest crap in driver existence. Grats AMD.

Problem totally solved.



You are confusing Wattman with the "settings advisor". Anybody who uses that get what they deserve. Ever heard of 'Raptr'?


No, i was a long time nvida user, im used to MSI afterburner. And i also mean WattMan, like, setting zero RPM off or slightly changing your RPM curve.

It wont stay in low temps in idle. After i first changed it a little, just the curve, my idle temps did go up 60c. Now i have the same setup, i disabled

the tower fans, and as long i do not touch wattman settings or adviser at all, the stay at 35c. Thats crazy. How is that possible?


Just to make sure, by idle i mean "zero rpm" mode with nothing but the screens running.

So same setup, zero rpm mode, slighly changed settings -  goes up to 60c then the fans start running. (adjustted the fan curve just by 1%, no joke).

Factory reset, nothing changed - 35c stable in 0 rpm.

Crazy. Im not able to understand how this could have been released. Im not even talking about that reanabling zero rpm is a quest at itself.


If you want the card to perform at its maximum designed performance should uninstall (not disable) Afterburner (which conflicts with AMD/Wattman settings and controls), reinstall the AMD drivers and only change two things in the Wattman game profile (not Global)...Temperature and Power Limit. Leave everything else at default (automatic).

Power Limit should be the highest + setting (slider all the way to the right)

Max Temperature set to manual and 75-80c. This setting will engage the fans at 40c (about 20% fan speed) and automatically increase as needed to keep the temperature at/below the selected Target temperature for that particular game.

Depending on the Wattman version:


For example, if i slide that lowest (first) slider even 1% up and press apply - everything is broken. zero rpm can not be brought back, and even with 3rd party fan control software like speedfan (neutral one) the GPU will always go to 60c on 0 rpm, even if i completely slide GPU mhz, memory, and power limit to the lowest possible point. As long as i not touch it, its a cool 35c and works nice. I myself would like to set a lower temperature (more rpm) for some games, but yea, i better let it be. Maybe they will fix it at some point.


And by 60c i mean it would go up even more, but the fans kick in. I think the catalyst for it is the "zero rpm" option somehow. It breaks something in the driver, and the gpu goes in a nonstop loop by checking it, activity goes pretty high. I have no idea.


I can't see enough of your Wattman control panel to comment..but there has to be a setting for Temp like I posted. If you don't raise your Power Limit you will never get the performance the card was designed for. The default setting is a power saving/run quiet setting.

Take the time to read about Power limit on this older post AMD graphics performance


Nope, thats it.



Power saving quiet running? Not with the rx 590 Fatboy. It reaches 80c fast.


By mentioning the power limit i wanted to say that i lowered whatever i could, and still it did rise to 60c (till fans kick in) by just showing the desktop, not even

a browser and on lowest possible settings. As said, if i do not touch it, its absolutely fine on "0 rpm". As long i do not start gaming, no matter what i do it will stay below 38-40c. Performance wise the card is fine, can not complain about that.


Did you scroll all the way down in Wattman settings? 60c is the default's set to keep things quiet while you surf the web.

You don't have any 'Max' temperature setting at all?


How to Tune GPU Performance Using Radeon Wattman and Radeon Chill | AMD

Power Limit

Power limit controls the level of power sent to the GPU. Increasing this value can improve GPU performance by allowing the GPU to maintain its highest clock frequency (state 7).

Power Limit can be increased or reduced by +/- 20-100% and should be set to the maximum value when increasing GPU or Memory clock frequency.

NOTE!   Power Limit % range is dependent on which GPU you are using.


I noticed this card has a dual Bios switch....maximum performance or quieter (noise level). Which one do you have it set to?


The dual bios is long gone, before i even got it, because the borked cards that the users were not able to bios properly.

Just 1 bios.


and yes, the swich is useless since months, because amd removed the download links. Idea was stupid to begin with, but kudos for  trying. rx 590 default bios here.


Im a web engineer and i know my stuff around the PC. Early days i did repair pcs soft or hardware. I overclocked about "i dont know now many" pcs in my life, i know all that stuff. What makes me mad that the adrenaline driver is beyond my understanding of working. I like it in a way.


Get the new adrenaline driver 18.2.2 or 18.2.3, if you find that option, ill ow you a beer.


I have the 18.2.3


I know it, you know it, it is broken beyond all  our hope. In 2008 or so, i said a goodbye to radeon and all their crap. After that i did buy nvidia and did live a happy life with no BS everyday. Till now. Im back into making sure that my GPU works daily as it should for hours. Last AMD card for me. Never again.





I will refund the rx590 and get a  gtx1060. Story ends. Ill be happy. Im tired ot that S*h*t.


Hello again

Sorry for ranting, i was really done with the card. However, i kept it and i found the solution. Maybe someone has that problem as me, so there it goes.

Problem was that im using 3 monitors, all of them were on 60hz but, one is able to run 72hz. Possible: 60 72 60. Running : 60 60 60.

But! The driver for some reason always started up like the middle one is on 72hz, and gave me the 2000hz all the time bug, thats why

the high idle temp. Started after the advisor switched my middle screen to 72hz once, so that was the catalyst.

Solution: Everytime i boot up, i switch the screen hz from 60 to 72 and back to 60 again. That sets the memory clock back to the normal 400hz.

Zero RPM is still not working, using SpeedFan to set it back to 0rpm after gaming everytime. A few more clicks, but at least its working.

All problems solved, sorry for ranting, i was very upset with the temperature rising, but now i was able to pinpoint the problem and im sort of happy

now with the card.

Thank you


Thanks for your help Kingfish.

I am unable to use crimson drivers, because im using rx 590, and it only goes with the new adrenaline.

I do not have your sort of temperature control, but a curvature instead. Im very falimliar with temperature curvatures, and how to set them.

the thing is adrenaline driver is completely broken, 18.2.2 or 18.2.3, absolutely worthless. I am not able to istall

the last crimson driver, which i hear is awesome and has very little problems. Crimson does not see my GPU on installation.


If i slightly adjust it, zero rmp will be impossible to bring back without restarting, and my gpu temperature will rise constantly till 60c for no reason.

now its 45 and sinking after 2 hours of ghost recon. Will reach 35 and stop. If i adjust even a little, it will keep going up to 60c all the time, no idea why.

Thats why it is so mindblowing to me.

Thank you!


Of course on the screenshot i pressed "discard". Temp down to 36c on zero rpm.