Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

RX 5700XT Unable to Monitor Sensors/Clock Speeds

Alright, so after two cards later and 4 reinstalls of Windows i'm still having this issue (Ubuntu drivers work fine so i'm going over there for now until this is fixed). 

Basically what happens is the monitoring will randomly fail if you're tinkering with Wattman settings or at anytime really. For me I was only adjusting fan speeds and enabling Auto-Undervolt. It'll essentially look empty like this (see attached pictures).. This is a big big problem because when this happens, no only will the overclocking software not be able to read these, the DRIVER wont either. Oddly it'll still boost clock speeds based on demands, but your fan WILL NOT spin up and this card will cook itself till a restart or BSOD. Not good, because it cannot read the GPU temperature sensors either.  

The only way to fix this I've found is to Reinstall Windows, where it'll just happen again. I've seen another post with a person having this exact problem, it needs to be fixed. This is seriously annoying as hell, this is a critical priority 1 bug and may explain why people keep crashing their cards because this breaks without even touching wattman (usually in-game), etc and the card cant control its cooling/monitoring. 

DDU (safe mode) will not work, something gets corrupted in Windows. I've seen BSOD's for VIDEO TDR FAILURE also, they seem to happen at random, usually while the GPU has load and i'm guessing its because it isn't being cooled properly because the sensors are not working on the driver. It's already done this for the 4th time reinstalling Windows, so i'm moving to Ubuntu where it doesn't have any issues (already tried it, it works). 

I really love you AMD, but this is souring my taste of buying cards from you in the future. I feel like these are Alpha drivers i'm working with right here. Seems to me like this card was rushed out the door. 

  • AMD Graphics Card
    • ASUS AMD 5700XT
  • Desktop or Laptop System
    • Desktop
  • Operating System
    • Windows 10 64bit (1903, latest updates)
  • Driver version installed
    • Radeon Software Adrenaline Edition 19.7.4
  • Display Devices
    • AOC Q3279VWFD8, HDMI, 2560x1440@75hz
  • Motherboard + Bios Revision
    • Gigabyte X570 Aorus Elite v1, BIOS: F4g
    • AMD Ryzen 3700X
  • Power Supply Unit  Make, Model & Wattage
    • PowerSpec 650W PSU PS650BSM
  • RAM
    • Gskill F4-3000C16D-16GISB 16GB (8x8) @ 3000MHz

Also the computer seems to get a bit choppy whenever you're querying data about monitoring or clocks etc (in GPU-Z, Wattman, Afterburner).. Close it and choppiness goes away.  

5 Replies
Adept II

Issue not resolved as of 19.7.5.

Fresh install of Windows.

Installed Chipset Drivers from AMD

Installed CPU drivers

Did Windows update to latest version of 1903 and installed the July cumulative update. 

Installed only the driver with out Adrenalin software

Still seeing straight 0's and nulls in Afterburner and GPUz. My fan will spin up now at least, I'm gonna slam beers and just try to game. I give up, let the card Chernobyl itself I officially do not care anymore. It dies I'll go grab an Nvidia card and leave this chapter behind.

I'm not gonna play this dumb game of chasing supposed workarounds from other people. AMD make an official information release of what we need to do... 

Throwing back on my ASRock AB350 Pro 4 and seeing what that does. 

Adept II

Ditched my Gigabyte X570 board for my old Asrock AB350 Pro4, reinstalled windows and guess what happened....

I'm now going to mess with the settings and try to break it and see if it holds up even after a GPU failure. Going to do a series of 10 planned restarts after applying settings. This is on the 19.7.5 drivers.  

Adept II

Figured out how to break it. Set my monitor to 75hz and BOOM, broke just like that back to no stats on GPU and it seems to break.

Im running on my parents monitor but I when I was at my house running on my 1080p monitor via displayport @144hz no issues. This one is running 1440p via HDMI 1.4. 

It is NOT the x570 Chipset it was my monitor affirmed 100% when I adjusted the refreshrate. 

Adept II

Switched refreshrate back from 75hz to 60hz and everything worked again.