Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

RX 5700 XT - Massive fps drop with in-game steam notifications (friend messages)

Issue reported first with the link in the Radeon software, i thought i'd also share it here.


  • Graphics card: SAPPHIRE PULSE RX 5500 XT 8G GDDR6
  • Operating System: W10 64bit (build 1903)
  • Driver version installed: 20.1.3
  • Display Devices: AOC 24G2U as main monitor where games are running (DP, 144Hz, 1080p). Philips 243v5 (HDMI, 60Hz, 1080p) aside but not powered when i had the issue. Same for the Panasonic TV (HDMI to DP, 60Hz, 720p as 1080 is not listed, it was with a 7870?! it only accept 1080i though, may be the cause).
  • Motherboard: MSI MPG X570 Gaming Plus
  • CPU: AMD Ryzen 5 3600
  • Power Supply Unit: Thermaltake Smart BX1 RGB 750W
  • RAM: 32GB DDR4



As soon as i receive a message from a Steam friend and the notification in-game of it, any game where this notification will be displayed starts to stutter heavily and drop fps insanely.

For instance i was playing Hollow Knight ealier, i was going from 144 fps to 60-80, sometimes even less than 60. I was able to notice the same perf issue in Trials Rising (very specific here, the steam overlay propagated to this game by an Epic Game Launcher added in steam as a "non-steam game", and then from the Epic launcher it starts Trials Rising by also opening Uplay ; this game is capped at 60 fps so fps didn't drop much, but unsmooth gameplay was well there) and Torchlight III (Alpha).

So, steps to reproduce :

  1. Start a game from Steam with steam overlay and steam friends message notifications enabled.
  2. Get a message notification from a friend sending you a message.
  3. See your game dropping fps heavily and being very unsmooth.
17 Replies

I think AMD display driver is still not perfect. Sometimes I had a similar FPS drop issue with an overlay plugins in games. The reason for this problem is that FreeSync driver still does not work flawlessly. FreeSync driver also tries to be active when an alert is received and this is causing an FPS drop issue. I solved my problem I was experiencing as follows like that... I made "AMD External Events Utility" service disable and restarted my system. In this way, FreeSync only worked with fullscreen mode, and when a warning came, it disabled FreeSync feature and eliminated the problem of excessive FPS drop for me.

Adept II

Well, i got some new info about this issue, and it's very surprising. I've no idea how this can be a thing:

I disabled the steam overlay, started a game from Steam, here Hollow Knight. So no more message notifications in game, but as soon as i received a message from a friend in the steam chat window associated, the fps drop occurs.


Additionally i installed MSI Afterburner to still have a fps counter, but for now i can't do anything about that Steam issue so i re-enabled the Steam overlay. I don't really want to disable FreeSync, and i play most of my games in borderless so i can't just set FreeSync to work in fullscreen only.


I think the same with you. I think the problem you are experiencing is caused by FreeSync, and Radeon driver control panel only offers you the active-deactive option and is not effective. nVidia offers the option of which game you can activate GSYNC with Inspector software with fullscreen or borderless options. This is a deficiency but not an unresolved problem. You can contact AMD and I suggest you specify the additional feature requirement to the driver. 


I just tested by disabling FreeSync, it still occured for me apparently. I don't know if i could somehow capture in video the issue.

I forgot but for Hollow Knight i had to turn on the V-Sync otherwise it'd run the game at 500 fps which is a bit useless and probably a bad idea in the long run as i assume it uses all the resources available on the PC CPU/GPU wise. Most games now have a fps limit you can set with a default value at 150 often, which is probably the best to use in addition to the FreeSync. Hollow Knight doesn't.

Doing further tests with FreeSync off, i could still get massive fps drop w/ or w/o V-Sync activated in the game, and w/ or w/o Radeon Chill activated (which seems to be an alternative for games that doesn't provide a fps limit setting like here). In all cases receiving a steam friend message caused a fps drop. V-Sync off for instance it went from 500 to ~380.

I contacted AMD as you suggested, thanks. We will see where it leads to, if it leads anywhere.


Could you try the problem it with a monitor or a TV that is not FreeSync compatible? 

Strangely enough, i just tried on my old monitor which is my second screen in the list in the OP (Philips 243v5 (HDMI, 60Hz, 1080p)), and i had no fps drop issue / unsmooth rendering when i received a steam friend message.

I also tried before this test to disable FreeSync in the monitor settings directly of the main one in 144Hz instead of just the test i did by disabling FreeSync only in Radeon software but the issue still occured.

I don't really know what to do at this point... If even by disabling entirely FreeSync on my main monitor the issue is still there, what am i supposed to do?

In the meantime AMD requested me to "give a try by performing clean installation of latest 20.2.1 driver by using the AMD Cleanup utility and check the issue status". With a detailed process. I'll do so and edit this message if it fixed anything.

Update: So when doing that reinstall, on opening Radeon Software for the first time i clicked the games preset instaed of standard. And this time the issue didn't occur, though Hollow Knight was between 400-600 fps. I tried to disable Enhanced Sync right after, this was my first change in the default settings. And at this moment the issue came back. So FreeSync without Enhanced Sync = issue occurs. As soon as i enable Enhanced Sync however it's fine. Nope, it's not.

I enabled Radeon Chill too, with a 60-150 fps range as i don't have any use of frames going above that. It came back as being not good with it.

I set the settings back to where they were at first, and... the issue occured again, with the exact same config. I don't understand what's going on.

Update 2: Seems like i was able to set in stone a working config, at least in Hollow Knight. i'll see how it goes for others games. But apparently the winning combo is FreeSync + Enhanced Sync + VSync Off in-game. I'm not really sure yet about Radeon Chill. Hollow Knight "limit refresh rate" setting limits at 400 fps instead of up to 600, but the GPU is used at only 25-40% and CPU 30% so i guess it's fine.


I suggested that you experiment because I know that disabling FreeSync will not work. I still think the problem is from FreeSync. I think you should share this situation with AMD with sharing this forum link.

Yep, thanks again for the help. That's exactly what i did in my answer to their mail (and i already did put a link of this thread in the first message i sent for the ticket). Maybe they'll look into this issue further to fix what's wrong here.

Update: Well they only answered me "Please refer below link and perform the following steps for the FPS ," with 3 links:

Guess they'll not check further this issue. In the meantime, while the issue seems to be fixed, i got 2 new ones:

  • Black screen / crash of the driver i think, the game wouldn't come back. I assume it's the known issue with web browsers & cie w/ hardware accel.
  • Strange reminiscent frames from a few seconds ago or something. It's really annoying but not TOO frequent thankfully. Apparently it's called ghosting... I feel like it's related to Hollow Knight running at 400 fps. I'll see what happen in others games.

Part of the problem is that trademark infringer called Epic

Over on Steam there is a lot of hostility towards them by the users

Adept II

Just to add additional info on the topic here, it really seems the issue at the end comes to the fact either vsync is on or off.

A good test for that is the game Nioh. It's a game with vsync forced and 60 max fps. You can't edit any vsync option, there's none.

I tried to put VSync disabled w/ Disabled Enhanced Sync setting in the game profile in Radeon Software (instead of default Enabled Enhanced Sync) but it didn't do anything and the game was still heavily slowed down (i assume the game forces vsync in a way Radeon Software can't change that).

So the bad combo is a freesync monitor (whether enabled or not) + vsync on. This issue will occur 100% in this case. Screenshots:

  • Freesync + VSync ON + Received message on Steam :

    Freesync + VSync ON + Received message on Steam

  • Freesync + VSync ON + No message :

    Freesync + VSync ON + No message

  • Freesync + VSync OFF + IG FPS Limiter (small, can't set it as you want, aka 400+ fps instead of 600+) :

    Freesync + VSync OFF + IG FPS Limiter (small, can't set it as you want, aka 400+ fps instead of 600+)


Have you tried that following ways?
Run Windows Computer Managenet and then

Services and Applications > Services > Right Click "AMD External Events Utility" > Properties > Select Startup type to Disabled > Click Apply > Click OK > Restart the system
Did you follow these ways and make FreeSync works only with fullscreen mode?
This kind of FPS drop problem also exists with nVidia. However, with nVidia, this kind of problem can only be solved by activating GSYNC with the driver panel for only fullscreen mode. So the game screen switches to windowed mode with Steam alert and FPS becomes a drop. Your reason for having this problem with AMD is that... AMD display driver panel does not support FreeSync shutdown with only windowed mode for a game. Also, when a monitor that supports FreeSync is connected to the system, the driver consistency changes.

Of course, if you have the same problem like me, all this is true....


I didn't because as i said i play most of my games in windowed borderless. So doing the process you describe would prevent me from having freesync enabled most of the time.

I think i'd rather set myself offline on Steam chat to not be able to receive any message than having to disable freesync now i've it if i had to choose. It'd be the least annoying fix here.

Thanks again for the proposition of your fix though. I may try it at some point just for the purpose of trying it and see the result, but probably not for a longterm usage.


I agree you. I would like to share additional information. For example, to solve this problem with nVidia, going to the driver control panel and marking the GSYNC feature for the game for only fullscreen would solve the problem. When you turn off GSYNC feature from nVidia driver panel, display signal disappears and comes again. Then nVidia driver sees monitor firmware as if has no GSYNC. So nVidia doesn't just fix vertical hertz like AMD with adaptive sync supported monitors. Display signal is not lost when you disable FreeSync with AMD driver panel. AMD driver sees same monitor firmware supported by FreeSync, and is sometimes silly.

Considering another problem caused by what i assume is the FreeSync, i think i'll try what you said and see how it goes.

This another problem in question is that all the displays are like "frozen", only the mouse cursor is moving. The main screen with the game started is black but i can hear the sound of the game, and if i turn on the second screen, i see the task bar for instance but not reacting with clicks/hovers. It happened with Distance and Monster Hunter World so far. I had the idea yesterday to turn off freesync in the monitor settings menu instead of hard reboot once more. Displays were back again.

So maybe playing only in fullscreen mode with the freesync will help about this issue too. If not, i'll considering turning freesync completely off as it was with my old PC. But that may mean i'll have to use vsync, unless enhanced sync is that good (though i'll still need to limit fps either in-game or with RTSS).


I use FreeSync with my LG 4K panel fine. Driver notices it immediately and I have not seen any problems.

Depending on the game, the OSD shows anything from 30fps to 2400fps


I want to share additional information. When disabling FreeSync with the monitor menu, the signal disappears and comes again like nVidia driver response (without monitmr menu). So this may be fix this problem temporary.

I want to give an example. FPS drops with FreeSync when subtitles are added to Movies & TV application. Turning off FreeSync with the driver panel does not solve this problem bu turning off FreeSync with the monitor menu solves this problem. There are problems with the FreeSync driver. I reported this to AMD, but AMD does not put such problems into the problem class.

Yep i'd that in mind too that maybe displays came back when i turned off freesync in the monitor menu because it forced a "driver refresh" or something.

I'll see how it goes. For now i did what you said about "AMD External Events Utility" service being disabled by default, and i'll run games in fullscreen only and not in borderless.

Settings in Radeon Software being the default "games" preset ones. Latest driver (20.2.1).

For the few tests i did so far, no issues.