Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept III

RX 5700 XT major crash issues


This is by very far the hardest troubles i've ever had with a graphic card.

Troubles began when we tried installing Modern Warfare 2019 for Warzone. AMD drivers 20.2.2, the game would crash and cause severe system degradation if not rebooted. The game would go blackscreen, and would crash. After several crashes and reboot, several tries at uninstalling the display driver with DDU and then reinstalling, the degradation would be so bad we couldn't even boot any other previously functioning games like Counter Strike Global Offensive or Rocket League.

This is the current setup :

Viewsonic VX2758-C-MH connected by HDMI to an RX 5700 XT Sapphire card. (FreeSync enabled)
110M-ITX motherboard (stock bios) with Intel 6500K, 16GB (2x8) DDR4 2133 RAM.
Samsung 256gb 850 EVO + Samsung 256 840 EVO.
PSU Corsair 650W

Now i tried reinstalling windows from scratch, run all the updates, and then install 20.2.2 again and trying to install CS on steam (not even starting the game) the computer crashes with a BSOD (video scheduler internal error) and then refuses to boot (partition is broken).

This all started when trying to install Modern Warfare 2019, everything was running OK beforehand.

What we tried :

1 - Downgrading AMD drivers to 19.12.2. All games would run with worst performances, Modern Warfare was still crashing.

2 - Reinstalling Windows from scratch, didn't work

3 - Reinstalling the display driver after DDU, with factory reset, wouldn't work. 19.12.2 and latest 20.2.2.

4 - I noticed any games crashes if the Blizzard Launcher is opened. Might be the culprit. Disabled hardware acceleration in the launcher and didn't change anything.

5 - Reinstalled Modern Warfare and CS:GO, would still be garbage.

6 - Modern Warfare crashed a lot during its initial loadup because it has to download shaders, and the game would crash during the download.

7 - We managed to get the game running in safe mode for a little time. First time we managed to play maybe 3 minutes of warzone before the BSOD. Second time we had a lot of garbage on screen doing the initial training.

More info : In Modern Warfare we had the 6068 error code sometimes during crashes (when it wasn't a BSOD). We tried at least 40 times to boot the game and it always ended up failing.

All in all this is a garbage experience. Absolute garbage.

I have read in here : 

That a bios upgrade could maybe fix my issue but it's older hardware and i really don't want to try it because i can't brick my nephew's only computer.

Right now i just finished reinstalling windows and all its updates, and installed 20.1.3, and now i have no display.

This is beyond garbage at this point.

19 Replies
Adept III


Please check this thread

I just reinstalled windows and fully updated, latest amd driver, i have crashes for "Radeon Settings: Host applications"

Just by trying to install steam.

This is very hard to work with.

Adept III

I forgot to say

Turning off FreeSync or reducing the monitor refresh rate does nothing. Reducing the resolution also does nothing.

It seems like running Modern Warfare with 20.2.2 made a permanent damage to the card because even a fresh install i still have issues.

This is very unfortunate and at this point i am lost i think the next step will be a RMA but i'm not entirely sure i might try BIOS update before at this point.

Adept III

Trying to install CS via steam now crashes the computer display.

Adept III

Update : I just removed the AMD 20.1.3 drivers and the download for Counter-Strike doesn't seem to be causing the display to crash.

It's the driver. Your driver for the RX 5700 XT is garbage and you should definitely build a functioning one ASAP.

Adept III

UPDATE: I managed to install CS but it's not starting up obviously because there is no AMD drivers installed.

I will try installing 19.9.2. We bought this card last summer, i'll try to go as far as i can offered on AMD's page.

Adept III

Update : Installing 19.9.2 i managed to boot CS, but i got a BSOD and then the PC refused to start (BSOD on restart, video scheduler internal error again). I booted into safe mode to DDU the display driver and now i can reboot into the computer like nothing happened.

It seems like there is something stuck with the card like some memory corruption, i don't know. But it's stuck. Any time it tries to work with official AMD drivers it crashes to the point where it crashes the entire machine.

This is legit sabotage i don't know what else to call it.

Adept III



I just updated ASRock BIOS from 1.10 to 7.20 from here : ASRock > H110M-ITX 

I reinstalled windows and reinstalled updates, and reinstalled AMD's latest drivers.

I just got a BSOD trying to install counterstrike from steam : video_tdr_failure error code.

Can we expect newer drivers soon or should i start RMA with Sapphire? Card was purchased august 6th 2019 used in a single computer only with official amd drivers on a legit copy of windows.


I think you have to wait until 20.2.3 roll out.


thank you for your response.

when? do you have any clue?

i see previous driver release cycle was faster. this driver is getting old according to the average differences in between releases.


I think 1 month per update


been having the exact same issue with the RX 560X and the Vega 8, i found that staying at 20.2.2 is the only way to keep my computer from crashing or freezing. never buying AMD again, iv done system wipes, fresh updates, bios, windows features, new monitors everything, all started with adrenaline, i cant even use the default driver that came with the laptop from the factory, it has to be 20.2.2 or i keep getting freezes, adrenaline seems to damage the cards.

Adept III


New driver seems to mitigate some issues so far, like we're not having complete BSODs when trying the card, but trying rocketleague we can get in the menu but the game crashes when trying to get in game, same with CSGO.

We tried uninstalling CSGO after the crash, trying to uninstall the machine closed on it's own.

After a reboot we tried reinstalling and we get a steam error saying the map file for agency is corrupted. it's funny because when the game crashed it was trying to load agency. that probably means the uninstalled failed because probably the file was still being held by a process and the card not only crashes the computer but corrupts the files on the local machine?

this is a very uncomfortable experience so far.

i may be able to try with an rx 580 i'll let you know if i have further information.

Adept I

I don't know if this is going to help others to fix this issue but so far it's 2 days without any video_scheduler_internal_error BSOD

After 2 weeks with this problem in a brand new RIG, I hope I managed to fix it. And the issue was happening any time of the day without even playing or using anything. Was happening with the computer idle in the Desktop. I tried several driver versions among several other things and nothing work.


A couple of days ago I went to the BIOS and found that my 5700 XT was using 8x only instead of 16x even with the card installed in the first PCIe slot. Googling it and nothing came but when I read the manual carefully I find out a setting in there talking about the Hyper m.2 x16 Series Card Configuration showing the below.

Annotation 2020-04-04 144009.jpg

And guess what? It was enabled in my BIOS. After I disabled it, my card started showing as x16 and so far I did not have any video_scheduler_internal_error BSOD and hopefully will stay like that. Maybe it's too early to be sure but at least the issue isn't happening 5 times a day without even browse the internet and just sitting at my Desktop. The computer is now on for uninterrupted 48 hours and I even ran a few stress and stability tests using 3DMark with Fire Strike and Time Spy, Aida64 Extreme and Unigine Superposition. As I said, zero BSODs so far.

What I think it was causing the problem (assuming it's completely fixed now) was the BIOS set the GPU at 8x and not at x16. Regardless of the cause for this, it's because of what I mentioned above or if you have the card in the 2dn slot which also in some cases causes the GPU to not be at x16 I think worth a shot to check and

Here is my build in case anyone wants to know.

CPU: Intel Core i7-9700K 3.6 GHz 8-Core

Motherboard: Asus ROG MAXIMUS XI HERO (WI-FI) Intel Z390

GPU: Sapphire Radeon RX 5700 XT 8 GB NITRO+ SE

Memory: G.Skill Trident Z RGB 32 GB (2 x 16 GB) DDR4-3200

Storage: Samsung 970 Evo Plus 500 GB M.2-2280 NVME

Storage: Samsung 970 EVO Plus 2 TB M.2-2280 NVME

Storage: Samsung 860 Evo 2 TB 2.5" SSD

Monitor: ASUS ROG Strix XG32VQ 31.5-Inch Screen LCD Monitor (XG32VQ)

Case: Cooler Master MasterCase SL600M ATX Mid Tower

Hope this helps


How can I fix this? Please explain more.


Check your BIOS Manual and see where you can see if your VGA is at 8x or 16x. In my BIOS I went to Tools and then GPU Graphics Information like the picture below. To fix you will have to either change your VGA to the first (top) slot of the motherboard or disabled anything that is preventing the GPU to run at it's native speed. In my case was the Hyper m.2 x16 Series Card Configuration that was enabled and should be disabled.
WhatsApp Image 2020-04-03 at 23.23.37.jpeg


I can't find Tool/GPU. I use mainboard tuf gaming x570-plus. Please help me. I already search GPU and find nothing.


Maybe search for Graphic or VGA? Hard for me to tell you since my BIOS is a bit different than yours

Journeyman III

I've not had the pleasure of a game yet. My Sapphire Pulse Radeon RX 5700 XT 8 GB is causing crashes, the usual stuff, BSOD, etc.. Why can't AMD fix this?  Any fix ideas here?


Have you tried the above?