Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

RX 570 Windows 10 Driver Nightmare

I'm pulling my hair out having spent the last 48 hours trying everything I could find online to solve my issues - I throw myself at the mercy of this knowledgeable community to return my sanity to me.


Windows 10 Home (completely updated)

Gigabyte EX58-UD3R v1.0 Mobo Award BIOS F11

Intel i7 920 2.67 Ghz

3x4GB DDR3 Vengeance 1600 Hz

Silicon Power 1 TB SSD

Corsair 650W Power Supply

The system was stable as a rock with the old graphics card.  I removed my old graphics card and put in ColorPower Red Dragon RX570 (VBIOS Version: and during the installation of the 19.5.1 Adrenalin software, the signal to the monitor dropped and didn't come back.  The computer kept running (confirmed with log files after) but I couldn't see anything.  When I reboot, the monitor loses signal during the boot (first for a second and then 2 seconds later, for good).

The only thing that has given any variability in result is installing different AMD software (all installs done by booting to safe mode, uninstalling device and driver, running DDU, rebooting with internet cable removed and installing from AMD software).  While 19.4.1 gives the same result, 18.5.1 and 18.2.2 fail with a VIDEO_TDR_FAILURE BSOD during bootup.  17.11.1 has been the best so far, allowing me to boot, but then crashing with the same VIDEO_TDR_FAILURE BSOD when I do certain things in the system (e.g. plugging my iPhone into the USB drive for iTunes causes it).

Other things I've tried that have had no bearing on behavior:

  • Windows clean install
  • Tdr delay registry setting (tried values of both 0 and 8)
  • Playing with the Hz of the DRAM
  • With 17.11.1 installed, I changed WattMan settings to add 50 to the power (which was met with the system automatically reverting the setting due to an error)
  • Disabled Fast Startup in Windows
  • Enabled/Disabled XMP in BIOS
  • Rolled back chipset drivers to original manufacturer's versions
  • Attaching other monitors
  • Using HDMI and DVI cables
  • Disabled Windows automatic driver updates

I'm open to try anything - to me it points strongly to a software/driver issue - just can't figure it out. 


6 Replies

Well I can tell you this...I have the I7 960 and tried installing Win10 a couple of years ago. Nothing went right. Microsoft informed me my motherboard/processor was not officially supported and to not be surprised if issues arose.

I have to agree with Kingfish here. I would see if by chance there is a newer bios update for your motherboard you can load. If not I bet you have a hardware incompatibility with this new card.


You have a very old motherboard as far as motherboard's go. At Gigabyte there are no Windows 10 drivers for your Motherboard. Only Windows 2000 and Windows 7 or earlier versions. GA-EX58-UD3R (rev. 1.0/1.1) | Motherboard - GIGABYTE U.S.A. 

That being said. There are two BETA BIOS update after BIOS version F11. They are :

F12Q (03/11/11)

F12i (08/02/2010)

But since the BIOS is BETA you will be installing it at your risk. Make sure you have a copy of your current BIOS F11 in case something goes wrong.

The last Chip set is from 04/29/2010.

As mentioned in previous comments, Its likely your Motherboard hardware may not be compatible with latest AMD Drivers for Windows 10.  It would not be worth installing Windows 7 since it will not be supported any more by Microsoft in January 20 2010.

Adept I

Thanks fellows. 

Is there anyone out here that has had success getting the RX 570 to run stably on an older Mobo that could suggest what they did so I could try?

Journeyman III

Yeah i too had a similar experience. everything was fine with my i5 2500 + msi p67agd55 + gtx 760 rig until i decided to upgrade my gpu to rx580. after installing the gpu only i realized that something is seriously wrong. i was not getting any display out put. first i thought i had a bad gpu until i tried it in a newer rig. unfortunately i couldn't solve the issue and i ended up buying new cpu + mobo + ram. Switched from intel + nvidea to all amd setup.

Adept III

I'm using a Gigabyte GA-Z68XP-UD3 rev 1.0 (BIOS F-10) and currently running Win 10 1809 build 17763.529 without issues. I'd get in touch with Gigabyte and verify with them as to whether or not the board will work under Win10.