cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

steve6540
Journeyman III

RX 570 Error 43 - Cannot Install New Drivers

Hello,

I recently purchased a used RX 570 from a friend of mine. When I installed it, initially I got error code 43. I tried downloading the most recent drivers off the AMD site, but when I go to run the installer my computer BSODs with "MACHINE CHECK EXCEPTION" as the error. Using DDU and removing both AMD and Nvidia drivers didn't help. 

I read that  atikmdag-patcher-1.4.8.zip could help with some of this issues, so I downloaded it. I ran DDU in safemode, removed my Nvidia drivers, removed my AMD drivers and ran it. I no longer have error 43 and can use my two monitors properly. But, I still cannot install the most recent drivers. I get the same problem as before; my computer crashes as the installer loads (after the animation and sound). Right now I'm using the ones that came on the CD (2017).

In atikmdag-patcher-1.4.8.zip, it finds all of the fields except "SL-DVI limit on DL-DVI"

I tried ignoring this and going on with the old drivers, but when I tried to run a game (COD Warzone), it crashes with error code "COD WARZONE: FATAL ERROR 0X00000001411700A0 7544987 0XC000001D - amdxc64.dll". This seems to indicate a problem with the drivers... that I can't install because it crashes xD

Sorry for no photos, I'm away from the computer in question until Friday. Thank you in advance for any help!

0 Likes
4 Replies
kon33
Adept I

Re: RX 570 Error 43 - Cannot Install New Drivers

stay with the stable drivers . ive heard that these latest have caused problem . 

0 Likes
steve6540
Journeyman III

Re: RX 570 Error 43 - Cannot Install New Drivers

I think these drivers are what is causing my problem, though.

0 Likes
elstaci
MVP

Re: RX 570 Error 43 - Cannot Install New Drivers

Need to post your computer information like Windows version, Make & Model of your CPU, Motherboard, PSU, RAM, etc. Also UEFI/BIOS Version installed for your motherboard.

If a laptop, then you need to post the exact Make & Model of your laptop or Serial number.

steve6540
Journeyman III

Re: RX 570 Error 43 - Cannot Install New Drivers

So, to anyone else who searches Google and finds this, I'm going to list what I did (as I remember it) in order to give someone else a starting point.

This issue very likely had to do with the old drivers being incompatible with the game. In order to get my game going again, I had to:

1) In safe mode, use DDU to uninstall both my old nVidia drivers and AMD drivers.
2) Run the DISM and SFC commands in CMD.
3) Delete the players folder.
4) Delete the C:\AMD folder.
5) Repair MW within Battle.net
6) Download the most recent drivers, unzip them, but don't run the setup. If you crash here with Clock_Watchdog_Timeout or if you try looking for hardware changes within device manager... for some odd reason, this is caused by a DVD drive being plugged into the wrong SATA port (3Gb vs 6Gb ports). I just unplugged mine in order to get this to work for now. I think this is what was stopping the AMD installer from running.
7) Point the now generic display device to the folder when you unzipped the drivers. They should install.
😎 Restart. Once you load back up in non-safe mode, run the AMD ATI Pixel Clock Patcher. If you cannot find all limits, make sure you have the most up to date drivers and/or Pixel Clock Patcher.
9) Apply it and restart.

Good luck to anyone who finds this and hope it helps.

0 Likes