cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

ripto
Journeyman III

RX 570 8GB GPU Load 100% - Returns to Normal Only After Launching Adrenalin Software

Hello all.  I recently installed a RX 570 8GB card into my system as an upgrade to an Nvidia GTS 250 1GB.  This is my first AMD graphics card.  Install went fine, it wouldn't output to my DVI monitor for some reason but a DVI-HDMI adapter fixed that.

I am having the dreaded 100% GPU load issue as I see a lot of AMD users are experiencing.  I am running the 20.11.2 Radeon Adrenalin software/drivers.  Seems different from Nvidia as there is software that accompanies this but I'm assuming the 20.11.2 is the driver number.

Starting my computer up, the GPU fans are off as it's only running at about 22*C and the load ranges from 0 to 10 or so, but whenever I really do anything (internet, games) the GPU load pegs to 100% and will not come back down, even after a restart one time.  This obviously increases the temp and causes the fans to kick in.  Worried about long term wear.

I looked for services I've seen people mention killing but I didn't have them (eg. ReLive Host I believe was one, I have a service running but it wasn't any mentioned, and killing it did not affect anything good or bad).  The thing I found that seemed to fix it was opening up the Radeon Adrenalin software.  As soon as it opened, the GPU load returned to normal and acted normal thereafter.  I repeated this 2-3 times.  I believe I exited the software and it still functioned properly.  I literally did nothing in the program, just had to launch it.

Is this software something that has to be running in the background?  As stated, new to AMD and didn't have any software with my old Nvidia card.  Is there a way to get this software to startup on Windows launch?  I don't see any options in it besides the notification in the system tray.  Is there something I should be doing for this problem?  Are there older drivers that may work on the AMD site?

Thanks.

Specs:

Asus Z87-Plus Motherboard, Intel i5-4670 CPU, 8GB DDR3 1600MHz G.Skill RAM, Windows 7 64-bit

0 Likes
2 Replies
quickmaq
Journeyman III

Im experiencing same issue with my Gigabyte RX 570 8GB OC after an update my GPU load spike to 100% then after a minute my screen will turn into black. I already reformatted my Windows. 

My specs B450M, R7 2700, 16GB RAM, RX 570 8GB, 650W Bronze

0 Likes
crenshaw1979
Adept I

Try this.

DDU removes all Intel, AMD and NVidia drivers from your setup, reboot your PC and install JUST your AMD graphics driver w/o all the extra and see if it works.  Then if you are good, then add all the extra stuff back by install the Adrenalin later, if you think you need it.

Util. to remove all AMD graphics drivers from your setup:
https://www.guru3d.com/files-get/display-driver-uninstaller-download,19.html

0 Likes