cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

psfbl
Journeyman III
Journeyman III

rx 5600xt green screen crash

Hi guys
A couple of days ago i finished building my new pc. (first time building one)
Everything seemed to work fine until i started getting constant green screen crashes.
The computer is currently unusable as anytime i try to run anything id get the green screen. (sometimes it crashes after booting the system).

CPU: Amd Ryzen 7 3700x
Motherboard: MSI B450 Tomahawk max
Motherboard BIOS Version: 7C02v39
RAM: Crucial Ballastix ddr4 - 3600 mhz 2 x 8 ram
OS: Windows 10 Pro 64x bit
OS Version: 20H2 
GPU: Asus dual rx5600xt TOP
GPU Driver Version: the most recent one
PSU: Seasonic Core gm- 650 W 80plus gold

 

0 Kudos
7 Replies
RPX100
Challenger
Challenger

Re: rx 5600xt green screen crash

Hey there @psfbl.
I am sorry to hear that you are having trouble with your PC.

You mentioned that this is the first time you have build a PC yourself,
so the following steps are aimed towards helping you to understand what to look for.

Did you update (flash) the current BIOS version yourself or was this BIOS already installed on the Mainboard?
It is recommended to clear CMOS after changing the installed BIOS version.
If you are able to enter the BIOS, then you can also choose "[F6] Load/Restore Default Values"

Also please note: the BIOS version you are using was released mainly to add Ryzen 5000 support.
I am not sure if these are still best BIOS options for Ryzen 3000.

Either way, I suggest to enter your BIOS and try to run these settings:
Make sure to check each setting and then save & exit with [F10]

MSI click BIOS 5 settings:
- PBO (Precision Boost Overdrive) -> [enabled]

- Global C-State Control -> [enabled]
- Power Supply Idle Control -> [low current idle]
- CPPC -> [enabled]
- CPPC preferred cores -> [enabled]
- SMT -> [enabled]

- XMP -> [enabled]
- DRAM frequency -> [DDR4-3600] (see XMP profile for reference)
- FCLK -> [1800 MHz]
- UCLK -> [1800 MHz] (or select UCLK = FCLK | 1:1)
- DRAM voltage -> [1.35v] (see XMP profile for reference)

- CPU multi -> [Auto]
- CPU core voltage -> [Auto]
- SoC voltage -> [Auto]

- PCIe_E1 gen -> [Gen3] (your GPU sockets PCIe 3.0 standard)

---
These settings are focused on optimizing your CPU and RAM
and how the windows OS is interacting with your CPU.

-> make sure to go an check if your Windows Power Plan is set to "Ryzen Balanced"
If you don't see any Ryzen Power Plans, then you need to reinstall your AMD chipset drivers.

Also make sure to use "recommended" GPU driver for your card and leave
the settings within Radeon Software on "Standard" profile.

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 21.1.1 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.0 | RAM: 2x 16GB 3600-CL16 | SSD: 2x 2TB NVMe ]
psfbl
Journeyman III
Journeyman III

Re: rx 5600xt green screen crash

thanks for the reply.

i tried the settings but nothing has really changed.

The system gots a green screen and crashed the moment i turned it on.

i checked the energy settings using safe mode and it was on am ryzen balanced by default. 

I also already had the settings on standard for the graphics driver. i used the recommended one from the asus support page.

so far no change.

 

0 Kudos
RPX100
Challenger
Challenger

Re: rx 5600xt green screen crash

Please have a look at the Windows Reliability Monitor and Event Log.

Then post all error messages and error codes here.

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 21.1.1 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.0 | RAM: 2x 16GB 3600-CL16 | SSD: 2x 2TB NVMe ]
0 Kudos
psfbl
Journeyman III
Journeyman III

Re: rx 5600xt green screen crash

i went and checked on reliability monitor and only found that windows was not orderly shut down on the times it crashed. (pardon my english my system is in german)

on event viewer i saw event id: 41 Kernel-Power also on times it crashed.

0 Kudos
RPX100
Challenger
Challenger

Re: rx 5600xt green screen crash

event id 41 : Kernel Power
https://www.mynewsdesk.com/de/minitool/pressreleases/2020-6-loesungen-zur-behebung-des-fehlers-kerne... (german)

1) Your crashes might be related to wrong windows 10 power plan settings
-> Energiesparplan ändern -> Erweiterte Einstellungen ändern
-> "PCI Express" -> Verbindungszustand Energieeinstellungen -> "Aus" (deactivate it)
-> also have a look at the link to the german guide regarding this kernel event 41

or 2) some driver is not working as intended and is causing the crashes.
-> try to reinstall the GPU (clean reinstall)
-> use Display Driver Uninstaller (Download from Guru3D) 
-> run DDU as Administrator in Windows Safe Mode (Abgesicherter Modus)
-> this will uninstall the current AMD Radeon GPU driver
-> download the current recommended driver for your card and install that after DDU is done
-> look on AMDs driver support page, maybe the one from ASUS is causing trouble
-> don't forget to restart the PC between uninstall and fresh install of the driver

3) Are there any problematic devices showing up in device manager (Geräte Manager)?

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 21.1.1 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.0 | RAM: 2x 16GB 3600-CL16 | SSD: 2x 2TB NVMe ]
0 Kudos
psfbl
Journeyman III
Journeyman III

Re: rx 5600xt green screen crash

so i used DDU (standard settings) to wipe the driver.

everything was working fine without the driver installed

then i went and dl and installed the recommended AMD driver for the card. The crashes start happening again.

also no problems with any device according to device manager.

 

0 Kudos
RPX100
Challenger
Challenger

Re: rx 5600xt green screen crash

Here is some detailed info from user @mackbolan777 from another post.
I have added some more info into his solution for making it clear what to do.
This was the solution that fixed my crashing problems on my own RX 5700 XT.

 

The full "solution" is:

1)  use DisplayDriverUninstaller (DDU) first in "windows safe mode" (important)
how to start your PC in safe mode in windows (support.microsoft.com)
- either disconnect your internet or use DDU to block windows update (temporarily)
- there is a checkbox in DDU to block the updates, or just pull your LAN cable out for the moment
-> it is important to prevent Windows Updates from installing the "best driver"
-> if you do not block Windows Updates, it might mess up your driver already at this point

2) then after the uninstall is done and your PC has been restarted install driver 20.8.3
- this seems to be the most stable for 5000 series (community feedback)
- I have been using 20.9.1 and 20.11.2 myself and it works for me
- (which were the recommended WHQL drivers for 5700 XT over the last months)

3) Then for a bonus and a bit more stability, go into the "performance", "tuning" area. (Radeon Software)
- Click on "automatic", "undervolt GPU" and write that number down. (the mV number)
- Switch to "manual" and enter that lower number into the "max" voltage area
-> located under the "advanced controls", "fine tuning".

4) Then navigate to the power limit (and enable control) and set that to max. (slider all the way to the right)
- This allows the GPU to take more juice as needed, if it needs more than the undervolt.
- Think of it as a "reserve".
- The GPU doesn't tap that power limiter until it's used up the max voltage set under "fine tuning"
- and then only takes what it needs, not all of it.

5) last step should be to optimize your fan curve
- increase it as far as it needs to: manual testing required or go for 100% RPM
- adjust fan curve until your card stays below 85°C junction temp (under gaming loads)
- your cards core, VRM and memory temps should stay around 60-65°C


These 5000 cards come out running far more voltage than needed.
Undervolting them will result in more stable clocks and better temps.

 

As I said: this solution is from user @mackbolan777 and I added some details to it.
If you follow this step by step and do the uninstall correctly, then it should fix the crashes.
I have tested this for the RX 5700 XT myself and it fixed my problems.

---

If all that does not help and you still get Kernel Event Error 41,
then you should try different power plan settings, like mentioned here:
https://community.amd.com/t5/drivers-software/solution-for-green-screen-crash-reboot-with-radeon-rx-... 

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 21.1.1 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.0 | RAM: 2x 16GB 3600-CL16 | SSD: 2x 2TB NVMe ]
0 Kudos