Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

RX 550 No AMD Graphic Driver is Installed or AMD Driver is not functioning properly.

Hello guys, so i recently bought a used RX 550 from my local community, and I installed it with latest graphic driver 18.9.3 but my computer displayed error code 43 in device manager.

I downloaded GPU-Z and it read my graphic card. But my graphic card won't work. And Also when I installed older driver the message change from "No AMD Graphic Driver Installed" to "Radeon Setting Currently unavailable. Please Try again after connecting AMD graphics." I've already browsed the forum and try Uninstall with DDU and clean install several times but nothing changed. I already updated the bios to the latest version but nothing happened too. I also found a tip that deleting driver version in registry editor would make change but it doesn't work in my computer. I'm so frustrated please help me out. Thank You.

My Setup

Motherboard  : ASUS H61M-C

Processor      : Intel G850 2.9 GHz

RAM               : 4GB

Graphic Card : Sapphire RX 550 GDDR5 4GB

PSU               : Corsair VS450

OS                  : Windows 7 Ultimate SP1 64bit

PS : I'm using HDMI to VGA converter because I don't have monitor that support HDMI

5 Replies
Journeyman III

Try with 18.5.2 driver, then use atikmdag patcher then restart your pc.

Gonna try that out later, 18.5.2? is that catalyst? if im not mistaken hopes on the roof xD

Adept II

Idk what is going on anymore same problem for thousands and hundreds of people using rx550 4gb no matter what made they all got the same problems from no signal monitors to undetectable gpus to lock resolutions at 800x640. Eversince that update from windows it somehow affects every versions of their windows including the old ones that had been finalized with the updates.

(take this comment with grain of salt as its personal/anecdotal experience)

I checked and  the RX550 has no power connector, but one possible cause (possible) could  be slipped out PCI E cable, somewhat, I've had that and I tried to install, remove, reinstall drivers with or without DDU with and without safe installation. Could be cause by the vibration of cars, trucks, train, tram etc over time(even if the cable and PSU is coupled), so checking PCI E cable for others who have this issue can be one step of troubleshooting


This time however I got it, I checked the AMD Software and driver compability and I installed the freshest driver with the auto driver downloader, and it was gone , so I guess i was lucky? RX 560 here

Good for you, I tried everything if you believe me, if I remove the rx550 on slot the pc work fantastic lmao and with good resolution thanks to windows 10 22h2 built in display driver but when I use the rx550 it boots but in 800x640 resolution. I tried disabling the default windows display driver while the rx550 is inserted and installs the driver of amd (i always use ddu for proper way of removing driver on safeboot) still every when the display driver of amd pops up on the device manager the monitor beeps an ejecting sound then inserting sound again (wherein in most default cases the display driver of amd should take over but second beep ejecting then NO SIGNAL) I'm tired this is my first time having this kind of issue ever since I tried amd gpu and ever since that faithful update by windows. -_-