Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

RX 480 keeps crashing every day at least once after the new Adrenaline 2019

Since the first Adrenaline 2019 update in decembre my RX 480 crashes at least once a day (system hang and needs to force restart manually) 

my friend has an Rx 480 too and he's experiencing the same things 


I5 6600K

RX 480 8gb Gaming X

Corsair 600w

Msi 170 Tomahawk

16 gb DDR4

4 Replies

As you see, using the most uptodate driver is not always the best idea.

Although some  games like Siege  nag about the need it's not necessary.

So, my point is, if it ain't broke.. don't fix it unless you see something in the release notes that applies to your card/situation.. which is highly unlikely for the 480.

just sayin'

And if cleaning the new driver with DDU and installing one you know worked doesn't fix it, take a look at windows updates in that period. You may also have a restore point to simplify this.

ASUS TUF X570 wifi, AMD Ryzen 5 5600G, ASUS ROG STRIX RX580 8G Gaming, Antec Truepower new 700w. 16GB
Adept I

I'm having the same problem with my computer with the RX480 card. Mine is happening when my tv is hooked up as a second monitor. Been having this issue ever since the 18.12.2 drivers. My wifes computer, which is basically the same, has no problems.


AMD seems to be having a plethora of issues when multiple monitors are installed and especially TV's. I don't know why but this has been going on long while and seems to be getting worse based on reports here, not better. 

If you have not tried this I would suggest unplugging the TV and doing a clean install of the driver with the internet disabled. Then once running good plug the TV back in. If it has issues try disabling HDCP. 

If that doesn't help you can try and regress to a driver you know that worked in the past. 

Make sure to report this issue to AMD for every driver they release that does not fix things:  

Online Service Request | AMD 


I just tried that last night and same thing happened. I have created a online service ticket. I doubt that will do anything, but it's a try.