cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

raxyk
Adept I

RX 480 Crashing repeatedly

Describe your system:

  • Graphics Card
    • MSI RADEON RX 480 8G
  • OS
    • Windows 10 64bit
  • Drivers
    • 19.3.1 (but happened at earlier versions too)
  • Monitor
    • Don't know the exact model, it's a Samsung1080p @60HZ HDMI
  • Motherboard
    • Gigabyte H61MA-D2V
  • CPU
    • Intel Core i5 3330 3.00 GHZ
  • Power Supply
    • EVGA W1 500W 80 Plus
  • RAM
    • Kingston ValueRam DDR3 1333 PC3-10600 4GB CL9 (x3 making a total of 12)

 

I had this card up and running for almost 2 years IIRC. It gave me no problems at all, running Witcher 3 and other kind of pretty demanding games with ease. The problem begun when I tried Divinity 2: Original Sin. In some scenarios when the screen is filled with fire and fog effects, after some flicking and slowing of the image, the screen goes black and I have to force a shutdown on the PC so I can restart. The audio keeps playing tho. I can bypass that problem by setting the graphics to the lowest (although the auto detection suggests everything to max) and alt+tabing when I expect a big load of graphical FX to be displayed. 

The most recent issue is with DQXI. When I get to a cutscene that seems to be demanding some kind of graphical load, with foggy FX and some stones falling and whatsoever, the crash happens again. And now, it crashes even if I alt+tab at the cutscene. I have the graphics on the minimum settings, although the recommended ones suggest something inbetween medium and high, but the crash keeps happening.

I have tried some tweaks I found over this forum from users having some kind of similar problems, with no effect. (Underclocking to 1800, setting Wattman settings to manual and undervolting here and there, etc). My Windows has been fully reinstalled quite a few times since I noticed this problem (the Divinity thing started happening like a year ago or so). In Afterburner I can't seem to notice any anomaly right before the crash. It just seems that at some points of intense graphic FX, the card can't hold the charge. I don't know what can I do to try and fix this. Other games, like for example Shadows of Mordor or DS3 don't get the crash, although they seem pretty much more demanding games, so I'd like some advice. 

Thanks in advance for your time! 

 

1 Solution
raxyk
Adept I

I'll do a clean installation once again and try all the latest suggestions (stable driver, custom fan curve, tuning down the memory etc) and will report back with the results. Thank you all for the time you're taking to help me out, really apreciate it guys, you rock!  

View solution in original post

0 Likes
15 Replies

I read this "AMD Radeon RX 480 - On your average system the card requires you to have a 450 Watt power supply unit as minimum" , Then Maybe can be your PSU (500W + other peripherals), but I said Maybe...

0 Likes

Hi andre, thanks for your answer.

Is there any way I can test this to see if that's indeed the problem? 

Test with only : cpu, 1 memory slot, 1 hdd/ssd

This if you have many peripherals ... with the app HWmonitor you can see all Watt drying from CPU,  RAM and GPU but not from HDD / SSD

(my gpu and cpu/memory Watt consumption, attach)

0 Likes

I downloaded the software but the problem I'm having is that I can't see if there's a W peak when it crashes, is there any similar software that allows me to see those values while in game?

0 Likes

HWmonitor can produce log with the curves stored in file.

0 Likes
kingfish
Volunteer Moderator

Have you raised the power limit in Wattman? Please read > https://community.amd.com/thread/195150 

I do it through Afterburner, it's already set to +50 (the max available)

0 Likes
kingfish
Volunteer Moderator

All third party graphics controllers can conflict with AMD and Wattman settings and controls. Afterburner, Trixx, Asus, etc, etc.

Try deleting Afterburner (not disable) from your computer. This will remove the registry changes Afterburner creates. Then clean install the AMD driver of your choice.

Raise the power limit in the game profile to +50.  AMD graphics performance 

Poor performance in World of Warships - Radeon 17.6.2 & RX 480 

https://community.amd.com/thread/215258 

Will be trying this later to check it out. 

Still happening  

Disable Fast Startup

Remove Afterburner

Run DDU from safe mode with Internet disconnected. 

reinstall driver with clean install while disconnected still. 

If you didn't do all that you won't fix your issues.

If you did or did not do that do it then do the following:

Set your power limit to 50 in Wattman, not a 3rd party tweaker like Afterburner. (if you choose to return to afterburner later after being stable that's on you but return Wattman to defaults before doing that) You don't need Afterburner though. All those settings can be done without conflict right in Wattman. 

Now next it sounds like you are thermal throttling. My RX 580 and most peoples do this under very demanding games. A custom fan curve should help but will make your fan a bit louder. You can save profiles and use these settings per game if you like not globally. 

Do not follow the following picture for GPU speed setting as these are from my card. I wan't you to set a fan curve similar to this though and see if that does not help your situation. Report back if it doesn't and we can figure it out from there. 

sirwalrusthe3rd
Adept I

I kinda had a similar problem with msi rx570 8gb the best I could do was install latest divers(From AMD). Disconnect internet (I unplugged ethernet cable) do this because if you have windows 10 it will automatically install drivers. After that I used AMD Cleanup utility safe mode then install the drivers you installed out of safe mode.

I still get the flickers every now and then but never the black screen.

Also when I would get the black screen and disconnect from display; I found for me if I hit CTRL+ALT+DEL would reboot it back on weirdly enough.

up to you if you want to try this. This was just my way.

taru
Adept II

Hello,

If you are experiencing with the latest drivers, then try for the 18.9.3 stable driver

https://www.amd.com/en/support/kb/release-notes/rn-rad-win-18-9-3

And reduce the clock frequency to 100 or 200mhz of the GPU by using the wattman

https://www.amd.com/en/support/kb/faq/dh-020

raxyk
Adept I

I'll do a clean installation once again and try all the latest suggestions (stable driver, custom fan curve, tuning down the memory etc) and will report back with the results. Thank you all for the time you're taking to help me out, really apreciate it guys, you rock!  

0 Likes
raxyk
Adept I

It seems to have stopped for now, I'll be checking further these days and will report if it happens again. Thanks everyone!