Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

RX 460 will only work with driver 16.7.3

I have a MSI RX 460 LP 2gb card that has issues with any driver but 16.7.3. Updating to any newer driver causes the screen to repeatedly flicker, go to a grey fuzzy screen or sometimes give a green tint, and eventually go black. This can be temporarily remedied by unplugging the HDMI cable and plugging it back in. Usually within 30 seconds it starts to spaz again.

Initially I installed this card using the latest graphic driver available from AMD at the time (19.5.2) and afterwards I've tried the following: 19.2.1, 19.1.1, and 17.11.1 - each give me the same problem. I also tried driver 18.7.1 available from the MSI product support page. I've changed every setting imaginable, but nothing works. The only driver that doesn't give me any problems is 16.7.3. I've reinstalled Windows 10 and even tried Windows 7 with the same results. Both the GPU and CPU maintained stable core temps with the GPU maxing at around 42-43 Celsius. Both the motherboard and graphics card have the latest bios available. All drivers for the motherboard are installed and Windows 10 compatible.

Here's the specs of what I'm running:
-Phenom X4 9600 Black

-A-Tech PC2-8500 1066mhz DDR2 8gb (4x 2gb)

-Asus M3A78-EM motherboard

-Corsair CX450 psu

-Crucial MX500 250gb ssd
-Windows 10 x64 latest build

-using our TV for the monitor via HDMI (LG 49" 4K 49UJ6300)

Yes, I know the hardware is old and outdated. Yes, I know there is better hardware out there that doesn't cost two mortgage payments. All of the parts for this computer were brand new and cost me very little. It serves its purpose as a nice streaming and light workload pc.

I've found zero leads on this problem anywhere else. While this card does OK with 16.7.3, there's no HDR or APP support. I should also mention the card is used, but was working fine in the other PC it was being used in (wasn't my PC so I don't know the specs - all I know is that it was a SFF HP with a 4th or 5th gen i5 I believe).

Any idea what the problem is? Could it be just an incompatibility with this older CPU and motherboard?

2 Replies
Adept III

Try updating chipset and bios and see if that does work.
For me i had instaler hang with outdated chipset and bios on 19.7.1 which was only recoverable by system restore...
Chipset and bios upgrade worked great for me.


Bios and chipset are both already updated to the latest version available. Installation doesn't hang up, just the screen problem.