Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Relive doesn't record game audio

In all seriousness, what's the point of using Relive when you don't have the ability to record gameplay sound. I got a RX580, a 2700x and an Asus rog strix B450-f, I do use the default realtek drivers included with my board. I got a headest (Hyper X Cloud) directly to the front audio panel and no matter what I tried, Relive won't record any game sounds (only mic). I tried a lot of stuff, but guess what, Relive will only record the hdmi sound (which is useless for me since I don't use a monitor with speakers nor I want to use one) and good luck removing the AMD Audio Bus driver, the option to opt out from it while installing a new driver doesn't exist anymore. Obviously there is no option to select the source via Relive (just the microphone) so yeah...

Is there any real solution at this point or I will have to use a third party recording software or even better, switch to team green? At least their stuff on my gaming laptop works. Been using AMD GPUs on my PCs since 2011 but this was a huge disappointment.

9 Replies
Adept I

I'll be honest, I've had issues with recording sound with my last two AMD cards. It worked well for a while with my 5700XT and the latest Radeon drivers, but there is a conflict with the drivers and Windows May creator's update. I finally got the Windows update, but still no sound in videos. I can record my microphone (or webcam sound), but no in-game sound. Very frustrating.

Meanwhile, my other PC has an old 1050ti with year old drivers, and it records like a dream. No hassle. Makes you wonder...

Adept I

I have it isolated to an issue with Realtek's HD drivers, Windows, and ReLive. After uninstalling Nahimic, Realtek HD (Using Driver Display Uninstaller), I was able to record sound using the generic Windows sound drivers. Unfortunately, the depth and quality of sound just isn't there with those generic drivers. I reinstalled the Realtek drivers, and again not able to record sound. Why isn't there an option to select an audio device inside ReLive other than the microphone (which I can get to record with any driver installed).


I have the same problem Bro!!! I'm using the Asus B360-F and Realtek Driver with Sonic Studio. Do u know if they fix the problem?

PS: My english is  not very good, sorry.


I have the same problem Brow. Do u fix that problem? I'm using ASUS B360-F M/B. And Realted Audio with Sonic Studio. Do u know if the AMD fix the problem? Where is the modders to help us?


PS: My english is not very good. Sorry.


go into sound settings and uncheck "apps have sole control over audio device" under exclusive mode

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
Journeyman III

Hey man!

I was having the exact same issue with my recordings for a couple months.
I managed to fix the issue recently.

Try this:

Go to Control Panel>Hardware and Sound>Manage Sound Devices
Once there, scroll down until you see your headset.
You should find you headset predefined as "Earphone". You need to change the predefinition to "Speakers".
Once this is done, press "Ok" and the problem should be fixed.

I honestly hope I could've helped you.
Good games for you Sir!

Check here the steps 

Journeyman III

Hope this helps.


the way i was able to get my Radeon Software recording app to record in-game sound.

Right Click the Speaker icon to bring up the options of:

Open Sound Settings, Open Volume Mixer, Spacial Sound, Sounds, Trouble Shooting

Select "Sounds" and a Sound Window Should appear.

Change tabs to Playback.

this is where you differ from me. for my fix i chose my headset and right clicked to make it the default device.

this worked for me i think because my headset overrides the speakers for sound but Radeon was only recording from Speakers which were the Default device, while my headset was active the speakers were muted. hence no audio.

again hope this helps.



I made an account just to comment because I found a fix that worked for me that no one else mentioned.
So hopefully this helps someone.

  1. Right-click your sound icon in the system tray
  2. Click "Sounds"
  3. Go to the playback tab.
  4. Right-click your headphones.
  5. Go to the Advanced tab.
  6. De-select "Allow applications to take exclusive control of this device".

I tried every other solution that I found online but this is the only thing that worked for me.

It's weird because as far as I know, that option has always been selected and there was never an issue. I don't know why anything changed but I guess that's just the way it is. 

Journeyman III

If you are using a razer headset and are using 7.1 Surround Sound switch the 7.1 off and it should work. (it worked for me)