cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

whip2-1
Journeyman III

Re: Dell's AMD Radeon R5 M420- radeon s/w no temperature & installs as Radeon HD 8500M

@dipak 

0 Likes
9 Replies
whip2-1
Journeyman III

Dell's AMD Radeon R5 M420- radeon s/w no temperature & installs as Radeon HD 8500M

 ticketno:[8201021866]

GPU-Z reports lesser specs on my current system, and on web lookup- as per their database certain specs should be a bit higher[DELL VOSTRO 15-3568]

 

Kindly enable proper specs by Driver or assist your OEM Dell with VBIOS so that they can validate & give to users- and I don't know why your latest driver installs it as Radeon HD 8500M & not as Radeon R5 M420 as installed by Dell's official driver (amd 2019)

 

But on all versions, GPU-Z is actually reporting lesser specs than what they had previously recorded.

Also Adrenalin 2020 software reports temperature as 0 C, whereas task manager & dell diagnostics show proper gpu temps.

Please escalate to Devs. Have already sent out 2 bug reports ( from ticket # you can see my mail id, bug reports have it too)

Dell a bit old driver, still decreased specsDell a bit old driver, still decreased specslatest AMD driver, HD 8500M not R5 M420- decreased specslatest AMD driver, HD 8500M not R5 M420- decreased specsEveryone can see proper temp except Radeon S/WEveryone can see proper temp except Radeon S/W

0 Likes
whip2-1
Journeyman III

Re: Dell's AMD Radeon R5 M420- radeon s/w no temperature & installs as Radeon HD 8500M

@sam-amd please inform dev team

0 Likes
dipak
Staff
Staff

Re: Dell's AMD Radeon R5 M420- radeon s/w no temperature & installs as Radeon HD 8500M

Thank you for reporting it. As it looks like a driver/software related issue, our support forums seem to be better place to report this issue. I'm moving it there.

Thanks.

0 Likes
whip2-1
Journeyman III

Re: Dell's AMD Radeon R5 M420- radeon s/w no temperature & installs as Radeon HD 8500M

@dipak putting on another board doesn't directly solve the problem. Only way to solve it is by telling the drivers team- and you are the person who can make that happen. Please...


 

0 Likes
dipak
Staff
Staff

Re: Dell's AMD Radeon R5 M420- radeon s/w no temperature & installs as Radeon HD 8500M

I'm adding @amdmatt who might be able to help you in this regard.

Hi @amdmatt , could you please help to report the issue to the appropriate team?

 

Thanks.

 

0 Likes
whip2-1
Journeyman III

Re: Dell's AMD Radeon R5 M420- radeon s/w no temperature & installs as Radeon HD 8500M

@amdmatt Help us please? say something if you see this. 

 

Its been 2 weeks, @dipak any other person or email you can send them?

0 Likes
kingfish
MVP

Re: Dell's AMD Radeon R5 M420- radeon s/w no temperature & installs as Radeon HD 8500M

AMD only offers generic drivers. That's what they mean by:

Important Note for Laptop and All-In-One (AIO) PCs 
AMD recommends OEM-provided drivers which are customized and validated for their system-specific features and optimizations.
If you experience issues using the Radeon™ Software Adrenalin Edition driver package downloaded from AMD.com, please install the OEM-provided drivers for full support and compatibility.

The latest AMD driver for your laptop >  https://www.amd.com/en/support/kb/release-notes/rn-rad-win-20-11-3

The 'read me shows what graphics card ..or SERIES of cards it supports:

Screenshot_5.pngYou have the correct driver with a generic name and no manufacturer specific optimizations. You want it to read R5 M420 download it from the manufacturer

kingfish
MVP

Re: Dell's AMD Radeon R5 M420- radeon s/w no temperature & installs as Radeon HD 8500M

I assume you have a integrated graphics chip? What is it...AMD or Intel. If intel it must be updated from Intel before installing any AMD driver. Did you see Intel graphics at the manufacturers support site.. ?

Do you have a AMD  APU? You don't update the graphics driver..you update the APU. That updates both the internal and the discrete card. It is the only driver you install.

0 Likes
kingfish
MVP

Re: Dell's AMD Radeon R5 M420- radeon s/w no temperature & installs as Radeon HD 8500M

The discrete card should show 0 activity at idle and normal surf the web stuff. Look in Device Manager...what has a yellow error mark on it?

0 Likes